OpenWrt Forum Archive

Topic: mwan3; multi-wan policy routing (general topic)

The content of this topic has been archived between 22 May 2013 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Adze wrote:
brick2008 wrote:

When use the following settings, I found Lan2's upload traffic is going wan1, anything wrong with my settings??

Everything looks perfectly fine. Can't tell you why you have this problem... If you browse to https://ipv4.wtfismyip.com/ from 192.168.1.207? Does it report the right ip address (from wan2)?

Yes,the shown is right(wan2's IP). and when I disconnect wan2, I can still access the Internet.(shown wan1's IP address).
after reconnect the wan2,shown wan2's IP again.
so how can I config  to make lan2 ONLY use wan2 ?

brick2008 wrote:
Adze wrote:
brick2008 wrote:

When use the following settings, I found Lan2's upload traffic is going wan1, anything wrong with my settings??

Everything looks perfectly fine. Can't tell you why you have this problem... If you browse to https://ipv4.wtfismyip.com/ from 192.168.1.207? Does it report the right ip address (from wan2)?

Yes,the shown is right(wan2's IP). and when I disconnect wan2, I can still access the Internet.(shown wan1's IP address).
after reconnect the wan2,shown wan2's IP again.
so how can I config  to make lan2 ONLY use wan2 ?

Use option last_resort: https://wiki.openwrt.org/doc/howto/mwan … figuration

If you have a traffic rule that matches a policy, but all the members (interfaces) for that policy are down, the exit strategy for that policy defaults to "unreachable". This is configurable with the last_resort option. Valid values are: blackhole, unreachable or default.


config policy 'wan2_only'
        list use_member 'wan2_m1_w1'
        option last_resort 'unreachable'

(Last edited by Adze on 18 Jan 2016, 14:49)

Is this message trigger by luci-mwan3?
daemon.err uhttpd[882]: uci: Entry not found

HI,
i have an issue with latest version of mwan3 (2.02). i have 2 internet connections, 1 3g connection with huawei qmi wwan, and a second internet connection adsl with pptp login.

3g connection is running correct, but pptp connection is allways offline in mwan3, but everything should ok - with older mwan3 (chaos calmer 15.05, mwan1.6-2 is everything ok. is it an configuration issue on my side - maybe someone can help me.

many thanks

troubleshooting data:

Software versions : 

OpenWrt - OpenWrt Designated Driver r48470
LuCI - git-16.023.59693-6123974

mwan3 - 2.0-2
mwan3-luci - 1.4-4

Output of "cat /etc/config/mwan3" : 

config rule 'mediasrv'
    option src_ip '192.168.1.6'
    option dest_port '80,443'
    option proto 'tcp'
    option sticky '0'
    option use_policy 'wan2_wan'

config rule 'w10chris'
    option src_ip '192.168.1.10'
    option dest_ip '0.0.0.0/0'
    option proto 'tcp'
    option sticky '0'
    option use_policy 'wan_wan2'

config rule 'youtube'
    option sticky '1'
    option ipset 'youtube'
    option dest_port '80,443'
    option proto 'tcp'
    option use_policy 'wan2_wan'

config rule 'https'
    option sticky '1'
    option dest_port '443'
    option proto 'tcp'
    option use_policy 'wan2_wan'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option proto 'all'
    option sticky '0'
    option use_policy 'wan2_wan'

config member 'wan_m1_w3'
    option metric '1'
    option weight '3'
    option interface 'pptp'

config member 'wan_m2_w3'
    option metric '2'
    option weight '3'
    option interface 'pptp'

config member 'wan2_m1_w2'
    option metric '1'
    option weight '2'
    option interface 'wwan'

config member 'wan2_m2_w2'
    option metric '2'
    option weight '2'
    option interface 'wwan'

config policy 'wan_only'
    list use_member 'wan_m1_w3'

config policy 'wan2_only'
    list use_member 'wan2_m1_w2'

config policy 'balanced'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
    list use_member 'wan_m2_w3'
    list use_member 'wan2_m1_w2'

config interface 'pptp'
    option enabled '1'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '3'
    list track_ip '8.8.8.8'
    list track_ip '8.8.4.4'
    list track_ip '208.67.222.222'
    list track_ip '208.67.220.220'

config interface 'wwan'
    option enabled '1'
    list track_ip '8.8.4.4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.222.222'
    list track_ip '208.67.220.220'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '3'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option dns '192.168.1.6'
    option ipaddr '192.168.1.254'

config globals 'globals'
    option ula_prefix 'fd2e:a3e9:ada2::/48'

config interface 'router_lan'
    option proto 'static'
    option ifname 'eth1'
    option ipaddr '10.0.0.1'
    option netmask '255.255.255.0'

config interface 'wwan'
    option proto 'dhcp'
    option ifname 'wwan0'
    option metric '20'

config interface 'pptp'
    option proto 'pptp'
    option server '10.0.0.138'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option metric '10'
    option mtu '1492'

config route
    option interface 'lan'
    option target '192.168.101.0/24'
    option netmask '255.255.255.0'
    option gateway '192.168.1.21'

Output of "ifconfig" : 

br-lan    Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fd2e:a3e9:ada2::1/60 Scope:Global
          inet6 addr: fe80::ba27:ebff:feda:3f64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17969 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31561 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1387942 (1.3 MiB)  TX bytes:42885481 (40.8 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:17976 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31567 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1391217 (1.3 MiB)  TX bytes:43141041 (41.1 MiB)

eth1      Link encap:Ethernet  HWaddr 00:71:00:FF:23:8D  
          inet addr:10.0.0.1  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::271:ff:feff:238d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:605 errors:0 dropped:0 overruns:0 frame:0
          TX packets:759 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:82845 (80.9 KiB)  TX bytes:89380 (87.2 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:72 errors:0 dropped:0 overruns:0 frame:0
          TX packets:72 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7190 (7.0 KiB)  TX bytes:7190 (7.0 KiB)

pptp-pptp Link encap:Point-to-Point Protocol  
          inet addr:62.46.45.32  P-t-P:188.22.247.254  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:88 errors:0 dropped:0 overruns:0 frame:0
          TX packets:389 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:33297 (32.5 KiB)  TX bytes:53086 (51.8 KiB)

wwan0     Link encap:Ethernet  HWaddr EE:58:8C:EA:41:BA  
          inet addr:178.112.196.103  Bcast:178.112.196.111  Mask:255.255.255.240
          inet6 addr: fe80::ec58:8cff:feea:41ba/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:31234 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17337 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:42164075 (40.2 MiB)  TX bytes:1507588 (1.4 MiB)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         188.22.247.254  0.0.0.0         UG    10     0        0 pptp-pptp
0.0.0.0         178.112.196.97  0.0.0.0         UG    20     0        0 wwan0
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth1
10.0.0.138      0.0.0.0         255.255.255.255 UH    0      0        0 eth1
178.112.196.96  0.0.0.0         255.255.255.240 U     20     0        0 wwan0
178.112.196.97  0.0.0.0         255.255.255.255 UH    20     0        0 wwan0
188.22.247.254  0.0.0.0         255.255.255.255 UH    0      0        0 pptp-pptp
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.101.0   192.168.1.21    255.255.255.0   UG    0      0        0 br-lan

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
1002:    from all iif wwan0 lookup main 
2002:    from all fwmark 0x200/0xff00 lookup 2 
2253:    from all fwmark 0xfd00/0xff00 blackhole
2254:    from all fwmark 0xfe00/0xff00 unreachable
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

2
default via 178.112.196.97 dev wwan0

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 6276 packets, 2720K bytes)
 pkts bytes target     prot opt in     out     source               destination         
48279   43M mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
 7141 3002K fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 1325 packets, 130K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 4818 packets, 2558K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 5459 2784K mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 1813 packets, 446K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 2238  506K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 6631 packets, 3004K bytes)
 pkts bytes target     prot opt in     out     source               destination         
17192 1250K QOS_MARK_wwan0  all  --  *      wwan0   0.0.0.0/0            0.0.0.0/0           [goto] 
  375 53364 QOS_MARK_pptp-pptp  all  --  *      pptp-pptp  0.0.0.0/0            0.0.0.0/0           [goto] 

Chain QOS_MARK_pptp-pptp (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  375 53364 CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff
  181 15018 QOS_RULES_pptp-pptp  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff

Chain QOS_MARK_wwan0 (1 references)
 pkts bytes target     prot opt in     out     source               destination         
17176 1249K CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff
  997 80594 QOS_RULES_wwan0  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff

Chain QOS_RULES_pptp-pptp (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    9   429 MARK       tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport dports 20,21,22,25,80,110,443,465,993,995 MARK xset 0x2/0xff
   37  2717 MARK       udp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport dports 53,123 MARK xset 0x1/0xff
  135 11872 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff MARK xset 0x3/0xff
  181 15018 CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff

Chain QOS_RULES_wwan0 (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  293 24544 MARK       tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport dports 20,21,22,25,80,110,443,465,993,995 MARK xset 0x2/0xff
  362 26094 MARK       udp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport dports 53,123 MARK xset 0x1/0xff
  341 29554 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff MARK xset 0x3/0xff
  963 77953 CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    4   208 TCPMSS     tcp  --  *      pptp-pptp  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain mwan3_connected (2 references)
 pkts bytes target     prot opt in     out     source               destination         
 4708 3377K MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected dst MARK or 0xff00

Chain mwan3_hook (2 references)
 pkts bytes target     prot opt in     out     source               destination         
50517   43M CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff00
 1555  156K mwan3_ifaces_in  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 1525  153K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 1136 93043 mwan3_ifaces_out  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  762 62198 mwan3_rules  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
50517   43M CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff00
 8354 3860K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xff00/0xff00

Chain mwan3_iface_in_wwan (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  wwan0  *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected src mark match 0x0/0xff00 /* default */ MARK or 0xff00
   30  3525 MARK       all  --  wwan0  *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wwan */ MARK xset 0x200/0xff00

Chain mwan3_iface_out_wwan (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  325 27136 MARK       all  --  *      *       178.112.196.103      0.0.0.0/0            mark match 0x0/0xff00 /* wwan */ MARK xset 0x200/0xff00

Chain mwan3_ifaces_in (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 1539  150K mwan3_iface_in_wwan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

Chain mwan3_ifaces_out (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 1130 91643 mwan3_iface_out_wwan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

Chain mwan3_policy_balanced (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wwan 2 2 */ MARK xset 0x200/0xff00

Chain mwan3_policy_wan2_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wwan 2 2 */ MARK xset 0x200/0xff00

Chain mwan3_policy_wan2_wan (4 references)
 pkts bytes target     prot opt in     out     source               destination         
  428 30910 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wwan 2 2 */ MARK xset 0x200/0xff00

Chain mwan3_policy_wan_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan_wan2 (1 references)
 pkts bytes target     prot opt in     out     source               destination         
   10   507 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wwan 2 2 */ MARK xset 0x200/0xff00

Chain mwan3_rule_https (1 references)
 pkts bytes target     prot opt in     out     source               destination         
   58  8374 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 MARK xset 0x200/0xff00
    1    83 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x200/0xff00 ! match-set mwan3_sticky_https src,src MARK and 0xffff00ff
    1    83 mwan3_policy_wan2_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
   58  8374 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 del-set mwan3_sticky_https src,src
   58  8374 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 add-set mwan3_sticky_https src,src

Chain mwan3_rule_youtube (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 MARK xset 0x200/0xff00
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x200/0xff00 ! match-set mwan3_sticky_youtube src,src MARK and 0xffff00ff
    0     0 mwan3_policy_wan2_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 del-set mwan3_sticky_youtube src,src
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 add-set mwan3_sticky_youtube src,src

Chain mwan3_rules (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    9   484 mwan3_policy_wan2_wan  tcp  --  *      *       192.168.1.6          0.0.0.0/0            multiport sports 0:65535 multiport dports 80,443 mark match 0x0/0xff00 /* mediasrv */
   10   507 mwan3_policy_wan_wan2  tcp  --  *      *       192.168.1.10         0.0.0.0/0            multiport sports 0:65535 multiport dports 0:65535 mark match 0x0/0xff00 /* w10chris */
   58  8374 mwan3_rule_https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443 mark match 0x0/0xff00 /* https */
  418 30343 mwan3_policy_wan2_wan  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* default_rule */

Hi tango38317,

tango38317 wrote:

HI,
i have an issue with latest version of mwan3 (2.02). i have 2 internet connections, 1 3g connection with huawei qmi wwan, and a second internet connection adsl with pptp login.

3g connection is running correct, but pptp connection is allways offline in mwan3, but everything should ok - with older mwan3 (chaos calmer 15.05, mwan1.6-2 is everything ok. is it an configuration issue on my side - maybe someone can help me.

Something is wrong indeed. Could you try the following please:

. /lib/functions/network.sh && network_get_gateway gateway pptp; echo $gateway

Do you get an ip address back?

HI Adze,

yes, i get back the Gateway from my pptp Connection.

. /lib/functions/network.sh && network_get_gateway gateway pptp; echo
$gateway
188.22.247.254


In Diagnostic i haft tried to ping the Default Gateway, this is ok,
ping -c 3 -W 2 -I pptp-pptp 188.22.247.254

PING 188.22.247.254 (188.22.247.254): 56 data bytes
64 bytes from 188.22.247.254: seq=0 ttl=64 time=12.272 ms
64 bytes from 188.22.247.254: seq=1 ttl=64 time=8.114 ms
64 bytes from 188.22.247.254: seq=2 ttl=64 time=9.303 ms

but ping tracking ip i have on all ip an timeout:
ping -c 3 -W 2 -I pptp-pptp 8.8.8.8

PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss


ping -c 3 -W 2 -I pptp-pptp 8.8.4.4

PING 8.8.4.4 (8.8.4.4): 56 data bytes

--- 8.8.4.4 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss


ping -c 3 -W 2 -I pptp-pptp 208.67.222.222

PING 208.67.222.222 (208.67.222.222): 56 data bytes

--- 208.67.222.222 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss


ping -c 3 -W 2 -I pptp-pptp 208.67.220.220

PING 208.67.220.220 (208.67.220.220): 56 data bytes

--- 208.67.220.220 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss

Hi tango38317,


If you stop mwan3, is it still not possible to ping the track_ip's over pptp interface? (if you fail to get a reply when mwan3 is not running, then it is not a mwan3 problem)
Could you try and see if mwan3 works ok if you temporary remove all current configuerd track_ip options and replace it with only 188.22.247.254?

(Last edited by Adze on 26 Jan 2016, 12:08)

Adze wrote:

Hi tango38317,


If you stop mwan3, is it still not possible to ping the track_ip's over pptp interface? (if you fail to get a reply when mwan3 is not running, then it is not a mwan3 problem)
Could you try and see if mwan3 works ok if you temporary remove all current configuerd track_ip options and replace it with only 188.22.247.254?


HI,

now i have reseted the device, and configured only pptp connection. tried ping and everything is ok - browsing and ping.
added pptp to mwan interface, disabled all oder interfaces > after adding i cannot browse and cannot ping any ip adress - expect gateway of pptp interface.

removed pptp from wman - and everything was ok.

troubleshooting info after adding pptp to mwan:

OpenWrt - OpenWrt Designated Driver r48470
LuCI - git-16.023.59693-6123974

mwan3 - 2.0-2
mwan3-luci - 1.4-4

Output of "cat /etc/config/mwan3" : 

config interface 'wan'
    list track_ip '8.8.4.4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.222.222'
    list track_ip '208.67.220.220'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    option enabled '0'

config member 'wan_m1_w3'
    option interface 'wan'
    option metric '1'
    option weight '3'

config member 'wan_m2_w3'
    option interface 'wan'
    option metric '2'
    option weight '3'

config member 'wan2_m1_w2'
    option interface 'wan2'
    option metric '1'
    option weight '2'

config member 'wan2_m2_w2'
    option interface 'wan2'
    option metric '2'
    option weight '2'

config policy 'wan_only'
    list use_member 'wan_m1_w3'

config policy 'wan2_only'
    list use_member 'wan2_m1_w2'

config policy 'balanced'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
    list use_member 'wan_m2_w3'
    list use_member 'wan2_m1_w2'

config rule 'https'
    option sticky '1'
    option dest_port '443'
    option proto 'tcp'
    option use_policy 'balanced'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option use_policy 'balanced'

config interface 'pptp'
    option enabled '1'
    list track_ip '8.8.8.8'
    list track_ip '8.8.4.4'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '3'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdef:67f1:8807::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.1.254'

config interface 'pptp'
    option proto 'pptp'
    option server '10.0.0.138'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option metric '10'

config interface 'router_lan'
    option proto 'static'
    option ifname 'eth1'
    option netmask '255.255.255.0'
    option ipaddr '10.0.0.1'

Output of "ifconfig" : 

br-lan    Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdef:67f1:8807::1/60 Scope:Global
          inet6 addr: fe80::ba27:ebff:feda:3f64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3589 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:539700 (527.0 KiB)  TX bytes:1552492 (1.4 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7253 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6582 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:920049 (898.4 KiB)  TX bytes:3281558 (3.1 MiB)

eth1      Link encap:Ethernet  HWaddr 00:71:00:FF:23:8D  
          inet addr:10.0.0.1  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::271:ff:feff:238d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2962 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2551 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:957558 (935.1 KiB)  TX bytes:518833 (506.6 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:250 errors:0 dropped:0 overruns:0 frame:0
          TX packets:250 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:18948 (18.5 KiB)  TX bytes:18948 (18.5 KiB)

pptp-pptp Link encap:Point-to-Point Protocol  
          inet addr:62.46.40.179  P-t-P:188.22.247.254  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:1742 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1924 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:815445 (796.3 KiB)  TX bytes:372822 (364.0 KiB)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         188.22.247.254  0.0.0.0         UG    10     0        0 pptp-pptp
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth1
10.0.0.138      0.0.0.0         255.255.255.255 UH    0      0        0 eth1
188.22.247.254  0.0.0.0         255.255.255.255 UH    0      0        0 pptp-pptp
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
2253:    from all fwmark 0xfd00/0xff00 blackhole
2254:    from all fwmark 0xfe00/0xff00 unreachable
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

No data found

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 621 packets, 51876 bytes)
 pkts bytes target     prot opt in     out     source               destination         
  956  140K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           
  794 69122 fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 365 packets, 33431 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 96 packets, 6977 bytes)
 pkts bytes target     prot opt in     out     source               destination         
  109  7617 mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 541 packets, 78012 bytes)
 pkts bytes target     prot opt in     out     source               destination         
  802  166K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 544 packets, 78515 bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 TCPMSS     tcp  --  *      eth1    0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
    0     0 TCPMSS     tcp  --  *      pptp-pptp  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain mwan3_connected (2 references)
 pkts bytes target     prot opt in     out     source               destination         
  235 37592 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected dst MARK or 0xff00

Chain mwan3_hook (2 references)
 pkts bytes target     prot opt in     out     source               destination         
 1758  306K CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff00
  446 33333 mwan3_ifaces_in  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  439 32918 mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  313 23034 mwan3_ifaces_out  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  295 21635 mwan3_rules  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 1758  306K CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff00
  491 61138 mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xff00/0xff00

Chain mwan3_ifaces_in (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mwan3_ifaces_out (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mwan3_policy_balanced (2 references)
 pkts bytes target     prot opt in     out     source               destination         
  256 18919 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan2_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan2_wan (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan_only (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_policy_wan_wan2 (0 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* unreachable */ MARK xset 0xfe00/0xff00

Chain mwan3_rule_https (1 references)
 pkts bytes target     prot opt in     out     source               destination         
   15  1205 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 del-set mwan3_sticky_https src,src
    0     0 SET        all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xfc00/0xfc00 add-set mwan3_sticky_https src,src

Chain mwan3_rules (1 references)
 pkts bytes target     prot opt in     out     source               destination         
   15  1205 mwan3_rule_https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443 mark match 0x0/0xff00 /* https */
  241 17714 mwan3_policy_balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* default_rule */

mwan troubleshooting data after removing pptp interface from mwan

OpenWrt - OpenWrt Designated Driver r48470
LuCI - git-16.023.59693-6123974

mwan3 - 2.0-2
mwan3-luci - 1.4-4

Output of "cat /etc/config/mwan3" : 

config interface 'wan'
    list track_ip '8.8.4.4'
    list track_ip '8.8.8.8'
    list track_ip '208.67.222.222'
    list track_ip '208.67.220.220'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    option enabled '0'

config member 'wan_m1_w3'
    option interface 'wan'
    option metric '1'
    option weight '3'

config member 'wan_m2_w3'
    option interface 'wan'
    option metric '2'
    option weight '3'

config member 'wan2_m1_w2'
    option interface 'wan2'
    option metric '1'
    option weight '2'

config member 'wan2_m2_w2'
    option interface 'wan2'
    option metric '2'
    option weight '2'

config policy 'wan_only'
    list use_member 'wan_m1_w3'

config policy 'wan2_only'
    list use_member 'wan2_m1_w2'

config policy 'balanced'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m1_w2'

config policy 'wan_wan2'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m2_w2'

config policy 'wan2_wan'
    list use_member 'wan_m2_w3'
    list use_member 'wan2_m1_w2'

config rule 'https'
    option sticky '1'
    option dest_port '443'
    option proto 'tcp'
    option use_policy 'balanced'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option use_policy 'balanced'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdef:67f1:8807::/48'

config interface 'lan'
    option type 'bridge'
    option ifname 'eth0'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.1.254'

config interface 'pptp'
    option proto 'pptp'
    option server '10.0.0.138'
    USERNAME HIDDEN
    PASSWORD HIDDEN
    option metric '10'

config interface 'router_lan'
    option proto 'static'
    option ifname 'eth1'
    option netmask '255.255.255.0'
    option ipaddr '10.0.0.1'

Output of "ifconfig" : 

br-lan    Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          inet addr:192.168.1.254  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fdef:67f1:8807::1/60 Scope:Global
          inet6 addr: fe80::ba27:ebff:feda:3f64/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:6015 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6034 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:835506 (815.9 KiB)  TX bytes:2546656 (2.4 MiB)

eth0      Link encap:Ethernet  HWaddr B8:27:EB:DA:3F:64  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:9872 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9088 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1244672 (1.1 MiB)  TX bytes:4301834 (4.1 MiB)

eth1      Link encap:Ethernet  HWaddr 00:71:00:FF:23:8D  
          inet addr:10.0.0.1  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::271:ff:feff:238d/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4613 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3799 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1562617 (1.4 MiB)  TX bytes:734612 (717.3 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:370 errors:0 dropped:0 overruns:0 frame:0
          TX packets:370 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:26868 (26.2 KiB)  TX bytes:26868 (26.2 KiB)

pptp-pptp Link encap:Point-to-Point Protocol  
          inet addr:62.46.40.179  P-t-P:188.22.247.254  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2588 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2805 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1339801 (1.2 MiB)  TX bytes:516389 (504.2 KiB)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         188.22.247.254  0.0.0.0         UG    10     0        0 pptp-pptp
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth1
10.0.0.138      0.0.0.0         255.255.255.255 UH    0      0        0 eth1
188.22.247.254  0.0.0.0         255.255.255.255 UH    0      0        0 pptp-pptp
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 br-lan

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

No data found

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 4240 packets, 1369K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 5514 1480K fwmark     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 2705 packets, 728K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 1501 packets, 640K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 1659  652K mssfix     all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain OUTPUT (policy ACCEPT 2676 packets, 539K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain POSTROUTING (policy ACCEPT 4175 packets, 1178K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain fwmark (1 references)
 pkts bytes target     prot opt in     out     source               destination         

Chain mssfix (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 TCPMSS     tcp  --  *      eth1    0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
   34  1852 TCPMSS     tcp  --  *      pptp-pptp  0.0.0.0/0            0.0.0.0/0            tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Hi tango38317,


I think i know what is wrong, just to be sure:

Could you post me the output of "mwan3 status" please?

Could you test it without any track_ip configured and with adding the following rules to your mwan3 config (place them above any other rules):

config rule 'test_rule1'
    option dest_ip '62.46.40.179'
    option use_policy 'default'

config rule 'test_rule2'
    option dest_ip '188.22.247.254'
    option use_policy 'default'
Adze wrote:

Hi tango38317,


I think i know what is wrong, just to be sure:

Could you post me the output of "mwan3 status" please?

Could you test it without any track_ip configured and with adding the following rules to your mwan3 config (place them above any other rules):

config rule 'test_rule1'
    option dest_ip '62.46.40.179'
    option use_policy 'default'

config rule 'test_rule2'
    option dest_ip '188.22.247.254'
    option use_policy 'default'

Hi Adze,

after adding pptp interface to mwan3 and adding the rules to mwan3 config i have following output of "mwan3 status":

mwan3 status
Interface status:
 interface pptp is online and tracking is not enabled

Current ipv4 policies:
balanced:
 unreachable

wan2_only:
 unreachable

wan2_wan:
 unreachable

wan_only:
 unreachable

wan_wan2:
 unreachable


Current ipv6 policies:
balanced:
 unreachable

wan2_only:
 unreachable

wan2_wan:
 unreachable

wan_only:
 unreachable

wan_wan2:
 unreachable


Directly connected ipv4 networks:
 127.255.255.255
 192.168.1.255
 10.0.0.138
 127.0.0.0/8
 188.22.247.254
 10.0.0.1
 62.47.135.30
 192.168.1.0/24
 192.168.1.254
 224.0.0.0/3
 10.0.0.0
 192.168.1.0
 10.0.0.255
 127.0.0.1
 127.0.0.0
 10.0.0.0/24

Directly connected ipv6 networks:
 fdef:67f1:8807::/64
 fe80::/64

Active ipv4 user rules:
    0     0 MARK       all  --  *      *       0.0.0.0/0            62.46.40.179
    0     0 MARK       all  --  *      *       0.0.0.0/0            188.22.247.254
   41  2088 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
  133 37517 - balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    0     0 - balanced  all      *      *       ::/0                 ::/0
mwan3 status
Interface status:
 interface pptp is online and tracking is not enabled

Current ipv4 policies:
balanced:
 unreachable

wan2_only:
 unreachable

wan2_wan:
 unreachable

wan_only:
 unreachable

wan_wan2:
 unreachable


Current ipv6 policies:
balanced:
 unreachable

wan2_only:
 unreachable

wan2_wan:
 unreachable

wan_only:
 unreachable

wan_wan2:
 unreachable


Directly connected ipv4 networks:
 127.255.255.255
 192.168.1.255
 10.0.0.138
 127.0.0.0/8
 188.22.247.254
 10.0.0.1
 62.47.135.30
 192.168.1.0/24
 192.168.1.254
 224.0.0.0/3
 10.0.0.0
 192.168.1.0
 10.0.0.255
 127.0.0.1
 127.0.0.0
 10.0.0.0/24

Directly connected ipv6 networks:
 fdef:67f1:8807::/64
 fe80::/64

Active ipv4 user rules:
    0     0 MARK       all  --  *      *       0.0.0.0/0            62.46.40.179
    0     0 MARK       all  --  *      *       0.0.0.0/0            188.22.247.254
   41  2088 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
  133 37517 - balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    0     0 - balanced  all      *      *       ::/0                 ::/0

Hi tango38317,


With your last try your config is wrong. It has no members and no policies configured for pptp interface. Try this config if you will please and start from there:

config interface 'pptp'
    option enabled '1'

config member 'pptp_m1_w3'
    option interface 'pptp'
    option metric '1'
    option weight '3'

config policy 'balanced'
    list use_member 'pptp_m1_w3'

config rule 'default_rule'
    option dest_ip '0.0.0.0/0'
    option use_policy 'balanced'

(Last edited by Adze on 27 Jan 2016, 20:06)

Adze wrote:

Hi tango38317,


With your last try your config is wrong. It has no members and no policies configured for pptp interface. Try this config if you will please and start from there:

Hi Adze,

sorry, was lost after reset in (brain)space... :-D

now i have added the pptp Interface to policies > Output of mwan3 Status:

mwan3 status
Interface status:
 interface pptp is unknown and tracking is not enabled
 interface ROUTER_LAN is unknown and tracking is not enabled

Current ipv4 policies:

Current ipv6 policies:

Directly connected ipv4 networks:

Directly connected ipv6 networks:

Active ipv4 user rules:

Active ipv6 user rules:

root@firewall:~# mwan3 status
Interface status:
 interface pptp is online and tracking is not enabled
 interface ROUTER_LAN is unknown and tracking is not enabled

Current ipv4 policies:
balanced:
 pptp (100%)

wan2_only:
 unreachable

wan2_wan:
 pptp (100%)

wan_only:
 pptp (100%)

wan_wan2:
 pptp (100%)


Current ipv6 policies:
balanced:
 unreachable

wan2_only:
 unreachable

wan2_wan:
 unreachable

wan_only:
 unreachable

wan_wan2:
 unreachable


Directly connected ipv4 networks:
 192.168.1.0/24
 10.0.0.0
 10.0.0.1
 10.0.0.0/24
 10.0.0.255
 224.0.0.0/3
 192.168.1.252
 62.46.43.72
 10.0.0.138
 188.22.247.254
 127.0.0.1
 192.168.1.255
 127.0.0.0
 127.0.0.0/8
 127.255.255.255
 192.168.1.0

Directly connected ipv6 networks:
 fe80::/64
 fdef:67f1:8807::/64

Active ipv4 user rules:
    0     0 MARK       all  --  *      *       0.0.0.0/0            62.46.40.179
    0     0 MARK       all  --  *      *       0.0.0.0/0            188.22.247.254
    0     0 S https  tcp  --  *      *       0.0.0.0/0            0.0.0.0/0            multiport sports 0:65535 multiport dports 443
    0     0 - balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0  

Active ipv6 user rules:
    0     0 S https  tcp      *      *       ::/0                 ::/0                 multiport sports 0:65535 multiport dports 443
    6  1688 - balanced  all      *      *       ::/0                 ::/0 

have also added your config and tried it:


mwan3 status
Interface status:
 interface pptp is online and tracking is not enabled

Current ipv4 policies:
balanced:
 pptp (100%)


Current ipv6 policies:
balanced:
 unreachable


Directly connected ipv4 networks:
 192.168.1.252
 127.0.0.1
 224.0.0.0/3
 192.168.1.255
 10.0.0.138
 10.0.0.0/24
 10.0.0.255
 188.22.247.254
 10.0.0.1
 192.168.1.0
 62.46.43.72
 127.0.0.0
 127.255.255.255
 10.0.0.0
 127.0.0.0/8
 192.168.1.0/24

Directly connected ipv6 networks:
 fdef:67f1:8807::/64
 fe80::/64

Active ipv4 user rules:
    0     0 - balanced  all  --  *      *       0.0.0.0/0            0.0.0.0/0  

Active ipv6 user rules:
    0     0 - balanced  all      *      *       ::/0                 ::/0  

Hi tango38317,

Well, the last output (with my config) seems 100% ok. Still not able to ping?

Hi Adze,

Output of:

 
ping -c 3 -W 2 -I pptp-pptp 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes

--- 8.8.8.8 ping statistics ---
3 packets transmitted, 0 packets received, 100% packet loss

ping Gateway:

ping -c 3 -W 2 -I pptp-pptp 188.22.247.254
PING 188.22.247.254 (188.22.247.254): 56 data bytes
64 bytes from 188.22.247.254: seq=0 ttl=64 time=7.710 ms
64 bytes from 188.22.247.254: seq=1 ttl=64 time=8.703 ms
64 bytes from 188.22.247.254: seq=2 ttl=64 time=7.800 MS

Ping after removing from WMAN3

ping -c 3 -W 2 -I pptp-pptp 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=59 time=17.782 ms
64 bytes from 8.8.8.8: seq=1 ttl=59 time=16.821 ms
64 bytes from 8.8.8.8: seq=2 ttl=59 time=17.952 ms

Hi tango38317,

Weird. Is there a possibility i could get access to your router and troubleshoot some more?

Hi Adze,

no Problem. How do you want to have access, and how to transfer informations?

thx.

Hi

After reading these latest posts I just remembered to update that I got exact same ping problems in mwan3 diagnostics page.

Ping replies are received only from my main wan gateway but not from VPN gateways.

From a PC I can ping both local IP address and gateway of one VPN connection and neither of the two on second VPN connection.

update:

replaced the latest version with 1.4-2 from github and the ping replies are now received from first VPN gateway. there must be some bugs in v2

(Last edited by anarchy99 on 30 Jan 2016, 12:46)

Hi Adze,

several month ago I use openwrt combine with modem from my ISP that still using phone connection trough ADSL
I can connect 2 wan account trough 1 port wan, but today my ISP upgraded the modem using fo and GPON ZTE f660 and I can't connect 2 wan connection or more, just 1 connection. If I add 2 wan connection, no one wan connection will connect on my router, I convert/add 1 wan port from LAN port and use hub before connect to my ISP GPON modem, but also can't connect anymore.
when I check the system log it says
kern.info kernel: [   74.740000] IPv6: eth0.2: IPv6 duplicate address fe80::6670:2ff:fe8e:e16c detected!
but I already turn off ipv6 feature on my router and my gpon and also my ISP give me just ipv4 connection
I'm confuse cz I can't use mwan if I just have 1 connection sad
anyone can give soution ??
Thanks for your reply

PS; sorry for my bad english

Hello thank you very much for the tutorial and script tool.

I have a WR740N with Barrie braker, I managed to create my own image with all requirements and after flash image, install mwan3 and luci-app-mwa3.

Currently I connect to a wireless network as a client-A WWAN, and create another wireless network as master AP Wireless-B

I wonder if you could connect to two wireless clients? 2 WWAN and balaced with mwan3

I would like to have 2 WWAN, connect to two WiFi networks as a client, and another one as wireless LAN AP

thanks for everything

kanzer wrote:

I would like to have 2 WWAN, connect to two WiFi networks as a client, and another one as wireless LAN AP

I would suspect that would require there to be two or three physical radios in your router but I'm not sure I haven't really worked with connecting to two different APs on the same radio and I suspect you'd need a radio just for the AP functionality.

for me, it works radio0 as client and AP, with different names ssid and passwort
check my current config
cat /etc/config/wireless

config wifi-device 'radio0'
    option type 'mac80211'
    option hwmode '11g'
    option path 'platform/ar933x_wmac'
    option htmode 'HT20'
    option disabled '0'
    option channel '1'
    option txpower '30'
    option country 'US'

config wifi-iface
    option network 'wwan'
    option ssid 'MyHouse'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid 'D4:70:F0:3C:A4:C0'
    option key 'mypasshouse'

config wifi-iface
    option device 'radio0'
    option mode 'ap'
    option ssid 'MyAProckstar'
    option network 'lan'
    option encryption 'psk-mixed'
    option key 'rockANDroll'

cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'
    option ula_prefix 'fdc3:83da:377d::/48'

config interface 'lan'
    option ifname 'eth0'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ip6assign '60'
    option ipaddr '192.168.20.1'

config interface 'wan'
    option ifname 'eth1'
    option proto 'dhcp'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 1 2 3 4'

config interface 'wwan'
    option proto 'dhcp'

I liked add one wifi-iface more with option mode 'sta'

example ADD

config wifi-iface
    option network 'wwan2'
    option ssid 'MyWORKSHOP'
    option encryption 'psk2'
    option device 'radio0'
    option mode 'sta'
    option bssid 'D4:70:F0:3C:C4:C0'
    option key 'mypassWORKSHOP'

and if possible balanced with mwan3

Thanks for all

What is the proper basic configuration for ipv6 and can you please update the wiki?

I have two upstream providers, CC and MB, and have just upgraded to mwan3 2.0-2.

When mwan3 is stopped, I can reach my ipv6 tracking addresses, when it is running, I can't ping them at all, and, of course, mwan3 shows ipv6 stuff as unreachable.  IPv4 works fine.

I'm scratching my head trying to figure out what's wrong...?

Is it something to do with the ip firewall rules or table?

root@g2s:/etc/config# ip -6 route list table 1
root@g2s:/etc/config# ip -6 route list table 2
root@g2s:/etc/config# ip -6 rule show
0:    from all lookup 128
1:    from all lookup local
2253:    from all fwmark 0xfd00/0xff00 blackhole
2254:    from all fwmark 0xfe00/0xff00 unreachable
32766:    from all lookup main
4200000000:    from 2601:645:4000:92ed::1/64 iif br-lan unreachable
4200000000:    from 2607:f598:b0b9:f600::1/64 iif br-lan unreachable
4200000001:    from all iif lo failed_policy
4200000009:    from all iif br-lan failed_policy
4200000010:    from all iif eth0.10 failed_policy
4200000010:    from all iif eth0.10 failed_policy
4200000011:    from all iif eth0.11 failed_policy
4200000011:    from all iif eth0.11 failed_policy
4200000028:    from all iif wlan1-1 failed_policy

Software versions : 

OpenWrt - OpenWrt Designated Driver r48648
LuCI - git-16.038.37696-9b5724d

mwan3 - 2.0-2
mwan3-luci - 1.4-4

Output of "cat /etc/config/mwan3" : 

config rule 'default_ipv4'
    option proto 'all'
    option family 'ipv4'
    option sticky '0'
    option use_policy 'wan_mb_wan_cc'

config rule 'default_ipv6'
        option proto 'all'
    option family 'ipv6'
        option sticky '0'
        option use_policy 'wan_mb_wan_cc'

config interface 'wan_cc'
    option enabled '1'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    list track_ip '8.8.4.4'
    list track_ip '8.8.8.8'
    list track_ip '75.75.75.75'
    list track_ip '75.75.76.76'
    list track_ip '2001:2031:0:4::d1aa:5bcb'
    list track_ip '2607:f8b0:4007:809::200e'

config interface 'wan_mb'
    option enabled '1'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'
    list track_ip '8.8.8.8'
    list track_ip '208.69.43.23'
    list track_ip '208.69.40.4'
    list track_ip '2607:f8b0:4007:809::200e'
    list track_ip '2a03:2880:2130:cf24:face:b00c::25de'

config member 'wan_cc_m1_w2'
    option interface 'wan_cc'
    option metric '1'
    option weight '2'

config member 'wan_cc_m2_w2'
    option interface 'wan_cc'
    option metric '2'
    option weight '2'

config member 'wan_mb_m1_w3'
    option interface 'wan_mb'
    option metric '1'
    option weight '3'

config member 'wan_mb_m2_w3'
    option interface 'wan_mb'
    option metric '2'
    option weight '3'

config policy 'wan_cc_only'
    list use_member 'wan_cc_m1_w2'

config policy 'wan_mb_only'
    list use_member 'wan_mb_m1_w3'

config policy 'balanced'
    list use_member 'wan_cc_m1_w2'
    list use_member 'wan_mb_m1_w3'

config policy 'wan_cc_wan_mb'
    list use_member 'wan_cc_m1_w2'
    list use_member 'wan_mb_m2_w3'

config policy 'wan_mb_wan_cc'
    list use_member 'wan_mb_m1_w3'
    list use_member 'wan_cc_m2_w2'

Output of "cat /etc/config/network" : 

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config globals 'globals'

config interface 'lan'
    option ifname 'eth1'
    option force_link '1'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.88.1'
    option ip6assign '64'

config switch
    option name 'switch0'
    option reset '1'
    option enable_vlan '1'
    option mirror_source_port '0'
    option mirror_monitor_port '0'

config switch_vlan
    option device 'switch0'
    option vlan '1'
    option ports '0 2 3 4 5'
    option vid '1'

config switch_vlan
    option device 'switch0'
    option vlan '2'
    option vid '2'

config interface 'guest'
    option _orig_ifname 'wlan1-1'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '192.168.89.1'
    option netmask '255.255.255.0'
    option broadcast '192.168.89.255'

config interface 'openvpn'
    option ifname 'tun0'
    option proto 'none'

config interface 'wan_cc'
    option proto 'dhcp'
    option ifname 'eth0.10'
    option metric '100'

config interface 'wan_cc6'
    option ifname 'eth0.10'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option metric '100'
    option reqprefix 'auto'

config interface 'wan_mb'
    option ifname 'eth0.11'
    option proto 'dhcp'
    option metric '110'

config interface 'wan_mb6'
    option ifname 'eth0.11'
    option proto 'dhcpv6'
    option reqaddress 'try'
    option metric '110'
    option reqprefix 'auto'

config switch_vlan
    option device 'switch0'
    option vlan '3'
    option ports '1t 6t'
    option vid '10'

config switch_vlan
    option device 'switch0'
    option vlan '4'
    option vid '11'
    option ports '1t 6t'

config route
    option interface 'wan_cc'
    option target '192.168.100.0'
    option netmask '255.255.255.0'

Output of "ifconfig" : 

br-lan    Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FE  
          inet addr:192.168.88.1  Bcast:192.168.88.255  Mask:255.255.255.0
          inet6 addr: fe80::32b5:c2ff:fe96:62fe/64 Scope:Link
          inet6 addr: 2601:645:4000:92ed::1/64 Scope:Global
          inet6 addr: 2607:f598:b0b9:f600::1/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:318796 errors:0 dropped:0 overruns:0 frame:0
          TX packets:267837 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:153945932 (146.8 MiB)  TX bytes:178018593 (169.7 MiB)

eth0      Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FF  
          inet6 addr: fe80::32b5:c2ff:fe96:62ff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:397308 errors:0 dropped:0 overruns:0 frame:0
          TX packets:293434 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:180246337 (171.8 MiB)  TX bytes:156697664 (149.4 MiB)
          Interrupt:4 

eth0.10   Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FF  
          inet addr:50.150.100.134  Bcast:50.150.101.255  Mask:255.255.254.0
          inet6 addr: 2001:558:6045:77:78a5:8dea:4200:ec3d/128 Scope:Global
          inet6 addr: fe80::32b5:c2ff:fe96:62ff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:243161 errors:0 dropped:0 overruns:0 frame:0
          TX packets:120143 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:98670404 (94.0 MiB)  TX bytes:67893048 (64.7 MiB)

eth0.11   Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FF  
          inet addr:199.230.11.153  Bcast:199.230.11.191  Mask:255.255.255.192
          inet6 addr: 2607:f598:b0b0:219::a072/128 Scope:Global
          inet6 addr: fe80::32b5:c2ff:fe96:62ff/64 Scope:Link
          inet6 addr: 2607:f598:b0b0:219:32b5:c2ff:fe96:62ff/64 Scope:Global
          inet6 addr: 2607:f598:b2e0:219:32b5:c2ff:fe96:62ff/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:154147 errors:0 dropped:0 overruns:0 frame:0
          TX packets:173283 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:74424389 (70.9 MiB)  TX bytes:87630024 (83.5 MiB)

eth1      Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FE  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:277759 errors:0 dropped:0 overruns:1 frame:0
          TX packets:1333999 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:154682038 (147.5 MiB)  TX bytes:1670220177 (1.5 GiB)
          Interrupt:5 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:793 errors:0 dropped:0 overruns:0 frame:0
          TX packets:793 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:91042 (88.9 KiB)  TX bytes:91042 (88.9 KiB)

wlan0     Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FC  
          inet6 addr: fe80::32b5:c2ff:fe96:62fc/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:18397 errors:0 dropped:0 overruns:0 frame:0
          TX packets:25310 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:2947493 (2.8 MiB)  TX bytes:6723780 (6.4 MiB)

wlan1     Link encap:Ethernet  HWaddr 30:B5:C2:96:62:FD  
          inet6 addr: fe80::32b5:c2ff:fe96:62fd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1186475 errors:0 dropped:0 overruns:0 frame:0
          TX packets:92509 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:1580955250 (1.4 GiB)  TX bytes:89327381 (85.1 MiB)

wlan1-1   Link encap:Ethernet  HWaddr 32:B5:C2:96:62:FD  
          inet addr:192.168.89.1  Bcast:192.168.89.255  Mask:255.255.255.0
          inet6 addr: fe80::30b5:c2ff:fe96:62fd/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:864 (864.0 B)

Output of "route -n" : 

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         50.150.100.1    0.0.0.0         UG    100    0        0 eth0.10
0.0.0.0         199.230.11.129  0.0.0.0         UG    110    0        0 eth0.11
50.150.100.0    0.0.0.0         255.255.254.0   U     100    0        0 eth0.10
50.150.100.1    0.0.0.0         255.255.255.255 UH    100    0        0 eth0.10
192.168.88.0    0.0.0.0         255.255.255.0   U     0      0        0 br-lan
192.168.89.0    0.0.0.0         255.255.255.0   U     0      0        0 wlan1-1
192.168.100.0   0.0.0.0         255.255.255.0   U     100    0        0 eth0.10
199.230.11.128  0.0.0.0         255.255.255.192 U     110    0        0 eth0.11
199.230.11.129  0.0.0.0         255.255.255.255 UH    110    0        0 eth0.11

Output of "ip rule show" : 

0:    from all lookup 128 
1:    from all lookup local 
1001:    from all iif eth0.10 lookup main 
1002:    from all iif eth0.11 lookup main 
2001:    from all fwmark 0x100/0xff00 lookup 1 
2002:    from all fwmark 0x200/0xff00 lookup 2 
2253:    from all fwmark 0xfd00/0xff00 blackhole
2254:    from all fwmark 0xfe00/0xff00 unreachable
32766:    from all lookup main 
32767:    from all lookup default

Output of "ip route list table 1-250" : 

1
default via 50.150.100.1 dev eth0.10 
2
default via 199.230.11.129 dev eth0.11

Firewall default output policy (must be ACCEPT) : 

ACCEPT

Output of "iptables -L -t mangle -v -n" : 

Chain PREROUTING (policy ACCEPT 26979 packets, 6093K bytes)
 pkts bytes target     prot opt in     out     source               destination         
27100 6107K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain INPUT (policy ACCEPT 4173 packets, 389K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain FORWARD (policy ACCEPT 22728 packets, 5677K bytes)
 pkts bytes target     prot opt in     out     source               destination         
  309 16924 TCPMSS     tcp  --  *      eth0.10  0.0.0.0/0            0.0.0.0/0            ID:66773300 tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU
  492 32817 TCPMSS     tcp  --  *      eth0.11  0.0.0.0/0            0.0.0.0/0            ID:66773300 tcp flags:0x06/0x02 /* wan (mtu_fix) */ TCPMSS clamp to PMTU

Chain OUTPUT (policy ACCEPT 3838 packets, 693K bytes)
 pkts bytes target     prot opt in     out     source               destination         
 3871  696K mwan3_hook  all  --  *      *       0.0.0.0/0            0.0.0.0/0           

Chain POSTROUTING (policy ACCEPT 26430 packets, 6363K bytes)
 pkts bytes target     prot opt in     out     source               destination         

Chain mwan3_connected (2 references)
 pkts bytes target     prot opt in     out     source               destination         
13572 4559K MARK       all  --  *      *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected dst MARK or 0xff00

Chain mwan3_hook (2 references)
 pkts bytes target     prot opt in     out     source               destination         
30971 6803K CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK restore mask 0xff00
 3601  266K mwan3_ifaces_in  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 2501  200K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 1519  117K mwan3_ifaces_out  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  507 38457 mwan3_rules  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
30971 6803K CONNMARK   all  --  *      *       0.0.0.0/0            0.0.0.0/0            CONNMARK save mask 0xff00
26015 5971K mwan3_connected  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match ! 0xff00/0xff00

Chain mwan3_iface_in_wan_cc (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  eth0.10 *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected src mark match 0x0/0xff00 /* default */ MARK or 0xff00
  614 36937 MARK       all  --  eth0.10 *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan_cc */ MARK xset 0x100/0xff00

Chain mwan3_iface_in_wan_mb (1 references)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 MARK       all  --  eth0.11 *       0.0.0.0/0            0.0.0.0/0            match-set mwan3_connected src mark match 0x0/0xff00 /* default */ MARK or 0xff00
  486 28499 MARK       all  --  eth0.11 *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00 /* wan_mb */ MARK xset 0x200/0xff00

Chain mwan3_iface_out_wan_cc (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  760 57071 MARK       all  --  *      *       50.150.100.134       0.0.0.0/0            mark match 0x0/0xff00 /* wan_cc */ MARK xset 0x100/0xff00

Chain mwan3_iface_out_wan_mb (1 references)
 pkts bytes target     prot opt in     out     source               destination         
  252 21168 MARK       all  --  *      *       199.230.11.153       0.0.0.0/0            mark match 0x0/0xff00 /* wan_mb */ MARK xset 0x200/0xff00

Chain mwan3_ifaces_in (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 3595  266K mwan3_iface_in_wan_cc  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
 2958  227K mwan3_iface_in_wan_mb  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

Chain mwan3_ifaces_out (1 references)
 pkts bytes target     prot opt in     out     source               destination         
 1516  117K mwan3_iface_out_wan_cc  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00
  747 58913 mwan3_iface_out_wan_mb  all  --  *      *       0.0.0.0/0            0.0.0.0/0            mark match 0x0/0xff00

I have issues with torrent traffic suddenly dropping speed after a few seconds of combined high speed download with 3 WANs. The peers suddenly just stop seeding after a few seconds, and it only happens in UDP based connection.

What I did is create a 2 default rule with TCP with no sticky and UDP with sticky for 3600 seconds and that fixed it.

pleasantone wrote:

What is the proper basic configuration for ipv6 and can you please update the wiki?

I have two upstream providers, CC and MB, and have just upgraded to mwan3 2.0-2.

When mwan3 is stopped, I can reach my ipv6 tracking addresses, when it is running, I can't ping them at all, and, of course, mwan3 shows ipv6 stuff as unreachable.  IPv4 works fine.

I'm scratching my head trying to figure out what's wrong...?

Is it something to do with the ip firewall rules or table?

I have the same problem and i think its due to mwan3 getting IPv6 gateway from lib / functions / network.sh. Mine is returning :: and when i try to ping it trough my IPv6 interface with ping6 -I wan_v6 ::, i get an access denied.

I think that's why mwan3 think the interface is down. mwan3 can't get a valid nexthop and can't ping it so it mark the link as down and drop (or reject, depending on your conf) the packets cause all IPv6 links are down.

My IPv6 works cause i use the default behavior wich is to use the default main routing table. But mwan3 still think the link is down.

Is there a way to get an mwan dev to look at the issue ?

Edit: Ticket created

https://dev.openwrt.org/ticket/21927
https://github.com/openwrt/packages/issues/2429

(Last edited by mrfrezee on 27 Feb 2016, 15:33)

Hi Adze, first thanks for developing mwan3.
I have installed it (1.6-2) on my TL-WR842ND which has two service providers: wan and wan2 each capable of 8Mbps. I am also in control of both of these providers (they also run openwrt). Network metric is set to 10 and 20 respectivelly, and mwan3 is working with both, I tested with ping on each interface, checking that I have two different public IPs (refreshing a http page) and also by unplugging (fail test).

The problem: Balancing policy (60%,40%) or my weightFair (50%,50%) only send traffic mostly to just one wan, the other remains underused, and I can only flow traffic up to 8Mbps instead of double - I've tested with bittorrent. I did check that yes, both wan members of balancing policies have the same mwan3 metric of 1 (although network metric is 10 and 20).

Here are my configurations:
http://imgur.com/a/9G5UR
Results of the traffic distribution are in the last two images, captured from inside my service providers.

mwan3 configuration file:
http://pastebin.com/raw/8hTeU5c1

TL-WR842ND
Thanks

(Last edited by marco_silva85 on 2 Mar 2016, 23:56)