OpenWrt Forum Archive

Topic: mwan3; multi-wan policy routing (general topic)

The content of this topic has been archived between 22 May 2013 and 6 May 2018. Unfortunately there are posts – most likely complete pages – missing.

Hi swoofz,

Could you paste me your complete open-vpn and network config please? Not just a snippet. Thnx!

Adze wrote:

Hi swoofz,

Could you paste me your complete open-vpn and network config please? Not just a snippet. Thnx!

Hi Adze,

Here's the complete configs :

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.1'
        option gateway '192.168.0.1'
        option stp '1'
        option metric '10'
        option ifname 'eth0'

config switch
        option name 'eth0'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'

config interface 'WAN'
        option proto 'dhcp'
        option ifname 'eth1'
        option metric '20'

config interface 'VPN'
        option proto 'none'
        option ifname 'tun0'
        option defaultroute '0'
        option peerdns '0'
        option auto '1'
        option metric '30'
root@OpenWrt:~# cat /etc/config/openvpn

config openvpn 'pia_tun'
        option nobind '1'
        option float '1'
        option client '1'
        option comp_lzo '1'
        option reneg_sec '0'
        option dev 'tun'
        option persist_tun '1'
        option persist_key '1'
        option remote_cert_tls 'server'
        option verb '1'
        option remote 'vpndomain.com'
        option proto 'udp'
        option ca '/lib/uci/upload/cbid.openvpn.client_tun.ca'
        option resolv_retry 'infinite'
        option tls_client '1'
        option auth_user_pass '/etc/openvpn/pwd.txt'
        option enabled '1'

Any idea what I might missed in the configs? Thanks

Hi swoofz,


Please remove the gateway option and the metric option from the lan interface in your network config.  Add the option "redirect-gateway def1" to your openvpn config. Reboot and try again please.


Thnx!

Adze wrote:

Hi swoofz,


Please remove the gateway option and the metric option from the lan interface in your network config.  Add the option "redirect-gateway def1" to your openvpn config. Reboot and try again please.


Thnx!

Hi Adze,
Tried to do what you asked, and using the same mwan3 config still I couldn't redirect the traffic from my PC to the VPN line.

Will try it again later.  Thanks.

I have a question, if I define some rules, and a session doesn't match any rules, does it go to some default rule?

If no rules are matched, traffic is not marked and handled by the default routing table. After the first packet leaves a wan interface it eventually does get marked. So in short the default routing table is used.

Dear Adze:

Thanks for your mwan3, but in my home, it seems has some problem.
I can only use one pppoe link, but I did dial up for 3 pppoe link.

Is this a same pppoe gateway problem? And how can I fix this?

please help.

/etc/config/mwan3 :

config interface 'wan'
    option enabled '1'
    list track_ip '61.139.2.69'
    option reliability '3'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'

config interface 'wan2'
    option enabled '1'
    list track_ip '8.8.8.8'
    list track_ip '208.67.220.220'
    option reliability '1'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'

config interface 'wan3'
    option enabled '1'
    list track_ip '61.139.2.69'
    option reliability '2'
    option count '1'
    option timeout '2'
    option interval '5'
    option down '3'
    option up '8'

config member 'wan_m1_w3'
    option metric '1'
    option weight '3'
    option interface 'wan'

config member 'wan_m2_w3'
    option metric '2'
    option weight '3'
    option interface 'wan'

config member 'wan2_m1_w2'
    option interface 'wan2'
    option metric '1'
    option weight '2'

config member 'wan2_m2_w2'
    option interface 'wan2'
    option metric '2'
    option weight '2'

config member 'wan3_m1_w1'
    option interface 'wan3'
    option metric '1'
    option weight '4'

config member 'wan3_m2_w1'
    option interface 'wan3'
    option metric '2'
    option weight '4'

config policy 'wan_only'
    list use_member 'wan_m1_w3'

config policy 'wan2_only'
    list use_member 'wan2_m1_w2'

config policy 'wan3_only'
    list use_member 'wan3_m1_w1'

config policy 'wan_wan2_wan3_loadbalanced'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m1_w2'
    list use_member 'wan3_m1_w1'

config policy 'wan_pri_wan2_sec'
    list use_member 'wan_m1_w3'
    list use_member 'wan2_m2_w2'

config policy 'wan2_pri_wan_sec'
    list use_member 'wan_m2_w3'
    list use_member 'wan2_m1_w2'

config rule
    option proto 'tcp'
    option use_policy 'wan2_only'
    option src_ip '192.168.47.0/24'
    option dest_port '17000'

config rule
    option proto 'tcp'
    option use_policy 'wan_only'
    option src_ip '192.168.47.10'
    option src_port '22'

config rule
    option dest_ip '0.0.0.0/0'
    option use_policy 'wan_wan2_loadbalanced'

config rule
    option dest_ip '77.11.41.0/24'
    option proto 'tcp'
    option dest_port '1024:65535'
    option use_policy 'wan_pri_wan2_sec'

config rule
    option dest_ip '112.136.0.0/16'
    option proto 'udp'
    option dest_port '5352'
    option use_policy 'wan2_pri_wan_sec'

ifconfig:

br-lan    Link encap:Ethernet  HWaddr 64:16:F0:08:39:05  
          inet addr:192.168.47.1  Bcast:192.168.47.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32018 errors:0 dropped:62 overruns:0 frame:0
          TX packets:36456 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:4421073 (4.2 MiB)  TX bytes:31287304 (29.8 MiB)

eth0      Link encap:Ethernet  HWaddr 64:16:F0:08:39:05  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:38558 errors:0 dropped:0 overruns:0 frame:0
          TX packets:33609 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:30960371 (29.5 MiB)  TX bytes:5263479 (5.0 MiB)
          Interrupt:14 

eth0.1    Link encap:Ethernet  HWaddr 64:16:F0:08:39:05  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2558 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2531 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:337239 (329.3 KiB)  TX bytes:579601 (566.0 KiB)

eth0.2    Link encap:Ethernet  HWaddr 00:27:19:98:07:3A  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:35764 errors:0 dropped:0 overruns:0 frame:0
          TX packets:30902 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:29916868 (28.5 MiB)  TX bytes:4542226 (4.3 MiB)

eth2      Link encap:Ethernet  HWaddr 00:27:19:98:EF:14  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1245 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1003 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:83946 (81.9 KiB)  TX bytes:30792 (30.0 KiB)

eth3      Link encap:Ethernet  HWaddr 00:27:19:72:13:B1  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1228 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1003 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:82808 (80.8 KiB)  TX bytes:30792 (30.0 KiB)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:274 errors:0 dropped:0 overruns:0 frame:0
          TX packets:274 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:19319 (18.8 KiB)  TX bytes:19319 (18.8 KiB)

pppoe-wan Link encap:Point-to-Point Protocol  
          inet addr:118.113.16.64  P-t-P:118.114.236.12  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:32479 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27888 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:29496161 (28.1 MiB)  TX bytes:3836106 (3.6 MiB)

pppoe-wan2 Link encap:Point-to-Point Protocol  
          inet addr:118.113.16.63  P-t-P:118.114.236.12  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:26 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:1066 (1.0 KiB)  TX bytes:54 (54.0 B)

pppoe-wan3 Link encap:Point-to-Point Protocol  
          inet addr:118.113.16.66  P-t-P:118.114.236.12  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:9 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:302 (302.0 B)  TX bytes:54 (54.0 B)

wlan0     Link encap:Ethernet  HWaddr 64:16:F0:08:39:06  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:29784 errors:0 dropped:0 overruns:0 frame:0
          TX packets:35194 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:4540296 (4.3 MiB)  TX bytes:31697600 (30.2 MiB)

ip rule list:

0:    from all lookup local 
1008:    from all fwmark 0x100/0xff00 lookup 1001 
1016:    from all fwmark 0x1000/0xff00 lookup 1016 
1017:    from all fwmark 0x1100/0xff00 lookup 1017 
1018:    from all fwmark 0x1200/0xff00 lookup 1018 
1019:    from all fwmark 0x1300/0xff00 lookup 1019 
1020:    from all fwmark 0x1400/0xff00 lookup 1020 
1021:    from all fwmark 0x1500/0xff00 lookup 1021 
32766:    from all lookup main 
32767:    from all lookup default 

ip route list table 1001

default via 118.114.236.12 dev pppoe-wan

/etc/config/firewall

config defaults
    option syn_flood '1'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'lan'
    option network 'lan'
    option input 'ACCEPT'
    option output 'ACCEPT'
    option forward 'REJECT'

config zone
    option name 'wan'
    option input 'REJECT'
    option output 'ACCEPT'
    option forward 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan WAN'

config forwarding
    option src 'lan'
    option dest 'wan'

config rule
    option name 'Allow-DHCP-Renew'
    option src 'wan'
    option proto 'udp'
    option dest_port '68'
    option target 'ACCEPT'
    option family 'ipv4'

config rule
    option name 'Allow-Ping'
    option src 'wan'
    option proto 'icmp'
    option icmp_type 'echo-request'
    option family 'ipv4'
    option target 'ACCEPT'

config rule
    option name 'Allow-DHCPv6'
    option src 'wan'
    option proto 'udp'
    option src_ip 'fe80::/10'
    option src_port '547'
    option dest_ip 'fe80::/10'
    option dest_port '546'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Input'
    option src 'wan'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    list icmp_type 'router-solicitation'
    list icmp_type 'neighbour-solicitation'
    list icmp_type 'router-advertisement'
    list icmp_type 'neighbour-advertisement'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Allow-ICMPv6-Forward'
    option src 'wan'
    option dest '*'
    option proto 'icmp'
    list icmp_type 'echo-request'
    list icmp_type 'echo-reply'
    list icmp_type 'destination-unreachable'
    list icmp_type 'packet-too-big'
    list icmp_type 'time-exceeded'
    list icmp_type 'bad-header'
    list icmp_type 'unknown-header-type'
    option limit '1000/sec'
    option family 'ipv6'
    option target 'ACCEPT'

config rule
    option name 'Enforce-ULA-Border-Src'
    option src '*'
    option dest 'wan'
    option proto 'all'
    option src_ip 'fc00::/7'
    option family 'ipv6'
    option target 'REJECT'

config rule
    option name 'Enforce-ULA-Border-Dest'
    option src '*'
    option dest 'wan'
    option proto 'all'
    option dest_ip 'fc00::/7'
    option family 'ipv6'
    option target 'REJECT'

config include
    option path '/etc/firewall.user'

config zone
    option forward 'REJECT'
    option output 'ACCEPT'
    option name 'wan2'
    option input 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan2'

config forwarding
    option dest 'wan2'
    option src 'lan'

config zone
    option forward 'REJECT'
    option output 'ACCEPT'
    option name 'wan3'
    option input 'REJECT'
    option masq '1'
    option mtu_fix '1'
    option network 'wan3'

config forwarding
    option dest 'wan3'
    option src 'lan'

Hi Adze, your package seems very useful, but I'd like to use it a bit more differently. I don't have more wan interfaces, but all ports bridged together. I want to solve the failover by changing default route and assigning the route via option dhcp, because openwrt does not route at all. Is this possible with your package?

Yet another question, I get "Cannot satisfy the following dependencies for mwan3" error:

root@wr1043nd:~# opkg --force-depends install http://213.136.13.52/mwan3_1.1-6_a
r71xx.ipk
Downloading http://213.136.13.52/mwan3_1.1-6_ar71xx.ipk.
Installing mwan3 (1.1-6) to root...
Installing ip (3.3.0-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/ip_3.3.0-1_ar71xx.ipk.
Installing iptables-mod-conntrack-extra (1.4.10-4) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/iptables-mod-conntrack-extra_1.4.10-4_ar71xx.ipk.
Installing kmod-ipt-conntrack-extra (3.3.8-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/kmod-ipt-conntrack-extra_3.3.8-1_ar71xx.ipk.
Installing iptables-mod-ipopt (1.4.10-4) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/iptables-mod-ipopt_1.4.10-4_ar71xx.ipk.
Installing kmod-ipt-ipopt (3.3.8-1) to root...
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09-rc1/ar71xx/generic/packages/kmod-ipt-ipopt_3.3.8-1_ar71xx.ipk.
Configuring ip.
Configuring kmod-ipt-conntrack-extra.
Configuring kmod-ipt-ipopt.
Configuring iptables-mod-ipopt.
Configuring iptables-mod-conntrack-extra.
Configuring mwan3.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for mwan3:
 *      kernel (= 3.3.8-1-5440da3a2c45184a32da6bba25b8dd2a) *   kernel (= 3.3.8-1-5440da3a2c45184a32da6bba25b8dd2a) *

How can I install it? I have AA r35631.

(Last edited by nozombian on 5 Mar 2013, 08:25)

Adze wrote:
thdyck wrote:

6. LUCI item: In the "Multiwan policy configuration" and "Multiwan rule configuration" LuCI pages, it would be nice to have the "Member used" and "Policy assigned" fields be drop-down lists to avoid typos.

WiP, but it's more Arfett's project.

I was wanting to make it that way but honestly I have no idea how to code that in. If anyone knows I would be ecstatic to know how to make it work and I'll update the files.

(Last edited by arfett on 26 Mar 2013, 01:30)

Hi,arfett,I have a 12MBit FTTB line and a 6Mbit adsl line.I want to combind their bandwidth but limit adsl's upload bandwidth to 512kbit.Is mwan3 capable of doing this?

(Last edited by axishero on 27 Mar 2013, 05:54)

axishero wrote:

Hi,arfett,I have a 12MBit FTTB line and a 6Mbit adsl line.I want to combind their bandwidth but limit adsl's upload bandwidth to 512kbit.Is mwan3 capable of doing this?

Yes with Quality Of Service limiting the bandwidth and mwan3 load balancing. There is a LuCI app for QOS. At least I assume this will work. Try it and report back smile

(Last edited by arfett on 27 Mar 2013, 19:41)

Dear all,

I am running Attitude Adjustment 12.09 with the latest LuCI Web interface + mwan3 on a D-Link router. I would need some inputs and therefore appreciate any hints. Here is what I am trying to do:

Existing situation:

  • Physical WAN interface of the router uses PPPoE to connect to the Internet

  • The LAN interface (bridge) of the router is the default gateway for LAN clients at $LAN_GW

  • A VPN tunnel interface is set up to run inside the PPPoE tunnel to connect to a VPN provider

As soon as the VPN tunnel connects, all traffic is routed via the VPN as it becomes the default gateway to the internet for all LAN clients. If the VPN is down, all traffic is routed over the standard ISP tunnel.


To-be situation:

I want to create an alias to $LAN_GW called $LAN_GW1 on the same LAN subnet.

  • LAN clients that have $LAN_GW as their gateway should be routed over the standard PPPoE ISP tunnel.

  • LAN clients that have $LAN_GW1 as their gateway should be rounted over the VPN tunnel.

  • If the VPN tunnel is down the traffic routed via $LAN_GW1 should be routed via the PPPoE ISP tunnel.

I have studied the documentation of the IP package (IProute2) and mwan3 and can only find exampes for source based routing or for load-sharing and availability-based WAN link selection. What I am trying to do is gateway based routing regardless of the source. My configuration should effectively create two default gatways each with its own internet uplink.

Can mwan3 support my use case? If not pease excuse the off topic post.

Many thanks
MES3

arfett wrote:
axishero wrote:

Hi,arfett,I have a 12MBit FTTB line and a 6Mbit adsl line.I want to combind their bandwidth but limit adsl's upload bandwidth to 512kbit.Is mwan3 capable of doing this?

Yes with Quality Of Service limiting the bandwidth and mwan3 load balancing. There is a LuCI app for QOS. At least I assume this will work. Try it and report back smile

Yes,but qos in openwrt can only limit the total sum of upload and download bandwidth.

axishero wrote:
arfett wrote:
axishero wrote:

Hi,arfett,I have a 12MBit FTTB line and a 6Mbit adsl line.I want to combind their bandwidth but limit adsl's upload bandwidth to 512kbit.Is mwan3 capable of doing this?

Yes with Quality Of Service limiting the bandwidth and mwan3 load balancing. There is a LuCI app for QOS. At least I assume this will work. Try it and report back smile

Yes,but qos in openwrt can only limit the total sum of upload and download bandwidth.

On a per interface basis. Just apply it to that single interface.

Hi Adze,

Thx for your work to mwan3. I use your script with 2 dsl lines and the equalizer option 1, both weigths are set to 3 but only one dsl line gets used.
There seems to be a bug in your script while calculationg the sum weights for the iptables rules.

while looking at the output of "iptables -t mangle -vL":

Chain mwan3_rules (1 references)
pkts bytes target     prot opt in     out     source               destination         
  528  283K MARK       all  --  any    any     anywhere             10.10.0.0/16         mark match 0x0/0xff00 MARK xset 0x8000/0xff00
  822 67451 MARK       all  --  any    any     anywhere             anywhere             mark match 0x0/0xff00 statistic mode random probability 0.50000000000 MARK xset 0x100/0xff00
  764 62624 MARK       all  --  any    any     anywhere             anywhere             mark match 0x0/0xff00 statistic mode random probability 0.99999999953 MARK xset 0x200/0xff00

I put some debug putput in the /etc/hotplug.d/iface/15-mwan and you calculate in function mwan3_update_policy_iptables_rules() the iftotalweight=$(($old_weight+$iftotalweight)), where for the first trigger of interface-1 ...iftotalweight=0 .. so it does not respect to total sum of weights ... and for the second call for interface-2 it uses the current sum weight.

It looks a bit complicated to me how you get the weights and the total weights.

What do you think ?

Bye Bluse

Hi Adze,

One more thing I explored while troubleshooting the equalizer problem is, in case you do a "/etc/init.d/mwan3 restart",
the former {mwan3track} /bin/sh /usr/sbin/mwan3track wan1 eth0.2 2 3 5 5 5 8 8.8.4.4 8.8.8.8 processes do not get stoped properly .. so you end up with more and more mwan3tracker processes when restarting your script.

Greetings Bluse

Hi Bluse-Blue,


Thank you for testing. Thanks for noticing the probability error. I can reproduce it myself here on my router. Will fix this soon!

As for multiple mwan3track instances, i found that this problem is introduced in some of the newer openwrt builds (i think it has to do with firewall3 package). There are some more serious issues with it, for instance when an interface comes back online after it has failed, mwan3track still fails at pinging the remote host. So a downed interface will never come back up on itself...

bugs bugs bugs...

As for now i advice you not to use mwan3track for the moment, until i have time to fix it.

Bluse-Blue wrote:

Hi Adze,

There seems to be a bug in your script while calculationg the sum weights for the iptables rules.

while looking at the output of "iptables -t mangle -vL":

Chain mwan3_rules (1 references)
pkts bytes target     prot opt in     out     source               destination         
  822 67451 MARK       all  --  any    any     anywhere             anywhere             mark match 0x0/0xff00 statistic mode random probability 0.50000000000 MARK xset 0x100/0xff00
  764 62624 MARK       all  --  any    any     anywhere             anywhere             mark match 0x0/0xff00 statistic mode random probability 0.99999999953 MARK xset 0x200/0xff00

It looks to me that the calculating the sum of weights is correct. First rule says that 50% of the time it should mark the flow with 0x100 and the rest of the times with 0x200. As it should (50-50) distribution. Why it doesn't load share on your setup is due to something else...

What strikes me is that iptables somehow mangles the probability value?!?

root@mercurius:~# iptables -I OUTPUT -p icmp -o br-lan -m statistic --mode random --probability 0.60000000000 -j DROP
root@mercurius:~# iptables -L OUTPUT -n -v
Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 DROP       icmp --  *      br-lan  0.0.0.0/0            0.0.0.0/0            statistic mode random probability 0.60000000009

root@mercurius:~# iptables -I OUTPUT -p icmp -o br-lan -m statistic --mode random --probability 1 -j DROP
root@mercurius:~# iptables -L OUTPUT -n -v
Chain OUTPUT (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination         
    0     0 DROP       icmp --  *      br-lan  0.0.0.0/0            0.0.0.0/0            statistic mode random probability 0.99999999953
Adze wrote:

As for now i advice you not to use mwan3track for the moment, until i have time to fix it.


Hi Adze,

What do you mean by that "do not use mwantrack" ?
Do I just need to skip the hosts to ping in the mwan3 config file to skip mwan3track ?

Bye Bluse

Bluse-Blue wrote:

What do you mean by that "do not use mwantrack" ?
Do I just need to skip the hosts to ping in the mwan3 config file to skip mwan3track ?

Remove all options under the interface config, except for enabled:

config 'interface' 'wan2'
    option 'enabled' '1'

Hi Atze,

I would like to contribute to your package.
What about setting up a GitHub repo to ease the developement process ?
Let me know if you would set up such a repo.


Bye Bluse

Hello i have a problem with the package, it won't start

it gives me the following errors:

root@Gargoyle:~# /etc/init.d/mwan3 restart
root@Gargoyle:~# uci: Entry not found
sh: wan: unknown operand
uci: Entry not found
sh: wan: unknown operand
uci: Entry not found
sh: wan3: unknown operand
uci: Entry not found
sh: wan2: unknown operand
uci: Entry not found
sh: wan2: unknown operand
ERROR: No valid dynamic DNS service configurations defined
(Did you specify correct configuration file path?)
uci: Entry not found
sh: wan3: unknown operand
uci: Entry not found
sh: wan3: unknown operand
uci: Entry not found
sh: wan3: unknown operand
uci: Entry not found
sh: wan2: unknown operand
uci: Entry not found
sh: wan2: unknown operand

mwan3 conf:

config 'interface' 'wan'
    option 'enabled' '1'
    list 'track_ip' '8.8.4.4'
    list 'track_ip' '8.8.8.8'
    list 'track_ip' '208.67.222.222'
    list 'track_ip' '208.67.220.220'
    option 'reliability' '3'
    option 'count' '1'
    option 'timeout' '5'
    option 'interval' '10'
    option 'down' '3'
    option 'up' '8'

config 'interface' 'wan2'
    option 'enabled' '1'
    list 'track_ip' '8.8.4.4'
    list 'track_ip' '8.8.8.8'
    list 'track_ip' '208.67.222.222'
    list 'track_ip' '208.67.220.220'
    option 'reliability' '1'
    option 'count' '1'
    option 'timeout' '5'
    option 'interval' '10'
    option 'down' '3'
    option 'up' '8'

config 'interface' 'wan3'
    option 'enabled' '1'
    list 'track_ip' '8.8.4.4'
    list 'track_ip' '8.8.8.8'
    list 'track_ip' '208.67.222.222'
    list 'track_ip' '208.67.220.220'
    option 'reliability' '1'
    option 'count' '1'
    option 'timeout' '5'
    option 'interval' '10'
    option 'down' '3'
    option 'up' '8'

config 'interface' 'wan4'
    option 'enabled' '1'
    list 'track_ip' '8.8.4.4'
    list 'track_ip' '8.8.8.8'
    list 'track_ip' '208.67.222.222'
    list 'track_ip' '208.67.220.220'
    option 'reliability' '1'
    option 'count' '1'
    option 'timeout' '5'
    option 'interval' '10'
    option 'down' '3'
    option 'up' '8'

config 'member' 'wan_m1_w2'
    option 'interface' 'wan'
    option 'metric' '1'
    option 'weight' '2'

config 'member' 'wan_m2_w2'
    option 'interface' 'wan'
    option 'metric' '2'
    option 'weight' '2'

config 'member' 'wan2_m1_w2'
    option 'interface' 'wan2'
    option 'metric' '1'
    option 'weight' '2'

config 'member' 'wan2_m2_w2'
    option 'interface' 'wan2'
    option 'metric' '2'
    option 'weight' '2'


config 'member' 'wan3_m1_w2'
    option 'interface' 'wan3'
    option 'metric' '1'
    option 'weight' '2'

config 'member' 'wan3_m2_w2'
    option 'interface' 'wan3'
    option 'metric' '2'
    option 'weight' '2'


config 'member' 'wan4_m1_w2'
    option 'interface' 'wan4'
    option 'metric' '1'
    option 'weight' '2'

config 'member' 'wan4_m2_w2'
    option 'interface' 'wan4'
    option 'metric' '2'
    option 'weight' '2'


config 'policy' 'wan1_only'
    list 'use_member' 'wan1_m1_w2'

config 'policy' 'wan2_only'
    list 'use_member' 'wan2_m1_w2'

config 'policy' 'wan3_only'
    list 'use_member' 'wan3_m1_w2'

config 'policy' 'wan4_only'
    list 'use_member' 'wan3_m1_w2'

config 'policy' 'wan1_wan2_wan3_wan4_loadbalanced'
    list 'use_member' 'wan1_m1_w2'
    list 'use_member' 'wan2_m1_w2'
    list 'use_member' 'wan3_m1_w2'
    list 'use_member' 'wan4_m1_w2'

config 'policy' 'wan1_pri_wan2_sec'
    list 'use_member' 'wan1_m1_w2'
    list 'use_member' 'wan2_m2_w2'

config 'policy' 'wan2_pri_wan1_sec'
    list 'use_member' 'wan1_m2_w2'
    list 'use_member' 'wan2_m1_w2'

config 'rule'
    option 'dest_ip' '192.168.0.0/16'
    option 'proto' 'tcp'
    option 'use_policy' 'default'

config 'rule'
    option 'dest_ip' '0.0.0.0/0'
    option 'equalize' '1'
    option 'use_policy' 'wan1_wan2_wan3_wan4_loadbalanced'

network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option dns '208.67.222.222 208.67.220.220'
        option ipaddr '192.168.2.1'

config interface 'wan'
        option dns '208.67.222.222 208.67.220.220'
        option peerdns '0'
        option auto '1'
        option proto '3g'
        option device '/dev/ttyUSB0'
        option apn 'darmowy'
        option service 'umts_only'
        option mobile_isp 'Polska - Aero2'
        option metric '10'

config switch
        option name 'rtl8366rb'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '1'
        option ports '1 2 3 4 5t'

config switch_vlan
        option device 'rtl8366rb'
        option vlan '2'
        option ports '0 5t'

config interface 'wan2'
        option dns '8.8.8.8'
        option peerdns '0'
        option auto '1'
        option proto '3g'
        option device '/dev/ttyUSB3'
        option apn 'darmowy'
        option service 'umts_only'
        option mobile_isp 'Polska - Aero2'
        option metric '20'

config interface 'wan3'
        option dns '208.67.222.220 208.67.220.222'
        option peerdns '0'
        option auto '1'
        option proto '3g'
        option device '/dev/ttyUSB6'
        option apn 'darmowy'
        option service 'umts_only'
        option mobile_isp 'Polska - Aero2'
        option metric '30'

config interface 'wan4'
        option ifname 'eth1'
        option proto 'dhcp'
        option peerdns '0'
        option dns '8.8.4.4'
        option metric '40'

ifconfig -a

root@Gargoyle:~# ifconfig -a
3g-wan    Link encap:Point-to-Point Protocol
          inet addr:93.154.141.132  P-t-P:10.64.64.66  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:993 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1137 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:92592 (90.4 KiB)  TX bytes:108802 (106.2 KiB)

3g-wan2   Link encap:Point-to-Point Protocol
          inet addr:78.30.111.180  P-t-P:10.64.64.65  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:2090 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:1317739 (1.2 MiB)  TX bytes:281933 (275.3 KiB)

3g-wan3   Link encap:Point-to-Point Protocol
          inet addr:78.30.83.85  P-t-P:10.64.64.64  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1500  Metric:1
          RX packets:3685 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3146 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:2510801 (2.3 MiB)  TX bytes:568333 (555.0 KiB)

br-lan    Link encap:Ethernet  HWaddr 64:70:02:39:36:C2
          inet addr:192.168.2.1  Bcast:192.168.2.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:569866 errors:0 dropped:0 overruns:0 frame:0
          TX packets:582393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:50335726 (48.0 MiB)  TX bytes:702970499 (670.4 MiB)

eth0      Link encap:Ethernet  HWaddr 64:70:02:39:36:C2
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:570651 errors:0 dropped:0 overruns:60167 frame:0
          TX packets:582528 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:60735055 (57.9 MiB)  TX bytes:705307814 (672.6 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 64:70:02:39:36:C2
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:570566 errors:0 dropped:0 overruns:0 frame:0
          TX packets:582527 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:50454992 (48.1 MiB)  TX bytes:702976663 (670.4 MiB)

imq0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          NOARP  MTU:16000  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:11000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

imq1      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          NOARP  MTU:16000  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:11000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:11606 errors:0 dropped:0 overruns:0 frame:0
          TX packets:11606 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:882494 (861.8 KiB)  TX bytes:882494 (861.8 KiB)

wlan0     Link encap:Ethernet  HWaddr 64:70:02:39:36:C2
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2394 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:32
          RX bytes:0 (0.0 B)  TX bytes:268909 (262.6 KiB)

wwan0     Link encap:Ethernet  HWaddr 02:50:F3:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wwan1     Link encap:Ethernet  HWaddr 02:50:F3:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

wwan2     Link encap:Ethernet  HWaddr 02:50:F3:00:00:00
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Bluse-Blue wrote:

What about setting up a GitHub repo to ease the developement process ?
Let me know if you would set up such a repo.

GitHub repo is up: https://github.com/Adze1502/mwan . svn repo will close down shortly. Please update your "feeds.conf.default" file with the line "src-git mwan git://github.com/Adze1502/mwan.git" and remove the old svn repo.

Hi murjak,

murjak wrote:

Hello i have a problem with the package, it won't start

I'd like to help you get this problem fixed. Is there any possibility i could get remote access to your router?

Thnx!

murjak wrote:

Hello i have a problem with the package, it won't start

it gives me the following errors:

root@Gargoyle:~# /etc/init.d/mwan3 restart

There is no restart function in that init script. Only a start which initializes "/usr/sbin/mwan3 mwan_apply" at the end of boot time.

Adze,
Perhaps a stop/restart could be introduced which also kills off any mwantrack processes?

stop() {

    # code to kill off mwan processes and revert changes

}

restart() {

    stop
    start

}

(Last edited by arfett on 11 Apr 2013, 17:09)

Sorry, posts 126 to 125 are missing from our archive.