Re: [Volunteer nedeed] I need someone with 3G-6200N

prasannaliy wrote:

http://wiki.openwrt.org/toh/edimax/3g-6200n has warning about versions after 33300.

In your version have you given a workaround?

It is upgraded to 3.6.

Workaround is documented here:
https://dev.openwrt.org/ticket/12125

Re: [Volunteer nedeed] I need someone with 3G-6200N

guenti, can you please repost the link for downloading your image? I get 404 from the dropbox link posted earlier.

Thank you,
Cip

Re: [Volunteer nedeed] I need someone with 3G-6200N

cipri4ph wrote:

guenti, can you please repost the link for downloading your image? I get 404 from the dropbox link posted earlier.

Thank you,
Cip

https://dl.dropbox.com/u/87161358/edima … pgrade.bin

Re: [Volunteer nedeed] I need someone with 3G-6200N

guenti, thank you for that image, it works great.

I've tried to compile my own image based on trunk, it compiles ok, it builds also the needed packages, but when I flash the router with my image it does not boot. With tcpdump I see sending BOOTP/DHCP packages. Even if I provide a DHCP/tftp server in the lan, it does not take it. I'm lost with this.

Do you have a url where you can put the packages build along with that image?
I'm asking because I want to mount a usb stick, load and run openvpn/quagga/bgpd on it, and the packages I've installed depend on the kernel, so instalation usually fails. Even if I compile my own kmod-tun for example, I see segfault at first ping thru the openvpn tunnel.


Thank you,
Cip

Re: [Volunteer nedeed] I need someone with 3G-6200N

cipri4ph wrote:

guenti, thank you for that image, it works great.

I've tried to compile my own image based on trunk, it compiles ok, it builds also the needed packages, but when I flash the router with my image it does not boot. With tcpdump I see sending BOOTP/DHCP packages. Even if I provide a DHCP/tftp server in the lan, it does not take it. I'm lost with this.

Do you have a url where you can put the packages build along with that image?
I'm asking because I want to mount a usb stick, load and run openvpn/quagga/bgpd on it, and the packages I've installed depend on the kernel, so instalation usually fails. Even if I compile my own kmod-tun for example, I see segfault at first ping thru the openvpn tunnel.

Try this Workaround i use for a working Build:
https://dl.dropbox.com/u/87161358/edima … _Patch.tgz

Re: [Volunteer nedeed] I need someone with 3G-6200N

That really helped.

Thank you guenti.

Cip

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi,

guenti, could you help me? smile
I tried your openwrt builds for the 3G-6200n from http://umtslink.org/3g-forum/threads/68868-Edimax-3G-6200n-mit-OpenWrt/page7. Since my german is beginner level at best smile it makes not much sense for me to register there.

Could you provide me the .config you are using for the builds? I would like to build my own, based on your config (I need usb storage and filesystems support for my setup). So far I could get it running, but wifi is not working. I am missing some driver, I'm sure...

Thanks a lot,
Atti

58

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi Guenti,

excellent job you did so far. I was able to upgrade my Edimax 3G-6200N with 3.7.6 from your link:

https://dl.dropbox.com/u/87161358/edima … pgrade.bin

However when I try to install additional USB kernel module drivers (RT73, RT2800) I get dependency errors.

I would be very pleased if you could post your .config file so I can build my own image from trunk (r35576).
I guess I still have to use your patch (old switch driver < 33300)?


Thanks

jft

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi jft,
Looks like we're in the same boat smile I'm trying to compile my own image and packages from trunk, I'll post my config here if I'm successful.
I'm using Guenti's LAN patch, that's needed to have working LAN ports.
Maybe Guenti will help us with his .config in the meantime smile

60

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi katti,

yes indeed it looks we are struggling with the winds smile

I am able to build an image but would like to check my .config before flashing my device (I do not want to end up with a brick sad )

This is my .config that produces a 3MB image

https://dl.dropbox.com/s/64iewsg2ieoqjnc/.config


jft

Re: [Volunteer nedeed] I need someone with 3G-6200N

I compiled a working firmware, but I forgot to include the web interface. Also, my wireless didn't work, but that could be that it's disabled by default. Didn't spend too much time to check.

Anyway, right now I'm compiling a new one, with packages and all, but it takes time. I was too lazy to select only the packages I need, I just included all. But some of them give compilation errors, so every time it happens I have to uninstall that package from the tree and start again. I'll let you know wink

If someting goes wrong, it should be possible to unbrick with the procedure from here and revert to the Edimax firmware: http://wiki.openwrt.org/toh/edimax/3g-6200n#notes
I did it twice already wink

Re: [Volunteer nedeed] I need someone with 3G-6200N

guenti

Hi

What is the link to latest image? Have you updated it?

Thanks

63

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi katti,

did you manage to build a working image with luci? If so would you be so kind and post your .config file.

jft

64 (edited by katti 2013-02-20 10:31:53)

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi jft,

Yes, I did, but didn't install it yet, I'm planning to do it this weekend. Here's the config, if you want to use it: http://dl.dropbox.com/u/58885872/OpenWrt/config

I can tell you how it worked out maybe on Saturday. There shouldn't be any problems, right now I'm running an image that is very similar to this one, but it has no IPv6 support (and I need that wink) and I built no packages.
It's working fine so far. Just don't forget to apply Guenti's LAN patch before you build. I used trunk r35572.

Good luck & see you around!

Re: [Volunteer nedeed] I need someone with 3G-6200N

Update! I installed my new image, and it works like a charm! big_smile
Ok there are some small annoyances:
- Luci is not included in the firmware, but I installed it from packages with no problems
- my kernel log is filled with "br-lan: received packet on eth0.1 with own address as source address" messages, one line every two seconds. I have no idea what's the reason, but I see no problems with the LAN or the WiFi.

I'm already running with overlay fs on an USB stick, IPv6, openssh smile I still have to set up openvpn, and then it covers all my needs, and does everything my good old WL-500gP did, but now started to die after more than 5 years of great service sad
This router even seems a little bit faster than the Asus was, but it's not a speed daemon. It maxes at about ~5 MB/s on my PPPoE connection. But still, the fact that it can run openwrt, saved me from investing in some more serious stuff at the moment.

So, jft, tell me how yours worked out!

Re: [Volunteer nedeed] I need someone with 3G-6200N

Hi,
Please, can someone put the upload image 3G-6200n with a good, active LAN.
thx

Re: [Volunteer nedeed] I need someone with 3G-6200N

Here's my whole build: https://www.dropbox.com/sh/y9q1c1iapzwgflk/aLUrW3hDLm
Take the openwrt-ramips-rt305x-3g-6200n-squashfs-sysupgrade.bin image.
But BEWARE, it has no webinterface (luci) included, you have to log in via ssh and install it with opkg. I hope there is enough space left for it (I had, because I use a USB stick for overlay wink).
I also included my packages directory, you can take it from there.

Good luck!

Re: [Volunteer nedeed] I need someone with 3G-6200N

sorry @all, i had alot of work....

Latest working Image (LuCI, 3G, LAN) here:
http://dl.dropbox.com/u/87161358/OpenWR … pgrade.bin

Latest working Image (LuCI, 3G, LAN, USB-Storage (VFAT)) here:
http://dl.dropbox.com/u/87161358/OpenWR … pgrade.bin

LAN-Workaround here:
http://dl.dropbox.com/u/87161358/edimax_6200n(L)_3G/openwrt/forum/Edimax_6200n_LAN_Patch.tgz

Re: [Volunteer nedeed] I need someone with 3G-6200N

@guenti, is official build working now? As far as I understand https://dev.openwrt.org/ticket/12125 is claiming that r34379 should be working fine.

Re: [Volunteer nedeed] I need someone with 3G-6200N

Is client bridge mode working with 6200n?

A friend of mine has two 6200n running in client bridge mode and stock firmware. But both devices are losing configuration data a few times a year. And he can't fix it on his one...

I am asking because for my tl-wr740n v4 I could only configure working client bridge mode with dd-wrt brainslayer and not with dd-wrt and openwrt. Read somewhere something about a driver problem...

Re: [Volunteer nedeed] I need someone with 3G-6200N

@avalon:

avalon wrote:

@guenti, is official build working now? As far as I understand https://dev.openwrt.org/ticket/12125 is claiming that r34379 should be working fine.

try my latest working build:
https://dl.dropboxusercontent.com/u/871 … pgrade.bin

72 (edited by guenti 2013-06-08 12:17:18)

Re: [Volunteer nedeed] I need someone with 3G-6200N

avalon wrote:

@guenti, is official build working now? As far as I understand https://dev.openwrt.org/ticket/12125 is claiming that r34379 should be working fine.

r35761 is the latest working version i have built.

Re: [Volunteer nedeed] I need someone with 3G-6200N

Wireless gets assigned IP in the 192.168.1.* range correctly and has access to internet.
  Wired connection is assigned 169.184.85.* and can´t access internet even if IP is set as static in the correct range.
 
  I haven´t changed anything in the configuration yet. What should I do?

Re: [Volunteer nedeed] I need someone with 3G-6200N

try this Image:

https://dl.dropboxusercontent.com/u/871 … pgrade.bin

Re: [Volunteer nedeed] I need someone with 3G-6200N

Sorry about the last post. After turning off the whole thing and trying to connect directly to my modem like I´m used to, I still didn´t get a valid IP no mater waht  I did or how many times I disabled and enabled the NIC, so I gave up for the night.

A few minutes ago I tried again, but only turned the machine on after everything was connected, and it got a valid IP from the 3g-6200n, making me think it´s the stupid NIC fault, which I dismissed at first because I tried with two different computers.

  For now I´ll try to find out if Athereos NICs have any known problems (both computers have them).

  Sorry for all the trouble and thanks for all the help, guenti.