Topic: problem to access router with 802.11s


I configured 2 routers with OpenWRT enabled 802.11s mesh network.

First, I created in router 1 a wireless mesh network. After that, I joined the router 2 to the mesh. This works fine. the problem is: I can't ssh/ping the router 2 anymore. Because while it is on the mesh, it's like his IP doesn't exist anymore.
I need a way to access the router 2 without disable the mesh connection to router 1.

How they are configured?
well, lan interface (type bridge) has two wifi-ifaces associated, ap and mesh mode.
so I can access the mesh network by wifi and cable ethernet.

I tryed an other configuration,
the router 2 has two interfaces, lan (as usual) and an other called 'wifi', just the second one has the wifi-ifaces with mesh associated.
This configuration is near to this:
What is the result?
I can ssh the router 2 by ethernet. But I can't connect to the mesh, just by wifi.
As I told before, I need both of them connected to mesh and enable for configuration access (ssh).

TP-Link WR841ND and WA 701ND. Doesn't matter what's the router 1 or 2,  they works same way.

Thank you in advance smile

2 (edited by djr 2014-05-24 14:48:03)

Re: problem to access router with 802.11s

Set up router 2 exactly the same as router 1,  ie.. cut and paste the /etc/config/network and /etc/config/wireless exactly.  You can remove the AP setting from router 2 if you like.

So you have,  for example:

  router 1  [br-lan ip]
bridged ethernet + mesh + ap

  router 2 [br-lan ip]
bridged ethernet + mesh ( + ap if you like )

you should be able to ping from anywhere to anywhere.  this is how i have mine configured and it just works.  sometimes, just after mesh nodes join, or if all mesh nodes are new  (after a power failure etc) it can take a moment for the paths to work. 

also, i didn't set any mesh_gate options, just mesh_id really and it bridges + forwards all traffic transparently.