OpenWrt Forum Archive

Topic: ETHoA / RPC 1483 / PPPoEoA ADSL on Buffalo WBMR-HP-G300H

The content of this topic has been archived on 22 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

Hi,

I've compiled and installed open openwrt on my Buffalo WBMR-HP-G300H. I'm trying to understand what I need to set up ADSL.

I live in the UK, my provider is BeThere who use ETHoA / RPC 1483 / PPPoEoA or whatever the standard is called over ADSL2+ (annex a). The vpi/vci is 0/101 and the encapsulation is LLC (something about bridged IP).

I'n not sure where to start on setting up the ADSL model. First of all I changed the wan protocol to PPPoE as I heard that PPPoEoA is PPPoE over an ATM bridge. Then I removed the username and password for PPPoE. I then set the VCI, VPI and encapsulation mode of the bridge to LLC.

I originally had dd-wrt installed on the router and I seemed to have connected to the ADSL line. By that I mean I showed the upstream / downstream speeds. However I don't think it could bridge it as I could not use the internet.

With openwrt I don't think it is connected to the ADSL line at all.

I used the code provided by essele

#!/bin/sh

echo "$@" > /tmp/pipe/dsl_cpe0_cmd && cat /tmp/pipe/dsl_cpe0_ack

When I ran "dsl_cmd g997lsg 1 1" rather than getting stats. I get negative nReturn codes, which I assume indicate that the line is down or some other error. Is there anything I need to do to get the ADSL line up?


Richard

I checked the /etc/config/network file:

config adsl-device 'adsl'
    option fwannex 'b'
    option annex 'b2p'

I'm on annex a not annex b. I'm sure as I can see the annex a firmware in /lib/firmware.

I think there may be a problem with selecting the right board in target/linux/lantiq/base-files/etc/uci-defaults/network

Well changing a to b worked. I'm not sure why it was set to b.

In target/linux/lantiq/base-files/lib/lantiq.sh, we have:

lantiq_board_name() {
    grep ^machine /proc/cpuinfo | sed "s/machine.*: \(.*\)/\1/g" | sed "s/\(.*\) - .*/\1/g"
}

lantiq_dsl_fwannex() {
    ls /lib/firmware/dsl-fw-*.bin 2> /dev/null | sed "s/.*\([ab]\)\.bin/\1/g"
}

On the router lantiq_board_name() returns "WBMR". So from target/linux/lantiq/base-files/etc/uci-defaults/network is should use:

fwannex=$(lantiq_dsl_fwannex)
set_adsl "$fwannex" "${fwannex}2p"

lantiq_dsl_fwannex() returns "a", so I don't know why 'b' appeared. Will raise a ticket.

Also from another thread I found that RFC 1483 is dhcp over an ATM bridge so all is working now.

Great! thank you rhlee wink

Hi rhlee,

I've been trying to get my WBMR router to connect via ADSL and have had no success at all.

When I initially put my changes in I noticed that I had a "ppp" process running which looked like it had the configuration on the command line however after making a few more changes to try and get it working I can't see this process running at all, even after a reboot.

I'm keen to understand the exact changes you've made and the exact config you are using. Would you be kind enough to summarise the changes you had to make either to the source code in trunk or to the configuration on the router itself either via the web interface or config files/scripts.

Thx
Mark.

scaryAardvark wrote:

I'm keen to understand the exact changes you've made and the exact config you are using. Would you be kind enough to summarise the changes you had to make either to the source code in trunk or to the configuration on the router itself either via the web interface or config files/scripts.

The thing is that each ISP has different settings.

I'll try and run you through a checklist so we can narrow down the problem.

1. I assume that you have an ADSL line not ISDN. (Let me know if otherwise). If so, we have to make sure you have the dsl modules installed with the correct firmware. Type in:

opkg list-installed | grep dsl

You should get

kmod-ltq-dsl-ar9 - 3.2.13+3.24.4.4-3
kmod-ltq-dsl-firmware-a-ar9 - 3.24.4.4-3
ltq-dsl-app - 3.24.4.4-1

Make sure it is kmod-ltq-dsl-firmware-a-ar9 not kmod-ltq-dsl-firmware-b-ar9. B is for isdn lines.

2. Even if you have the 'a' firmware it still tries to use 'b' firmware. This is a bug ( https://dev.openwrt.org/ticket/11240 ), I think. So you have to change the network config file.

There are two ways to do this.

2.a. Either edit the /etc/config/network file directly using an editor. Change

config adsl-device 'adsl'
    option fwannex 'b'
    option annex 'b2p'
config adsl-device 'adsl'
    option fwannex 'a'
    option annex 'a2p'

2.b. Or use uci

uci set network.adsl.fwannex=a
uci set network.adsl.annex=a2p
uci commit network

Then  reboot the rooter with

sync && reboot

(SOMEONE PLEASE CHECK MY UCI INSTRUCTIONS, I've never really used uci properly.)

3. We now need to check that the ADSL modem is syncing with you ADSL line. It's easiest to create a script to do this. Run:

cat > /sbin/dsl_cmd

To create the file. Copy and paste the following script (the whole thing, not line-by-line).

#!/bin/sh

echo "$@" > /tmp/pipe/dsl_cpe0_cmd && cat /tmp/pipe/dsl_cpe0_ack

(credits go to eselle)
Hit enter, then ctrl-c to save the script.
Then make the script runnable:

chmod +x /sbin/dsl_cmd

Now we can run the script to query the modem for the line status information. Run:

dsl_cmd g997csg 0 1

This gets the downstream line information. You should see something like

nReturn=0 nChannel=0 nDirection=1 ActualDataRate=5106150 PreviousDataRate=0 ActualInterleaveDelay=800 ActualImpulseNoiseProtection=20

If you only see nReturn with a negative number, it means there is a problem.

4. Hopefully your ADSL line is up. New we need configure the way the router sends data over the line. This is entirely dependent on your ISP. Let us know which ISP + package you have and someone will try and help you. Or you can try entering the settings yourself.


Lastly, I also saw:

scaryAardvark wrote:

When I initially put my changes in I noticed that I had a "ppp" process running which looked like it had the configuration on the command line however after making a few more changes to try and get it working I can't see this process running at all, even after a reboot.

In the likely event that your ISP uses PPPoE or PPPoA, then yes, I think that this may be a problem as you need pppd to handle the ppp link. There was a thread about about pppd not running on boot https://forum.openwrt.org/viewtopic.php?id=34132 .
However, this was fixed several months ago, and by the looks of you other posts you compiled openwrt in the last two weeks, so this should not be a problem.
I can't say to much on pppd as I don't use it myself, but I think it is first best to establish whether you ADSL connection needs it or not. The best was to do this is to find out your ISP + package to get you connection type.

Wow!. Thanks rhlee,

My adsl connection is with BT broadband. From my previous settings, I was using PPoA with a VPI/VCI of 0/38 and also VCMUX encapsulation.

I didn't see VCMUX in the settings Luci was showing me I assumed it wasn't LLC so chose the other one, I think it was Multi something or other smile

I also noticed that the network config was showing annex-b and I know from previous searches that I should be using annex-a so you're setup is very enlightening.

Unfortunately I'm working away and won't have access to the router until the weekend but I will try the things you've shown me.

Once again, thanks for the thorough reply and hopefully with your help we can get it sorted smile

No probs.

scaryAardvark wrote:

My adsl connection is with BT broadband. From my previous settings, I was using PPoA with a VPI/VCI of 0/38 and also VCMUX encapsulation.

Ok so your seetings should be like this http://postimage.org/image/v0h6et3kl/

As per http://bt.custhelp.com/app/answers/deta … oadband%3F put in your bt email in the username and leave the password as blank or "BT".

scaryAardvark wrote:

I didn't see VCMUX in the settings Luci was showing me I assumed it wasn't LLC so chose the other one, I think it was Multi something or other smile

That's what the M stands for for in VCMUX, virtual circuit multiplexing. It defenitely is there (see picture). However from what you are telling me so far, I get the feeling you are on an older revision of openwrt. Could you tell us what revision you are on? It should be on the top black bar beginning with 'r', e.g. mine is r31214 .

The funny thing is, I had the settings pretty much as you've got there.

I'm currently running Attitude Adjustment (r31158)

    Router Name    OpenWrt
    Router Model    WBMR
    Firmware Version    OpenWrt Firmware Attitude Adjustment (r31158) / LuCI Trunk (trunk+svn8382)
    Kernel Version    3.2.13

I may be mistaken about the VCMUX think not being there. sad However, I do remember trying both settings then booting up my old router and checking it's config. Thats how I knew it was VCMUX.

M.

(Last edited by scaryAardvark on 11 Apr 2012, 17:46)

I decided to update trunk and rebuild.
When I did this I checked the list of packages in the bin/lantiq/packages directory which I assume are the packages that make up the image. I noticed that the annex-a firmware stuff wasn't there.

-rw-r--r-- 1 mark users 48168 Apr 11 18:46 bin/lantiq/packages/ltq-dsl-app_3.24.4.4-1_lantiq.ipk
-rw-r--r-- 1 mark users 101822 Apr 11 18:45 bin/lantiq/packages/kmod-ltq-dsl-ar9_3.2.14+3.24.4.4-3_lantiq.ipk
-rw-r--r-- 1 mark users 189180 Apr 11 18:45 bin/lantiq/packages/kmod-ltq-dsl-firmware-b-ar9_3.24.4.4-3_lantiq.ipk

I've no idea which menuconfig option turns on the creation of the -a- package, Any ideas?

M.

(Last edited by scaryAardvark on 11 Apr 2012, 19:16)

Ok, found it. and rebuilt..

-rw-r--r-- 1 mark users 101857 Apr 11 20:03 packages/kmod-ltq-dsl-ar9_3.2.14+3.24.4.4-3_lantiq.ipk
-rw-r--r-- 1 mark users 191913 Apr 11 20:03 packages/kmod-ltq-dsl-firmware-a-ar9_3.24.4.4-3_lantiq.ipk
-rw-r--r-- 1 mark users  48163 Apr 11 20:04 packages/ltq-dsl-app_3.24.4.4-1_lantiq.ipk

I'll install this at the weekend and see how we get on smile

Arse...!!!!

I managed to get it working last night and went to bed quite smug smile cool

However, when I got up this morning and powered the router back on it wouldn't connect to the ADSL. I did the dsl_cmd stuff you mentioned above and it came back as expected. I couldn't understand this so I decided to start again and reflash... :mad

Alas. this is where I cocked up. I managed to flash non-squashfs image instead of the squashfs one and now I think I have a bricked router sad

I'll have to investigate sorting out a serial cable sad:(:(

(Last edited by scaryAardvark on 14 Apr 2012, 06:37)

Ok, tried the generic debrick over tftp without much luck. Anyone had any success with trying to debrick this router

Sorry to hear about your bricking. Did you get round to trying the serial cable?

Unfortunately from what I read in this thread https://forum.openwrt.org/viewtopic.php?id=34072 people are having problems with serial connections after bricking it. it would be worth posting in that thread in case anyone has had success since.

Your other options are jtag, but that is a bit more expensive and complicated than serial.

PS If after you have tried everything and you still can't debrick it, I would be interested in buying it off you. I feel that this is potentially a great router for openwrt, but that fact that you can't debrick it is a major show stopper. I would like to have a shot myself at debricking it. I'm looking to create a cheap jtag solution using the inexpensive FT232 chip. Of source you would be welcome to buy it back from me at the same price, if I manage to debrick it.

I've opened up the router but I had to drill out the screws as I couldn't find any security torx bits that would fit in the very narrow screw recesses.

From what i've read I shouldn't have screwed up the bootloader just by mtd'ing over the linux partition but I could be wrong. I'm not that keen to throw some more money at buying serial cables etc only to find out I need to go Jtag which would be additional expense along with being completely unknown territory so.... I've got no problems selling it to you for your experiments.

I've got all the original contents etc so will box it up this weekend.

PM or email me and we'll take this off line smile

M.

(Last edited by scaryAardvark on 16 Apr 2012, 17:12)

Got myself another router and managed to get it all working over the weekend smile

Now all I need to do is work out how I can monitor the adsl usage on a per user/mac-address basis.  I looked at wrtbmon but it doesn't seem to work out of the box. I'll need to work out how to change it so it works correctly.

Failing that, does anyone know how I can achieve this per-user monitoring. I basically want to make sure that the kids aren't downloading too much by downloading dozens of movies etc smile

M.

So I've followed carefully through everything written so far in this thread, because I had the same problem - no ADSL connection on the WBMR-HP-G300H. I built from trunk and initially had the annex-b problem, but manifested slightly differently - the default config file had been written with annex a, but only the firmware for b was actually included in the build. So after adjusting that and building again I think I've ruled out that being the problem.

The trouble I'm having is that it's behaving like the modem simply isn't plugged into a line. This is definitely not a hardware problem, as I've flashed back and forwards between OpenWRT and DD-WRT and it works fine in DD-WRT, and never in OpenWRT. Here are some examples of what I see, using the dsl_cmd script detailed above:

Running the "lsg" command gives me "nLineState=0x200" - according to the docs 0x200 means "silent"
Running the "g997lisg" command tell me that  "nLineInitStatus" is 4 - docs say "no peer xtu"
And (predictably given the above) running "g997csg 0 1" gets me a -21 return code

So, given the above you'd be forgiven for saying "are you sure it's plugged in", but it definitely is! If anyone can give me any ideas as to what I can do next to try and diagnose this problem I'd be very grateful, as I'm desperate to replace DD-WRT with OpenWRT on this box.

CiaranG wrote:

So I've followed carefully through everything written so far in this thread, because I had the same problem - no ADSL connection on the WBMR-HP-G300H. I built from trunk and initially had the annex-b problem, but manifested slightly differently - the default config file had been written with annex a, but only the firmware for b was actually included in the build. So after adjusting that and building again I think I've ruled out that being the problem.

The trouble I'm having is that it's behaving like the modem simply isn't plugged into a line. This is definitely not a hardware problem, as I've flashed back and forwards between OpenWRT and DD-WRT and it works fine in DD-WRT, and never in OpenWRT. Here are some examples of what I see, using the dsl_cmd script detailed above:

Running the "lsg" command gives me "nLineState=0x200" - according to the docs 0x200 means "silent"
Running the "g997lisg" command tell me that  "nLineInitStatus" is 4 - docs say "no peer xtu"
And (predictably given the above) running "g997csg 0 1" gets me a -21 return code

So, given the above you'd be forgiven for saying "are you sure it's plugged in", but it definitely is! If anyone can give me any ideas as to what I can do next to try and diagnose this problem I'd be very grateful, as I'm desperate to replace DD-WRT with OpenWRT on this box.

I have exactly the same problem. Anything new on this?


Edit:
Found my Problem:

config adsl-device 'adsl'
    option fwannex 'a'
    option annex 'a2p'

annex a2p was the problem, my dsl line is dmt, so option annex 'admt' and my dsl line is up.

Ddwrt uses automodulation Option annex a as default

(Last edited by rossini on 27 Aug 2012, 21:26)

He Guys! Good News.

I debricked my router without JTAG or Serial or something.

My Symtoms: After power on the router, Power led was orange for about 5 seconds. Then nothing. No Pings no wlan, nothing.
After a wireshark session and a little trial&error i found following solution:

In the boot loader is a tftp client which requests a firmware.ram.

Following steps:

1. Build openwrt with ram image option. I just followed the guide.
2. Set your local interface on ip 192.168.11.2 netmask 255.255.255.0 router 192.168.11.1
3. setup a tftp-server. I used TftpServer Version 3.4.1 under osx mountain lion.
4. rename the openwork-lantig-ar9-WBMR-uImage to firmware.ram
5. start the tftp-server
6. connect your pc to one lan port on the router.
7. Power on the router + PUSH THE AOSS Button. If you dont push the button, there will be no tftp request.
8. Now the Powerled should light up red + the AOSS led should light up.
9. After a little while, change your local lan interface to automatic and you should get a ip-address from the dhcp server.
10. Do a normal sysupgrade with a good image.
11. Wait and prey.

If you have running wireshark in the background, you will see if the tftp-transfer of the ram-image is successful.

Please confirm if it is working. And maybe we should then write in the wiki about the uboot-tftp-client.

have a nice debricking.

^
this works.

Sorry to bring up an old thread.

I'm wondering if you chaps can help me?

I have a very similar setup to rhlee, same router, same isp.

I've followed the advice in this thread, and it appears the adsl is connected, data rates etc are shown when I run the dsl_cmd script. I can't get the wan interface to connect.

I think I need to set up the pppoe bridge, which I've done, putting in the correct vpi/vci, but no joy.

Isp mentions here http://beusergroup.co.uk/technotes/inde … _settings, that I should "Obtain IP using DHCP". I'm not sure where I configure that though? In the bridge settings or in /etc/config/dhcp ?

I'm not sure what I need to get any further? Any help would be greatly appreciated.

Also on another side note, more of a linux question really, can anyone tell me how to get a list of all the hardware devices? When I run ifconfig, I don't see anything for the adsl modem, I had a nosey in /dev but don't see anything that is obviously the adsl modem.

In /etc/config/network you need

config atm-bridge
       option unit     '0'
       option vpi      '0'
       option vci      '101'

config interface wan
        option 'ifname' 'nas0'
        option 'proto' 'pppoe'

DHCP is enabled by default in this case. Using ifconfig you should see the nas0 interface, which corresponds to the ATM bridge.

Hi,

Thanks for your reply.

Still no joy unfortunately sad

I've put the suggested settings in the network config file. This is how it looks now:

I've also added in my opkg list-installed and the output from the dsl_cmd script.

Should I be concerned about the nReturn=0 nChannel=0 values in the dsl_cmd script?

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option ifname 'eth0'
    option type 'bridge'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.2.1'
    
config adsl-device 'adsl'
    option fwannex 'a'
        option annex 'a2p'
        
config atm-bridge 'atm'
    option unit '0'
    option encaps 'llc'
    option payload 'bridged'
    option vci '101'
    option vpi '0'

config interface 'wan'
    option ifname 'nas0'
    option proto 'pppoe'

config switch
    option name 'eth0'
    option reset '1'
    option enable_vlan '0'

config switch_vlan
    option device 'eth0'
    option vlan '1'
    option ports '0 1 2 3 4 5'

I get this output from the dsl_cmd script

root@OpenWrt:~# dsl_cmd g997csg 0 1
nReturn=0 nChannel=0 nDirection=1 ActualDataRate=19630209 PreviousDataRate=0 ActualInterleaveDelay=800 ActualImpulseNoiseProtection=20

These are the installed packages:

root@OpenWrt:~# opkg list-installed
base-files - 134-r35838
blkid - 2.21.2-1
block-mount - 0.2.0-10
br2684ctl - 2.5.2-5
busybox - 1.19.4-6
ddns-scripts - 1.0.0-21
dnsmasq - 2.62-3
dropbear - 2012.55-2
firewall - 2-59
hostapd-utils - 20120910-1
hotplug2 - 1.0-beta-4
iptables - 1.4.10-5
iw - 3.6-1
jshn - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
kernel - 3.7.9-1-ceeaf901ed8ff7d57310827c37c23162
kmod-ath - 3.7.9+2013-02-22-1
kmod-ath9k - 3.7.9+2013-02-22-1
kmod-ath9k-common - 3.7.9+2013-02-22-1
kmod-atm - 3.7.9-1
kmod-cfg80211 - 3.7.9+2013-02-22-1
kmod-crypto-aes - 3.7.9-1
kmod-crypto-arc4 - 3.7.9-1
kmod-crypto-core - 3.7.9-1
kmod-crypto-manager - 3.7.9-1
kmod-fuse - 3.7.9-1
kmod-gpio-button-hotplug - 3.7.9-1
kmod-ipt-conntrack - 3.7.9-1
kmod-ipt-core - 3.7.9-1
kmod-ipt-nat - 3.7.9-1
kmod-ipt-nathelper - 3.7.9-1
kmod-leds-gpio - 3.7.9-1
kmod-ledtrig-usbdev - 3.7.9-1
kmod-lib-crc-ccitt - 3.7.9-1
kmod-ltq-adsl-ar9 - 3.7.9+3.24.4.4-1
kmod-ltq-adsl-ar9-fw-a - 0.1-1
kmod-ltq-adsl-ar9-mei - 3.7.9-1
kmod-ltq-atm-ar9 - 3.7.9-1
kmod-ltq-hcd-ar9 - 3.7.9-1
kmod-mac80211 - 3.7.9+2013-02-22-1
kmod-nls-base - 3.7.9-1
kmod-ppp - 3.7.9-1
kmod-pppoa - 3.7.9-1
kmod-pppoe - 3.7.9-1
kmod-pppox - 3.7.9-1
kmod-scsi-core - 3.7.9-1
kmod-scsi-generic - 3.7.9-1
kmod-tun - 3.7.9-1
kmod-usb-core - 3.7.9-1
kmod-usb-storage - 3.7.9-1
kmod-usb-storage-extras - 3.7.9-1
kmod-usb2 - 3.7.9-1
libblkid - 2.21.2-1
libblobmsg-json - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libc - 0.9.33.2-1
libgcc - 4.7-linaro-1
libip4tc - 1.4.10-5
libip6tc - 1.4.10-5
libiwinfo - 39
libiwinfo-lua - 39
libjson - 0.9-2
liblua - 5.1.5-1
liblzo - 2.06-1
libnfnetlink - 1.0.1-1
libnl-tiny - 0.1-3
libopenssl - 1.0.1e-1
libpthread - 0.9.33.2-1
libubox - 2013-01-29-0bc317aa4d9af44806c28ca286d79a8b5a92b2b8
libubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libubus-lua - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
libuci - 2013-01-04.1-1
libuci-lua - 2013-01-04.1-1
libuuid - 2.21.2-1
libxtables - 1.4.10-5
linux-atm - 2.5.2-5
ltq-adsl-app - 3.24.4.4-2
lua - 5.1.5-1
luci - trunk+svn9676-1
luci-app-ddns - trunk+svn9676-1
luci-app-firewall - trunk+svn9676-1
luci-app-samba - trunk+svn9676-1
luci-app-upnp - trunk+svn9676-1
luci-i18n-english - trunk+svn9676-1
luci-lib-core - trunk+svn9676-1
luci-lib-ipkg - trunk+svn9676-1
luci-lib-nixio - trunk+svn9676-1
luci-lib-sys - trunk+svn9676-1
luci-lib-web - trunk+svn9676-1
luci-mod-admin-core - trunk+svn9676-1
luci-mod-admin-full - trunk+svn9676-1
luci-proto-core - trunk+svn9676-1
luci-proto-ppp - trunk+svn9676-1
luci-sgi-cgi - trunk+svn9676-1
luci-theme-base - trunk+svn9676-1
luci-theme-openwrt - trunk+svn9676-1
miniupnpd - 1.8-1
mtd - 20
netifd - 2013-02-19-486aa750a164d41905beb61afec89268e3eb7f48
ntfs-3g - 2013.1.13-1-fuseint
openssl-util - 1.0.1e-1
openvpn-easy-rsa - 2013-01-30-1
openvpn-openssl - 2.3.0-1
opkg - 618-3
ppp - 2.4.5-9
ppp-mod-pppoa - 2.4.5-9
ppp-mod-pppoe - 2.4.5-9
procd - 2012-12-20-d343dd9e9a64d4ae7d225ea29169e97fa8d116a1
samba36-server - 3.6.11-2
swap-utils - 2.21.2-1
swconfig - 10
ubus - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
ubusd - 2013-01-13-bf566871bd6a633e4504c60c6fc55b2a97305a50
uci - 2013-01-04.1-1
uhttpd - 2013-01-22-14e3971c37e6feb0ec5eda0988e07d8a786ba9f9
uhttpd-mod-ubus - 2013-01-22-14e3971c37e6feb0ec5eda0988e07d8a786ba9f9
wpad-mini - 20120910-1
zlib - 1.2.7-1
root@OpenWrt:~# opkg list-installed | grep fw
kmod-ltq-adsl-ar9-fw-a - 0.1-1

What does

/etc/init.d/dsl_control status

show? Anything relevant in system log (logread)?

(Last edited by snk on 22 Mar 2013, 14:24)

This is the output from dsl_control status

root@OpenWrt:~# /etc/init.d/dsl_control status
Chipset:        Ifx-AR9 1.2
Line State:        UP [0x801: showtime_tc_sync]
Data Rate:        19.630 Mb/s / 1.249 Mb/s
Line Attenuation:    25.8dB / 11.9dB
Noise Margin:        2.9dB / 1.8dB
Line Uptime:        6m 2s

and the following from logread: (not a full post of log read, as it just seems to repeatedly attempt to connect pppoe without success so didn't really thing it was useful to post the whole thing)

root@OpenWrt:~# logread
Sep  8 15:44:23 OpenWrt user.info sysinit: Loading zones
Sep  8 15:44:25 OpenWrt user.info sysinit: Loading forwardings
Sep  8 15:44:25 OpenWrt user.info sysinit: Loading rules
Sep  8 15:44:25 OpenWrt user.info sysinit: Loading redirects
Sep  8 15:44:25 OpenWrt user.info sysinit: Loading includes
Sep  8 15:44:25 OpenWrt user.info sysinit: Optimizing conntrack
Sep  8 15:44:25 OpenWrt user.info sysinit: Loading interfaces
Sep  8 15:44:26 OpenWrt user.info firewall: adding lan (br-lan) to zone lan
Sep  8 15:44:27 OpenWrt local2.notice br2684ctl[1306]: Interface "nas0" created sucessfully
Sep  8 15:44:27 OpenWrt local2.notice br2684ctl[1306]: Communicating over ATM 0.0.101, encapsulation: LLC
Sep  8 15:44:27 OpenWrt local2.info br2684ctl[1306]: Interface configured
Sep  8 15:44:27 OpenWrt local2.info br2684ctl[1306]: RFC 1483/2684 bridge daemon started
Sep  8 15:44:29 OpenWrt authpriv.info dropbear[1335]: Not backgrounding
Sep  8 15:44:30 OpenWrt daemon.info pppd[1341]: Plugin rp-pppoe.so loaded.
Sep  8 15:44:30 OpenWrt daemon.info pppd[1341]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 15:44:30 OpenWrt daemon.notice pppd[1341]: pppd 2.4.5 started by root, uid 0
Sep  8 15:44:32 OpenWrt user.notice dnsmasq: DNS rebinding protection is active, will discard upstream RFC1918 responses!
Sep  8 15:44:32 OpenWrt user.notice dnsmasq: Allowing 127.0.0.0/8 responses
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq[1393]: started, version 2.62 cachesize 150
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq[1393]: compile time options: IPv6 GNU-getopt no-DBus no-i18n no-IDN DHCP no-DHCPv6 no-Lua TFTP no-conntrack
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq-dhcp[1393]: DHCP, IP range 192.168.2.100 -- 192.168.2.249, lease time 12h
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq[1393]: using local addresses only for domain lan
Sep  8 15:44:35 OpenWrt daemon.warn dnsmasq[1393]: no servers found in /tmp/resolv.conf.auto, will retry
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq[1393]: read /etc/hosts - 1 addresses
Sep  8 15:44:35 OpenWrt daemon.info dnsmasq-dhcp[1393]: read /etc/ethers - 0 addresses
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led wifi
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led usb
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led dsl
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led movie
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led online
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led online2
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led power2
Sep  8 15:44:38 OpenWrt user.info sysinit: setting up led security
Sep  8 15:44:45 OpenWrt daemon.warn pppd[1341]: Timeout waiting for PADO packets
Sep  8 15:44:45 OpenWrt daemon.err pppd[1341]: Unable to complete PPPoE Discovery
Sep  8 15:44:45 OpenWrt daemon.info pppd[1341]: Exit.
Sep  8 15:44:45 OpenWrt daemon.notice netifd: Interface 'wan' is now down
Sep  8 15:44:45 OpenWrt daemon.info pppd[1451]: Plugin rp-pppoe.so loaded.
Sep  8 15:44:45 OpenWrt daemon.info pppd[1451]: RP-PPPoE plugin version 3.8p compiled against pppd 2.4.5
Sep  8 15:44:45 OpenWrt daemon.notice pppd[1451]: pppd 2.4.5 started by root, uid 0
Sep  8 15:45:00 OpenWrt daemon.warn pppd[1451]: Timeout waiting for PADO packets
Sep  8 15:45:00 OpenWrt daemon.err pppd[1451]: Unable to complete PPPoE Discovery
Sep  8 15:45:00 OpenWrt daemon.info pppd[1451]: Exit.

So it appears the line is connected, but its failing to establish the PPP bit.

Its tantalisingly close to working!

(Last edited by Jim3 on 23 Mar 2013, 14:54)

The discussion might have continued from here.