1 (edited by onlineuser 2012-03-16 22:05:02)

Topic: TL-MR3020 - openwrt - 3G-modem

Hi,

when I flash OpenWrt on my TL-MR3020 3G-router. Will the 3G-modem be supported by OpenWrt?

I also would need a OpenVPN server on it. Does it run?

greets

Re: TL-MR3020 - openwrt - 3G-modem

If the 3G modem is supported by usb-modeswitch and the option module it should work.

3 (edited by onlineuser 2012-03-16 22:08:51)

Re: TL-MR3020 - openwrt - 3G-modem

Where do I find the working modems for usb-modeswitch?

I also would need a OpenVPN server on it. Does it run?

On TL-MR3020 no backfire 10.3 runs - only trunk. Should the 3G-modem for WAN connection also run without problems?

Re: TL-MR3020 - openwrt - 3G-modem

Yeah, OpenVPN will work but you should add extra USB storage.

5 (edited by onlineuser 2012-03-16 22:28:01)

Re: TL-MR3020 - openwrt - 3G-modem

hmmm.

On my WRT54GL I also have only 4MB flash and 16MB RAM (or fon router 2100) and there openvpn runs with default memory.

How much memory does the 3G-support need?

Is this the right site for 3G-setup?

Do I really need all the modules? :-(
How could I add extra strorage? Could I buy a 3G-modem with build-in card reader and micro sd-card?

Re: TL-MR3020 - openwrt - 3G-modem

usb_modeswitch supported modem list here:
http://www.draisberghof.de/usb_modeswitch/device_reference.txt

Re: TL-MR3020 - openwrt - 3G-modem

Can you suggest me a 3g-modem with integrated extra-USB-storage for the TL-MR3020 which works without problems.

Re: TL-MR3020 - openwrt - 3G-modem

Can't you just buy a USB hub and card reader as well, I doubt you'll manage to get hold of a 3G modem with a card reader - that'd be a rather esoteric product

Arch Linux | TP-Link WR703N | TP-Link WR1043ND

9 (edited by onlineuser 2012-03-18 23:26:47)

Re: TL-MR3020 - openwrt - 3G-modem

The problem is that the TL-MR-3020 only has one USB port and because I realize a autark-solution I don't have extra power for the USB-hub. :-(

Do you think that the 3g-modem and a card reader would work on the TL-MR-3020 without external power?

Other question: When the extra memory is recognized by openwrt how can I install the apps to external memory instead of internal flash?
What happens at loss of power? Will it boots up without problems?

Huawei E585 / E367 / E169 / E156G, E173U-2 has integrated sdcard memory which will be detected as CDROM by Linux.

The switching between modem-mode and memory-mode seems to be tricky.

Re: TL-MR3020 - openwrt - 3G-modem

tl mr 3020 + huawei EC1260-2 evdo modem, 3g connection always disconnected after a few minutes when accessing via wifi,
when accessing via lan, its normal

please help to investigate.

------------- network config----------
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'

config interface 'wan'
option proto '3g'
option ifname 'ppp0'
option service 'evdo'
option device '/dev/ttyUSB0'
option username 'smart'
option password 'smart'
option maxwait '0'

---------------------firewall------------
config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

---------------wireless-----------
config wifi-device 'radio0'
option type 'mac80211'
option channel '11'
option country 'ID'
option txpower '20'

config wifi-iface
option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid 'OpenWrt'
option encryption 'none'

----dhcp--------
config dhcp lan
option interface lan
option start 100
option limit 150
option leasetime 12h

config dhcp wan
option interface wan
option ignore 1

------------------------