1 (edited by static-void 2011-10-30 19:46:36)

Topic: Interface naming problem

I have a Netgear DG834GT which I have just installed openwrt "Backfire 10.03.1-rc5" on by following the instructions here:
http://wiki.openwrt.org/toh/netgear/dg834gt

I want to use the router to connect to my home wireless (WEP) and share it out (masquerade rather than route I think) to my wired machines.

The atheros wireless in the device by default did not appear to work at all, even after doing

opkg install kmod-ath9k

This installed the modules (froze first time actually, but I re-did it after a reboot), but no interface ever appeared. So I swapped out the mini-PCI card for a spare I had around, using the intel pro chipset, and installed the drivers for that.

I can't get anything to work. I have tried following guides

here:
http://wiki.openwrt.org/doc/howto/clientmode
here:
http://wiki.openwrt.org/doc/recipes/routedclient#using.masquerade
here:
http://unix.stackexchange.com/questions/15461/how-to-extend-my-wireless-network-with-openwrt
here:
https://forum.openwrt.org/viewtopic.php?pid=137880#p137880
...

I don't understand where I am actually supposed to specify that my wireless interface is eth2. Whenever I run a command such as "wifi" I get errors like

command failed: Operation not supported (-122)
command failed: Operation not supported (-122)
Error for wireless request "Set Power Management" (8B2C) :
    SET failed on device wlan0 ; No such device.
ifconfig: SIOCSIFHWADDR: No such device
command failed: No such device (-19)
ifconfig: SIOCGIFFLAGS: No such device
ifconfig: SIOCGIFFLAGS: No such device
Could not read interface wlan0 flags: No such device
nl80211: Could not set interface 'wlan0' UP
wlan0: Failed to initialize driver interface
ifconfig: SIOCGIFFLAGS: No such device

It seems to think my wireless should be wlan0, but it is eth2.

I can do iwlist scan and get a full list of results etc, but nothing else seems to work.

Can anyone help?!

I am by no means a linux newbie, but I have to say that I am finding this all very confusing and frustrating. Especially the thing with all the logical interfaces. All I want to do is connect to a wireless network, turn ip masquerading on, and run a dhcp server.. which would take me 5 minutes on my linux desktop (from command line)! Sorry, I don't mean to criticise the work I am just feeling out of my depth, confused and frustrated! :S

Thanks

Re: Interface naming problem

Ok, so I swapped the module for a rt2500, which comes up as wlan0. Everything worked straight away - awesome!

It would be a good idea though to have some way to support changing the interface names... I spent all day confused by this, then once I had a card that is wlan0 instead of eth2 everything worked in 5 minutes!