1 (edited by dyq 2011-09-06 11:02:28)

Topic: Tp-link Tl-wr703n

Sorry of my bad English

I just bought a TP-LINK TL-WR703N. It's very cheap (RMB 99, about $15), but seems only produce for China.

It has 1x LAN port, 1x USB 2.0, AR9331 chipset, 4MB Flash and 32MB RAM.

Photos (not mine):
http://www.right.com.cn/forum/thread-52557-1-1.html

official website
http://www.tp-link.cn/pages/product-detail.asp?d=225

ttl (aka Serial):
on board TP_OUT is tx, TP_IN is rx.

ttl output:

U-Boot 1.1.4 (Aug 27 2011 - 10:39:39)

AP121-2MB (ar9330) U-boot

DRAM:  32 MB
led turning on for 1s...
id read 0x100000ff
flash size 4194304, sector count = 64
Flash:  4 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7240_enet_initialize...
No valid address in Flash. Using fixed address
No valid address in Flash. Using fixed address
: cfg1 0x5 cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
ag7240_phy_setup 
eth0 up
: cfg1 0xf cfg2 0x7214
eth1: 00:03:7f:09:0b:ad
athrs26_reg_init_lan
ATHRS26: resetting s26
ATHRS26: s26 reset done
ag7240_phy_setup 
eth1 up
eth0, eth1
Autobooting in 1 seconds
## Booting image at 9f020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

Booting AR9330(Hornet)...
Linux version 2.6.31--LSDK-9.2.0.312 (root@bogon) (gcc version 4.3.3 (GCC) ) #128 Fri Aug 26 14:58:53 CST 2011
flash_size passed from bootloader = 4
CPU revision is: 00019374 (MIPS 24Kc)
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
User-defined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: console=ttyS0,115200 root=31:02 rootfstype=squashfs init=/sbin/init mtdparts=ar7240-nor0:128k(u-boot),1024k(kernel),2816(rootfs),64k(config),64k(ART) mem=32M
PID hash table entries: 128 (order: 7, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 29864k/32768k available (1888k kernel code, 2904k reserved, 524k data, 116k init, 0k highmem)
Hierarchical RCU implementation.
NR_IRQS:128
plat_time_init: plat time init done
Calibrating delay loop... 266.24 BogoMIPS (lpj=532480)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
===== ar7240_platform_init: 0


Whoops! This kernel is for product wr703 v1.0!

bio: create slab <bio-0> at 0
SCSI subsystem initialized
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
AR7240 GPIOC major 0
squashfs: version 4.0 (2009/01/31) Phillip Lougher
NTFS driver 2.1.29 [Flags: R/O].
msgmni has been set to 58
alg: No test for lzma (lzma-generic)
alg: No test for stdrng (krng)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
ttyS0: detected caps 00000000 should be 00000100
serial8250.0: ttyS0 at MMIO 0xb8020000 (irq = 19) is a 16550A
console [ttyS0] enabled
PPP generic driver version 2.4.2
NET: Registered protocol family 24
cmdlinepart partition parsing not available
set partition boot 
set partition kernel 
set partition rootfs 
set partition config 
set partition art 
set partition arching for RedBoot partition table
5 RedBoot partitions found on MTD device ar7240-nor0
Creating 5 MTD partitions on "ar7240-nor0":
0x000000000000-0x000000020000 : "boot"
0x000000020000-0x000000120000 : "kernel"
0x000000120000-0x0000003e0000 : "rootfs"
0x0000003e0000-0x0000003f0000 : "config"
0x0000003f0000-0x000000400000 : "art"
->Oops: flash id 0x10215 . 
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Port Status 1c000004 
ar7240-ehci ar7240-ehci.0: ATH EHCI
ar7240-ehci ar7240-ehci.0: new USB bus registered, assigned bus number 1
ehci_reset Intialize USB CONTROLLER in host mode: 3
ehci_reset Port Status 1c000000 
ar7240-ehci ar7240-ehci.0: irq 3, io mem 0x1b000000
ehci_reset Intialize USB CONTROLLER in host mode: 3
ehci_reset Port Status 1c000000 
ar7240-ehci ar7240-ehci.0: USB 2.0 started, EHCI 1.00
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
TCP cubic registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
ar7240wdt_init: Registering WDT success
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 116k freed
====>slow_led_expire 621: here
===>slow_led_expire 625: off
init started:  BusyBox v1.01 (2011.04.01-07:49+0000) multi-call binary
====>slow_led_expire 621: here
===>slow_led_expire 636: on
This Board use 2.6.31
xt_time: kernel timezone is -0000
nf_conntrack version 0.5.0 (512 buckets, 5120 max)
====>slow_led_expire 621: here
===>slow_led_expire 625: off
ip_tables: (C) 2000-2006 Netfilter Core Team
insmod: cannot open module `/lib/modules/2.6.31/kernel/iptable_raw.ko': No such file or directory
====>slow_led_expire 621: here
===>slow_led_expire 636: on
insmod: cannot open module `/lib/modules/2.6.31/kernel/flashid.ko': No such file or directory
PPPoL2TP kernel driver, V1.0
PPTP driver version 0.8.3
insmod: cannot open module `/lib/modules/2.6.31/kernel/harmony.ko': No such file or directory
====>slow_led_expire 621: here
===>slow_led_expire 625: off

 (none) mips #128 Fri Aug 26 14:58:53 CST 2011 (none)
(none) login: Now flash open!
Now flash open!
====>slow_led_expire 621: here
===>slow_led_expire 636: on
ATHR_GMAC: Length per segment 1536
ATHR_GMAC: fifo cfg 3 01f00140
ATHR_GMAC: Mac address for unit 1:bf1f0006
ATHR_GMAC: 12:64:c3:58:67:a4 
ATHR_GMAC: Max segments per packet :   1
ATHR_GMAC: Max tx descriptor count :   40
ATHR_GMAC: Max rx descriptor count :   96
ATHR_GMAC: Mac capability flags    :   4D83
ATHR_GMAC: Mac address for unit 0:bf1f0000
ATHR_GMAC: 01:9c:b5:c8:b7:c9 
====>slow_led_expire 621: here
===>slow_led_expire 625: off
ATHR_GMAC: Max segments per packet :   1
ATHR_GMAC: Max tx descriptor count :   40
ATHR_GMAC: Max rx descriptor count :   252
ATHR_GMAC: Mac capability flags    :   4403
athr_gmac_ring_alloc Allocated 640 at 0x81e77800
athr_gmac_ring_alloc Allocated 4032 at 0x81d63000
Setting Drop CRC Errors, Pause Frames and Length Error frames 
Setting PHY...mac 0
====>slow_led_expire 621: here
===>slow_led_expire 636: on
====>slow_led_expire 621: here
===>slow_led_expire 625: off
====>slow_led_expire 621: here
===>slow_led_expire 636: on
athr_gmac_ring_alloc Allocated 640 at 0x81e77400
athr_gmac_ring_alloc Allocated 1536 at 0x81f25000
====>slow_led_expire 621: here
===>slow_led_expire 625: off
====>slow_led_expire 621: here
===>slow_led_expire 636: on
athr_gmac_mii_setup: MDC check failed
Setting Drop CRC Errors, Pause Frames and Length Error frames 
ATHRS26: resetting s26
ATHRS26: s26 reset done
Setting PHY...mac 1
====>slow_led_expire 621: here
===>slow_led_expire 625: off
device eth0 entered promiscuous mode
Now flash open!
====>slow_led_expire 621: here
===>slow_led_expire 636: on
====>slow_led_expire 621: here
===>slow_led_expire 625: off
====>slow_led_expire 621: here
===>slow_led_expire 636: on
nf_conntrack_rtsp v0.6.21 loading
nf_nat_rtsp v0.6.21 loading
====>slow_led_expire 621: here
===>slow_led_expire 625: off
asf: module license 'Proprietary' taints kernel.
Disabling lock debugging due to kernel taint
====>slow_led_expire 621: here
===>slow_led_expire 636: on
ath_hal: 0.9.17.1 (AR9380, DEBUG, REGOPS_FUNC, WRITE_EEPROM, 11D)
ath_rate_atheros: Copyright (c) 2001-2005 Atheros Communications, Inc, All Rights Reserved
ath_dev: Copyright (c) 2001-2007 Atheros Communications, Inc, All Rights Reserved
====>slow_led_expire 621: here
===>slow_led_expire 625: off
====>slow_led_expire 621: here
ath_ahb: 9.2.0_U5.508 (Atheros/multi-bss)
Boostrap clock 25MHz
ar9300RadioAttach: Need analog access recipe!!
Restoring Cal data from Flash
ath_get_caps[4735] rx chainmask mismatch actual 1 sc_chainmak 0
ath_get_caps[4710] tx chainmask mismatch actual 1 sc_chainmak 0
wifi0: Atheros 9380: mem=0xb8100000, irq=2
wlan_vap_create : enter. devhandle=0x80c042c0, opmode=IEEE80211_M_HOSTAP, flags=0x1
wlan_vap_create : exit. devhandle=0x80c042c0, opmode=IEEE80211_M_HOSTAP, flags=0x1.
VAP device ath0 created 
 
 DES SSID SET=TP-LINK_620550 
ieee80211_scan_unregister_event_handler: Failed to unregister evhandler=c0a048a0 arg=81fa8ac0
wlan_vap_delete : enter. vaphandle=0x80e60000
wlan_vap_delete : exit. vaphandle=0x80e60000
wlan_vap_create : enter. devhandle=0x80c042c0, opmode=IEEE80211_M_HOSTAP, flags=0x1
wlan_vap_create : exit. devhandle=0x80c042c0, opmode=IEEE80211_M_HOSTAP, flags=0x1.
VAP device ath0 created 
 
 DES SSID SET=TP-LINK_620550 
 ieee80211_ioctl_siwmode: imr.ifm_active=393856, new mode=3, valid=1 
WARNING: Fragmentation with HT mode NOT ALLOWED!!
device ath0 entered promiscuous mode
br0: port 2(ath0) entering forwarding state
 ieee80211_ioctl_siwmode: imr.ifm_active=1442432, new mode=3, valid=1 
br0: port 2(ath0) entering disabled state
 
 DES SSID SET=TP-LINK_620550 
br0: port 2(ath0) entering forwarding state

I have already run an OpenWRT on it,but have some bugs, sysupgrade not work, and I can't find sysled's gpio, so sysled not work.

WR1043ND  WR941N  WR840N  WR741N  FW150R  WR703N  etc...

Re: Tp-link Tl-wr703n

Wow, that is a fantastically small device. I can't help with your issues I'm afraid, but would like to see full OpenWRT support for this. If I can acquire one, I'll happily contribute it to the developers.

Thanks,

Sam

Re: Tp-link Tl-wr703n

dyq - I have been told that the WR703N will be available in the US in the next few weeks. I see it is already available on one website (volumerates.com). I've ordered a few for testing, and have already arranged to donate one to juhosg (who maintains Atheros support on OpenWRT). I expect them to arrive with me in the next week or so.

Interestingly I see that you got OpenWRT working with the WR740N v5, which also uses the AR9331 chipset (http://www.right.com.cn/forum/thread-52644-1-1.html). Did you encounter any issues?

Thanks,

Sam

Re: Tp-link Tl-wr703n

sysupgrade fixed.
but i found another bug: usb not work..
It seems usb driver installed successfully,but i can't found usb device in dmesg.

WR1043ND  WR941N  WR840N  WR741N  FW150R  WR703N  etc...

Re: Tp-link Tl-wr703n

did you install ohci or uhci ?

6 (edited by dyq 2011-09-07 15:29:45)

Re: Tp-link Tl-wr703n

#3
i just updated 703n's firmware on that topic
i changed FW150R's flash(2MB>4MB) and ram(16M>32M), using 703n's uboot
however, i broken FW150R's ttl(aka Serial) because of careless...

#5
dmesg info

Linux version 2.6.39.4 (dyq@dyq-desktop) (gcc version 4.5.4 20110808 (prerelease) (Linaro GCC 4.5-2011.08) ) #1 Wed Sep 7 20:48:04 CST 2011
prom: fw_arg0=00000007, fw_arg1=a1f8ffb0, fw_arg2=a1f90460, fw_arg3=00000004
MyLoader: sysp=00d73bc7, boardp=ed0c292e, parts=97cba183
bootconsole [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
SoC: Atheros AR9330 rev 1
Clocks: CPU:400.000MHz, DDR:400.000MHz, AHB:200.000MHz, Ref:25.000MHz
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
On node 0 totalpages: 8192
free_area_init_node: node 0, pgdat 802b6800, node_mem_map 81000000
  Normal zone: 64 pages used for memmap
  Normal zone: 0 pages reserved
  Normal zone: 8128 pages, LIFO batch:0
pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
pcpu-alloc: [0] 0 
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line:  board=TL-WR703N console=ttyATH0,115200 rootfstype=squashfs,jffs2 noinitrd
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 29376k/32768k available (2009k kernel code, 3392k reserved, 386k data, 180k init, 0k highmem)
SLUB: Genslabs=9, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
NR_IRQS:80
Calibrating delay loop... 265.42 BogoMIPS (lpj=1327104)
pid_max: default: 32768 minimum: 301
Mount-cache hash table entries: 512
NET: Registered protocol family 16
MIPS: machine is TP-LINK TL-WR703N v1 by dyq
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
UDP hash table entries: 256 (order: 0, 4096 bytes)
UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
NET: Registered protocol family 1
PCI: CLS 0 bytes, default 32
squashfs: version 4.0 (2009/01/31) Phillip Lougher
JFFS2 version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
ar933x-uart: ttyATH0 at MMIO 0x18020000 (irq = 11) is a AR933X UART
console [ttyATH0] enabled, bootconsole disabled
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: found s25sl032a, expected m25p80
m25p80 spi0.0: s25sl032a (4096 Kbytes)
spi0.0: searching for MyLoader partition table at offset 0x10000
spi0.0: searching for MyLoader partition table at offset 0x20000
spi0.0: searching for MyLoader partition table at offset 0x30000
spi0.0: searching for MyLoader partition table at offset 0x40000
spi0.0: no MyLoader partition table found
Searching for RedBoot partition table in spi0.0 at offset 0x3e0000
Searching for RedBoot partition table in spi0.0 at offset 0x3f0000
No RedBoot partition table detected in spi0.0
spi0.0: no WRT160NL signature found
Creating 6 MTD partitions on "spi0.0":
0x000000000000-0x000000020000 : "u-boot"
0x000000020000-0x000000120000 : "kernel"
0x000000120000-0x0000003f0000 : "rootfs"
mtd: partition "rootfs" set to be root filesystem
mtd: partition "rootfs_data" created automatically, ofs=2E0000, len=110000 
0x0000002e0000-0x0000003f0000 : "rootfs_data"
0x0000003f0000-0x000000400000 : "art"
0x000000020000-0x0000003f0000 : "firmware"
0x000000000000-0x000000400000 : "fullflash"
ag71xx_mdio: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
eth0: using fixed link parameters
Atheros AR71xx hardware watchdog driver version 0.1.0
ar71xx-wdt: timeout=15 secs (max=171)
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <greearb@candelatech.com>
All bugs added by David S. Miller <davem@redhat.com>
VFS: Mounted root (squashfs filesystem) readonly on device 31:2.
Freeing unused kernel memory: 180k freed
input: gpio-keys-polled as /devices/platform/gpio-keys-polled/input/input0
Button Hotplug driver version 0.4.1
eth0: link up (100Mbps/Full duplex)
Registered led device: tl-wr703n:blue:system
JFFS2 notice: (377) jffs2_build_xattr_subsystem: complete building xattr subsystem, 21 of xdatum (0 unchecked, 20 orphan) and 38 of xref (0 dead, 20 orphan) found.
eth0: link down
eth0: link up (100Mbps/Full duplex)
device eth0 entered promiscuous mode
br-lan: port 1(eth0) entering forwarding state
br-lan: port 1(eth0) entering forwarding state
Compat-wireless backport release: compat-wireless-2011-08-25
Backport based on wireless-testing.git master-2011-08-26
cfg80211: Calling CRDA to update world regulatory domain
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
ath: EEPROM regdomain: 0x0
ath: EEPROM indicates default country code should be used
ath: doing EEPROM country->regdmn map search
ath: country maps to regdmn code: 0x3a
ath: Country alpha2 being used: US
ath: Regpair used: 0x3a
ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
Registered led device: ath9k-phy0
ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
cfg80211: World regulatory domain updated:
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2457000 KHz - 2482000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211: Calling CRDA for country: US
PPP generic driver version 2.4.2
ip_tables: (C) 2000-2006 Netfilter Core Team
cfg80211: Regulatory domain changed to country: US
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm)
cfg80211:     (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm)
cfg80211:     (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm)
NET: Registered protocol family 24
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
ar71xx-ehci ar71xx-ehci: Atheros AR91xx built-in EHCI controller
ar71xx-ehci ar71xx-ehci: new USB bus registered, assigned bus number 1
ar71xx-ehci ar71xx-ehci: irq 3, io mem 0x1b000000
ar71xx-ehci ar71xx-ehci: USB 2.0 started, EHCI 1.00
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 1 port detected
nf_conntrack version 0.5.0 (461 buckets, 1844 max)
cfg80211: Calling CRDA for country: CN
cfg80211: Regulatory domain changed to country: CN
cfg80211:     (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp)
cfg80211:     (2402000 KHz - 2482000 KHz @ 40000 KHz), (N/A, 2000 mBm)
cfg80211:     (5735000 KHz - 5835000 KHz @ 40000 KHz), (N/A, 3000 mBm)
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
br-lan: port 2(wlan0) entering forwarding state
device wlan0 left promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
device wlan0 entered promiscuous mode
br-lan: port 2(wlan0) entering forwarding state
br-lan: port 2(wlan0) entering forwarding state
ar71xx-wdt: enabling watchdog timer
ar71xx-wdt: timeout=60 secs

i installed kmod-usb2 and also added ar71xx_add_device_usb in mach

WR1043ND  WR941N  WR840N  WR741N  FW150R  WR703N  etc...

Re: Tp-link Tl-wr703n

can't wait to get my hands on one of those - just ordered a few from taobao.
'till it arrives i hope it will be fully supported by openwrt

Re: Tp-link Tl-wr703n

My order from volumerates.com has been shipped now (from Hong Kong). Hopefully they'll arrive next week.

9 (edited by kohain 2011-09-15 09:06:13)

Re: Tp-link Tl-wr703n

Hope it will be perfectly supported with Openwrt soon.
The one of mine is on the way.

10 (edited by samcrawford 2011-09-15 15:17:12)

Re: Tp-link Tl-wr703n

Mine arrived today, and I've already sent one to juhosg (the main Atheros maintainer for OpenWRT). I'll be experimenting with the other ones myself later this week.

Thanks,

Sam

Re: Tp-link Tl-wr703n

samcrawford?How about the progress?

Re: Tp-link Tl-wr703n

there is a firmware compiled for this device dated back two weeks ago http://u.115.com/file/dn3quy29#
i understood that there is a problem with the led and USB not being reconized.
i will try it this evening and report back

Re: Tp-link Tl-wr703n

maurer - You may want to hold on... something tells me that full support may be coming to this device very very soon smile

Keep your eyes on the ticket that dyq raised (https://dev.openwrt.org/ticket/10106) - it's been accepted by juhosg now.

Re: Tp-link Tl-wr703n

samcrawford wrote:

maurer - You may want to hold on... something tells me that full support may be coming to this device very very soon smile

Keep your eyes on the ticket that dyq raised (https://dev.openwrt.org/ticket/10106) - it's been accepted by juhosg now.

Great news! Hope 8187L will be support via USB.

Re: Tp-link Tl-wr703n

Now that's GREAT NEWS !!!!
Author: juhosg
Message: ar71xx: build images for the TP-Link TL-WR703N v1 board
https://dev.openwrt.org/changeset/28279
can't wait to make new build!

Re: Tp-link Tl-wr703n

Absolutely, I'm checking out the updates right now... USB support included too smile

I think we all owe juhosg and dyq a beer!

Re: Tp-link Tl-wr703n

sam, can you please post your build?
I cannot build it for at least 4 hours - i'm on a win7 laptop.

Re: Tp-link Tl-wr703n

No problem, just building it from new at the moment. Give me 20-30 minutes.

Re: Tp-link Tl-wr703n

The build's taking much longer than normal (lots of updates since I last checked out trunk), but I'll post it as soon as it's ready...

20 (edited by samcrawford 2011-09-21 15:47:22)

Re: Tp-link Tl-wr703n

Here you go: http://80.77.246.44/~sam/openwrt/tl-wr7 … actory.bin

This incorporates juhosg's latest changes (including USB support) and is at revision 28279.

Note that I've not tried this myself yet (my wr703n is sitting at home, but I'll be trying it tonight).

Thanks,

Sam

Re: Tp-link Tl-wr703n

samcrawford wrote:

Here you go: http://80.77.246.44/~sam/openwrt/tl-wr7 … actory.bin

This incorporates juhosg's latest changes (including USB support) and is at revision 28279.

Note that I've not tried this myself yet (my wr703n is sitting at home, but I'll be trying it tonight).

Thanks,

Sam

Thanks for the firmware.

But what's the default username and pass?

I flashed it. Found root & admin can't get in.

Re: Tp-link Tl-wr703n

Look at the OpenWRT wiki... You should telnet to 192.168.1.1 first. It won't ask for a password. Once you set a password you can access the device via SSH or via a web browser.

Thanks,

Sam

23 (edited by moviefuns 2011-09-21 17:31:51)

Re: Tp-link Tl-wr703n

Got it.
I used ssh after the first reboot.
After a reset, I found no ssh and telnet. Then I realized the empty pass method.
Thanks. Good job. The new firmware makes 703n as tiny 3G router and traveling NAS.

24

Re: Tp-link Tl-wr703n

I compiled one with luci and restorefactory
http://115.com/file/dn8qx6h6#
Note: the default language of luci is Chinese

WR1043ND  WR941N  WR840N  WR741N  FW150R  WR703N  etc...

25

Re: Tp-link Tl-wr703n

I found another bug that log spamming like

Sep  9 00:20:59 TP-LINK daemon.info init: process '/bin/ash --login' (pid 2468) exited. Scheduling for restart.
Sep  9 00:20:59 TP-LINK daemon.info init: starting pid 2473, tty '/dev/ttyS0': '/bin/ash --login'

it can be simply fixed by delete'ttyS0::askfirst:/bin/ash --login' in '/etc/inittab', but maybe not the good way to fix it

WR1043ND  WR941N  WR840N  WR741N  FW150R  WR703N  etc...