1 (edited by cheche 2012-11-13 01:00:50)

Topic: Support for Huawei HG553

This is a thread for the status of support on the HG553. You can find how to install on the wiki
http://wiki.openwrt.org/toh/huawei/hg553
Please subscribe to this topic  to get new updates.

What is missing.
ASDL Driver
VOIP Driver

Other problems
Power led keep on RED.
LAN Negotiate at 10 Mbps

Re: Support for Huawei HG553

done

Re: Support for Huawei HG553

Just wondering does the hg553 have voip drivers for the 2 telephone jacks on the back of the unit? and how would i go about setting it up? do i just install the voice software under luCI (I am running this as my web gui) I have 2 different voip providers in 2 different countries,

4 (edited by dk_giuse89 2011-09-03 10:20:59)

Re: Support for Huawei HG553

stevie7303215 wrote:

Just wondering does the hg553 have voip drivers for the 2 telephone jacks on the back of the unit? and how would i go about setting it up? do i just install the voice software under luCI (I am running this as my web gui) I have 2 different voip providers in 2 different countries,

Voip don't work with openwrt because openwrt kernel don't include voip drivers. Has need patch

Re: Support for Huawei HG553

especially OpenWrt makes it easy to patch stuff yourself.

http://wiki.openwrt.org/about/toolchain
http://wiki.openwrt.org/doc/devel/patches

Do you have patches for VoIP?

Re: Support for Huawei HG553

Its a great modem router, I currently have 3g and a usb hard drive attached. I also have lynksys wrtg54v with ddwrt, and the hg533 out preforms it easily. Soooo if someone isnt busy one weekend the patch would be cool and make it a all round router smile, I wish I wasnt such a noob with linux sad

Re: Support for Huawei HG553

1.So currently there is not voip support in openwrt?
2.And can i login(via ssh/telnet/cable/etc) to device with  root privs. in  default firmware?

Re: Support for Huawei HG553

dk_giuse89 wrote:

done

has the the hg553 jfs image have the adsl driver? Do i need to install any mods to make it work?

9 (edited by cncaihua 2011-09-29 09:41:10)

Re: Support for Huawei HG553

A speed limit of about 60KB/s was met when using ChinaMobile TD-SCDMA network and a 3G  USB dongle.To fix it ,we need a patch to usbserial .here is the link
http://blog.csdn.net/crob/article/details/5307245
http://wl500g.info/showthread.php?t=7318

Re: Support for Huawei HG553

cheche wrote:

This is a thread for the status of support on the HG553. You can find how to install on the wiki
http://wiki.openwrt.org/toh/huawei/hg553
Please subscribe to this topic  to get new updates.

What is missing.
ASDL driver
Power led keep on RED.

After upload i leave the router reboot , the LED power light switchs to red from blue and the router stops /freezes .
Sometimes the lan connection drops and reconnects and i can't access the 192.168.1.1 http interface page. Is this bricked?
But i can reflash with vodafone firmware using the resest safety feature.
Does openwrt work well on this router?

Re: Support for Huawei HG553

POCGOC wrote:
cheche wrote:

This is a thread for the status of support on the HG553. You can find how to install on the wiki
http://wiki.openwrt.org/toh/huawei/hg553
Please subscribe to this topic  to get new updates.

What is missing.
ASDL driver
Power led keep on RED.

After upload i leave the router reboot , the LED power light switchs to red from blue and the router stops /freezes .
Sometimes the lan connection drops and reconnects and i can't access the 192.168.1.1 http interface page. Is this bricked?
But i can reflash with vodafone firmware using the resest safety feature.
Does openwrt work well on this router?

image is built without LuCI,you need to install it yourself.

Re: Support for Huawei HG553

POCGOC wrote:
cheche wrote:

This is a thread for the status of support on the HG553. You can find how to install on the wiki
http://wiki.openwrt.org/toh/huawei/hg553
Please subscribe to this topic  to get new updates.

What is missing.
ASDL driver
Power led keep on RED.

After upload i leave the router reboot , the LED power light switchs to red from blue and the router stops /freezes .
Sometimes the lan connection drops and reconnects and i can't access the 192.168.1.1 http interface page. Is this bricked?
But i can reflash with vodafone firmware using the resest safety feature.
Does openwrt work well on this router?

I am having the same issues, I can install the default vodaphone or a hacked version, but when I install openwrt it wont let me telnet into 192.168.1.1,

I did install openwrt on this router a couple times before. I always reflash with the original hg553 firmware before I try to reinstall openwrt.

is there a nvram setting I can clear that the previous openwrt install left behind?

Re: Support for Huawei HG553

Hi guys,
Question voip:
Anyone have/or can be accessed at dump of original flash, can post link to download of compressed root?

I wanna see if voip driver are included as moduls of kernel. In this case, compiling openwrt kernel with the same verrsion of the moduls voip maybe can to work...

Re: Support for Huawei HG553

cncaihua wrote:
POCGOC wrote:
cheche wrote:

This is a thread for the status of support on the HG553. You can find how to install on the wiki
http://wiki.openwrt.org/toh/huawei/hg553
Please subscribe to this topic  to get new updates.

What is missing.
ASDL driver
Power led keep on RED.

After upload i leave the router reboot , the LED power light switchs to red from blue and the router stops /freezes .
Sometimes the lan connection drops and reconnects and i can't access the 192.168.1.1 http interface page. Is this bricked?
But i can reflash with vodafone firmware using the reset safety feature.
Does openwrt work well on this router?

image is built without LuCI,you need to install it yourself.

no ip address of gateway settings are acquired.
tried to telnet to 192.168.1.1
no response , no WiFi from router now.
I'm beginning to think its only supporting the Spanish hg553 not the Italian release router.

Is Jtag method of installation any better to use than installing by 192.168.1.1 flash upgrade?

15 (edited by dk_giuse89 2011-10-08 19:46:18)

Re: Support for Huawei HG553

Try this,
content of my archive:
Svn info, log of compiling, .config, and .bin image for each file system.

http://www.megaupload.com/?d=LSIQR1C9

Ciusss89, is my second nickname big_smile.

Re: Support for Huawei HG553

Hello everyone,
i'm trying to configure a LAN port of the HG533 as WAN port but with no success yet.
Reading the wiki and searching by google i came out with this config:

#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

#### WAN configuration               
config interface        wan       
        option ifname   "eth0.1"
        option proto    dhcp 

#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0

#### VLAN configuration
config switch eth0
        option vlan0    '1 2 3 5*'
        option vlan1    '0 5'

But i'm still not getting any WAN interface in any switch port. What i can't understand is also the original eth1 interface, that comes with the original firmware, what it refers to.
Can anyone help me? Thx big_smile

Re: Support for Huawei HG553

In mai config, i have set, two ethernet as wan, and 2 as lan,

root@VodafoneStation:~# cat /etc/config/network 

config 'interface' 'loopback'
    option 'ifname' 'lo'
    option 'proto' 'static'
    option 'ipaddr' '127.0.0.1'
    option 'netmask' '255.0.0.0'

config 'switch' 'eth1'
    option 'enable' '1'
    option 'enable_vlan' '1'
    option 'reset' '1'

config 'switch_vlan' 'vlan0'
    option 'vlan' '0'
    option 'device' 'eth1'
    option 'ports' '0 5*'

config 'switch_vlan' 'vlan1'
    option 'vlan' '1'
    option 'device' 'eth1'
    option 'ports' '3 5t'

config 'switch_vlan' 'vlan2'
    option 'vlan' '2'
    option 'device' 'eth1'
    option 'ports' '2 5t'

config 'switch_vlan' 'vlan3'
    option 'vlan' '3'
    option 'device' 'eth1'
    option 'ports' '1 5t'

config 'interface' 'lan'
    option 'type' 'bridge'
    option 'proto' 'static'
    option 'netmask' '255.255.255.0'
    option 'ifname' 'eth1.0 eth1.3 wl0'
    option 'ipaddr' '192.168.100.20'
    option 'ip6addr' '2001:X:X::1/48'

config 'interface' 'wan2'
    option 'ifname' 'eth1.1'
    option 'proto' 'dhcp'
    option 'macaddr' '00:00:00:00:00:1B'
    option 'dns' '192.168.1.1'

config 'interface' 'wan'
        option 'ifname' 'eth1.2'
        option 'proto' 'dhcp'
        option 'macaddr' '00:00:00:00:00:1A'
        option 'dns' '192.168.10.2'

config 'interface' 'ayiya'
    option 'proto' 'none'
    option 'ifname' '6Stun'

config 'interface' 'freenet'
    option 'proto' 'none'
    option 'ifname' '6Gtun'

root@VodafoneStation:~#

Re: Support for Huawei HG553

Hi, there's any chance to make adsl work on this router?

Re: Support for Huawei HG553

In mai config, i have set, two ethernet as wan, and 2 as lan

ty very much, i was using old/wrong syntax. any chance to get hw buttons working?

Re: Support for Huawei HG553

guys, where i can find dump of original flash??

Re: Support for Huawei HG553

Hi
I have this router with the latest versions of openwrt installed (trunk branch).
It works perfect, use it as a torrent client. ftp server, samba server, etc.
Unfortunately at times, and after rebooting, the router goes into 'recovery', losing the firmware and configuration.
Anyone have idea why is it?

22 (edited by chc 2011-12-19 19:52:04)

Re: Support for Huawei HG553

Hi all,
I'm new in this forum and probably my questions have easy answer for you...

I've installed openwrt-HW553-jffs2-64k-cfe.bin on my VS and it works fine; now I want to install mochad (http://sourceforge.net/apps/mediawiki/mochad/index.php?title=OpenWrt ... this is an how-to easy to adapt to backfire... ) so I prepared my work environnemend to add mochad feed and everything looks to be right... I can see the mochad entry in the utilities sub-tree!

My problem is that I would like to have all features present in the original openwrt-HW553-jffs2-64k-cfe.bin image and just add my mochad "extension" but I cannot find any .config file and/or feeds list used to make that image!!!
(I found the image here --> http://downloads.openwrt.org/snapshots/trunk/brcm63xx/openwrt-HW553-jffs2-64k-cfe.bin )

In few words I would like to have the starting .config of the openwrt-HW553-jffs2-64k-cfe.bin in order to load it before personalize my firmware, DO YOU KNOW WHERE CAN I FIND IT?!?

Few post up I saw the dk_giuse89's message and his megaupload (http://www.megaupload.com/?d=LSIQR1C9), it should be perfect but it looks strange that my file openwrt-HW553-jffs2-64k-cfe.bin is about 3.2MB, that one in the package is 13MB... so probably they come from different .config...

Tnx to all!!

Re: Support for Huawei HG553

Hi,

I have installed openwrt. And installed a LuCI Web. I pressed reset button and now I can't either ssh or telnet. Even cannot log via LuCI. DHCP is not working. I put LAN IP address manually and I can ping to route ip. Is there any tool to reinstall firmware without serial cable since I dont have serial cable. Please help me to resolve this.

Thank you in advance

Re: Support for Huawei HG553

dhammika wrote:

Hi,
Is there any tool to reinstall firmware without serial cable since I dont have serial cable.

Hold reset for 30 seconds and manual set your ip to 192.168.0.2 then http://192.168.0.1

25 (edited by bahti-k 2013-03-06 16:44:18)

Re: Support for Huawei HG553

Hi,
Sorry tell me where can take the scheme JTAG?
I killed my Huawei HG553((