1 (edited by eleon216 2011-06-07 13:51:52)

Topic: TP-Link TL-WR741ND v2.1 is working

Hi,

I got a new TP-Link TL-WR741ND v2.1. in the wiki http://wiki.openwrt.org/toh/tp-link/tl-wr741nd I read that the version 2.1 is untested. I paid only 17€ so I tested it smile
I flashed trunk (r27122) for TL-WR741ND v1 through the oem-webinterface (without doing a factory reset). The router didn't reboot, and I wasn't able to access it.
After a poweroff (after 10min) I was able to access failsafe-mode but couldn't mount the jffs2-partiton, so I erased the jffs2-partition and after another reboot everything was working fine (LAN, WAN, WIFI).

So I would like to figure out why I had this issues. Is this "normal", or would resetting the oem-firmware before flashing openwrt have fixed this problem?
   
I could modify the wiki but first I would like to figure out, if everyone else will face my upgrade-problems.

But as I said TP-Link TL-WR741ND Version 2.1 is working!

2 (edited by ad_user 2011-06-25 13:41:57)

Re: TP-Link TL-WR741ND v2.1 is working

I confirm the message above. Build r27256 also works, but with notices, exactly as described above: no reboot by itself, firstboot - in failsafe mode, fixing jffs by `firstboot` command.

Also in my case, i was forced to remove "/etc/rc.d/S39usb" to get it working properly.

Factory firmware was (according to page in original web interface):
Firmware Version: 3.12.4 Build 100910 Rel.57694n
Hardware Version: WR741N v1/v2 00000000

UPD: On the bottom label device marked as v2.1.

P.S. Thanks all!

Re: TP-Link TL-WR741ND v2.1 is working

hi, ad_user
good to know that this device really has these problems when upgrading.
I had no problems with sysupgrade from openwrt to openwrt, this happens only the first time when upgrading from stock-firmware to openwrt.

Re: TP-Link TL-WR741ND v2.1 is working

for the failsafe or any other procedures here, did you need a serial cable?

Re: TP-Link TL-WR741ND v2.1 is working

@cconn
No, this operation only requires keep pressing (or even single press) "QSS" button during router's boot time.