OpenWrt Forum Archive

Topic: Should I expect a media server to be seen across a wireless bridge?

The content of this topic has been archived between 6 Apr 2018 and 25 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

I ca't believe it but oem factory firmware for my Tp-link tl-wr-703n did the trick.
setting the router into client AP mode allowed multicast.
tp-link 1 - 0 openwrt smile

Hey there,

I can confirm that igmpproxy does work given that the right configuration is used (using OpenWrt 12.09 on Atheros HW).

In my case the lack of a "local IPv4 address" set for the relay interface caused it to not work. Once I set the address up to be the same as the wireless interface's address (which can be either set manually or assigned statically by a DHCP server), my DLNA server has shown up within a minute or so on my TV (attached to the LAN interface).

My home LAN is on subnet 192.168.0.0/24, the additional (unused) subnet is 192.168.2.0/24.

Contents of /etc/config/network:

config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

config interface 'lan'
    option proto 'static'
    option netmask '255.255.255.0'
    option ipaddr '192.168.2.1'
    option _orig_ifname 'eth0'
    option _orig_bridge 'true'
    option ifname 'eth0'

config interface 'wifi'
    option _orig_ifname 'wlan0'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '192.168.0.2'
    option netmask '255.255.255.0'
    option gateway '192.168.0.1'
    option dns '192.168.0.254'

config interface 'stabridge'
    option proto 'relay'
    list network 'lan'
    list network 'wifi'
    option ipaddr '192.168.0.2'

Contents of /etc/config/igmpproxy:

config igmpproxy
    option quickleave 1

config phyint
    option network wifi
    option direction upstream
    list altnet 192.168.0.0/24

config phyint
    option network lan
    option direction downstream
    list altnet 192.168.0.0/24

For simplicity, I removed the bridge interface (br-lan) as it is not required so my LAN interface is simply mapped to eth0.

Hope this helps some of you.

(Last edited by geryhun on 27 Jul 2014, 19:12)

Sorry to jump in here at the end but I have been following this thread with interest.

We are trying to get Multicast (UPnP) discovery working between our LAN and WAN sides of our router.  We can get it to go one way but not both simultaneously.

Is there any one that has done this or knows how to allow multicast (specifically UPnP discovery) to go LAN->WAN and WAN->LAN without just bridging the WAN and LAN together?

Thank you

(Last edited by reginaldStjohn on 30 Sep 2014, 21:24)

@reginaldStjohn Did you get it setup? I'm after the same thing

The discussion might have continued from here.