1,776 (edited by blinkinek 2011-08-31 13:42:22)

Re: Fully featured OpenWrt build for the WNDR3700

@arokh
I have already installed openswan and some prereq for this package. Is it possible that I setup racoon without installing your test build=

@merkurial
I have done it before as well, this file is laying exactly under /etc/ppp/ip-down.d/10-pptp.sh (I made a reboot after creating it) but it doesn't help...

-rw-r--r--    1 root     root           152 Aug 31 14:25 /etc/ppp/ip-down.d/10-pptp.sh

Here is what is being logged when I'm trying to connect:

Aug 31 14:32:13 OpenWrt daemon.info pptpd[2456]: CTRL: Client 195.226.16.162 control connection started
Aug 31 14:32:13 OpenWrt daemon.info pptpd[2456]: CTRL: Starting call (launching pppd, opening GRE)
Aug 31 14:32:13 OpenWrt daemon.notice pppd[2457]: pppd 2.4.5 started by root, uid 0
Aug 31 14:32:13 OpenWrt daemon.info pppd[2457]: Using interface ppp0
Aug 31 14:32:13 OpenWrt daemon.notice pppd[2457]: Connect: ppp0 <--> /dev/pts/1
Aug 31 14:32:43 OpenWrt daemon.warn pppd[2457]: LCP: timeout sending Config-Requests
Aug 31 14:32:43 OpenWrt daemon.notice pppd[2457]: Connection terminated.
Aug 31 14:32:43 OpenWrt daemon.notice pppd[2457]: Modem hangup
Aug 31 14:32:43 OpenWrt daemon.info pppd[2457]: Exit.
Aug 31 14:32:43 OpenWrt daemon.err pptpd[2456]: GRE: read(fd=6,buffer=41fc30,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Aug 31 14:32:43 OpenWrt daemon.err pptpd[2456]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Aug 31 14:32:43 OpenWrt daemon.debug pptpd[2456]: CTRL: Reaping child PPP[2457]
Aug 31 14:32:43 OpenWrt daemon.info pptpd[2456]: CTRL: Client 195.226.16.162 control connection finished
Aug 31 14:32:43 OpenWrt daemon.err pptpd[2456]: CTRL: Couldn't write packet to client.
Aug 31 14:32:43 OpenWrt daemon.err pptpd[2456]: CTRL: Couldn't write packet to client.

Re: Fully featured OpenWrt build for the WNDR3700

@blinkinek

That could be caused by a simple authentication problem.

Enable ppp's (/etc/ppp/options) and maybe even pptp's (/etc/pptpd.conf) debug mode and post the output.

Re: Fully featured OpenWrt build for the WNDR3700

It doesn't tell me much so I will just paste it ;( Hopefully you understand it better wink

Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: MGR: Launching /usr/sbin/pptpctrl to handle client
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: local address = 192.168.1.90
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: remote address = 192.168.1.91
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: pppd speed = 115200
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: pppd options file = /etc/ppp/options.pptpd
Aug 31 15:40:46 OpenWrt daemon.info pptpd[2459]: CTRL: Client 195.226.16.162 control connection started
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Received PPTP Control Message (type: 1)
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Made a START CTRL CONN RPLY packet
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: I wrote 156 bytes to the client.
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Sent packet to client
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Received PPTP Control Message (type: 7)
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Set parameters to 100000000 maxbps, 64 window size
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Made a OUT CALL RPLY packet
Aug 31 15:40:46 OpenWrt daemon.info pptpd[2459]: CTRL: Starting call (launching pppd, opening GRE)
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: pty_fd = 6
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: tty_fd = 7
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: I wrote 32 bytes to the client.
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Sent packet to client
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2460]: CTRL (PPPD Launcher): program binary = /usr/sbin/pppd
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2460]: CTRL (PPPD Launcher): local address = 192.168.1.90
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2460]: CTRL (PPPD Launcher): remote address = 192.168.1.91
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Received PPTP Control Message (type: 15)
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: CTRL: Got a SET LINK INFO packet with standard ACCMs
Aug 31 15:40:46 OpenWrt daemon.notice pppd[2460]: pppd 2.4.5 started by root, uid 0
Aug 31 15:40:46 OpenWrt daemon.debug pppd[2460]: using channel 1
Aug 31 15:40:46 OpenWrt daemon.info pppd[2460]: Using interface ppp0
Aug 31 15:40:46 OpenWrt daemon.notice pppd[2460]: Connect: ppp0 <--> /dev/pts/1
Aug 31 15:40:46 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:40:46 OpenWrt daemon.debug pptpd[2459]: GRE: accepting packet #0
Aug 31 15:40:46 OpenWrt daemon.debug pppd[2460]: rcvd [LCP ConfReq id=0x0 <mru 1400> <magic 0x55bc24dd> <pcomp> <accomp> <callback CBCP>]
Aug 31 15:40:46 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfRej id=0x0 <pcomp> <accomp> <callback CBCP>]
Aug 31 15:40:49 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:40:52 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:40:55 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:40:58 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:01 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:04 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:07 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:10 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:13 OpenWrt daemon.debug pppd[2460]: sent [LCP ConfReq id=0x1 <mru 1482> <auth chap MS-v2> <magic 0x253bf2cc>]
Aug 31 15:41:16 OpenWrt daemon.warn pppd[2460]: LCP: timeout sending Config-Requests
Aug 31 15:41:16 OpenWrt daemon.notice pppd[2460]: Connection terminated.
Aug 31 15:41:16 OpenWrt daemon.notice pppd[2460]: Modem hangup
Aug 31 15:41:16 OpenWrt daemon.info pppd[2460]: Exit.
Aug 31 15:41:16 OpenWrt daemon.err pptpd[2459]: GRE: read(fd=6,buffer=41fc30,len=8196) from PTY failed: status = -1 error = Input/output error, usually caused by unexpected termination of pppd, check option syntax and pppd logs
Aug 31 15:41:16 OpenWrt daemon.err pptpd[2459]: CTRL: PTY read or GRE write failed (pty,gre)=(6,7)
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2459]: CTRL: Reaping child PPP[2460]
Aug 31 15:41:16 OpenWrt daemon.info pptpd[2459]: CTRL: Client 195.226.16.162 control connection finished
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2459]: CTRL: Exiting with active call
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2459]: CTRL: Made a CALL DISCONNECT RPLY packet
Aug 31 15:41:16 OpenWrt daemon.err pptpd[2459]: CTRL: Couldn't write packet to client.
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2459]: CTRL: Made a STOP CTRL REQ packet
Aug 31 15:41:16 OpenWrt daemon.err pptpd[2459]: CTRL: Couldn't write packet to client.
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2459]: CTRL: Exiting now
Aug 31 15:41:16 OpenWrt daemon.debug pptpd[2376]: MGR: Reaped child 2459

1,779 (edited by merkurial 2011-08-31 14:47:17)

Re: Fully featured OpenWrt build for the WNDR3700

Hmm, the problem is indeed within ppp:

Aug 31 15:41:16 OpenWrt daemon.warn pppd[2460]: LCP: timeout sending Config-Requests

However I don't know how to fix it. This is not the gre kernel issue.

Where are you trying to connect from?

1,780

Re: Fully featured OpenWrt build for the WNDR3700

That's the exact same problem I got with my iphone if I'm not mistaken. Only way to fix it was to reboot the phone, then it would connect the first time.

Re: Fully featured OpenWrt build for the WNDR3700

Hmm I'm connecting from my company's network. I've just tried it with my iphone over 3g and it's working! wink

Do you have any clue what might be wrong with the network here? Some incoming ports are blocked?

Re: Fully featured OpenWrt build for the WNDR3700

As far as ports blocked, I don't think that's the problem, since you reach the pptp server.

Maybe you're going through some kind of proxy which interferes with the connection. After all the error is really a timeout.

It is the mschap-v2 request which is not being answered by the machine you're connecting from.

Try changing the authentication method (all the require-*/refuse-* in /etc/options.pptpd).

Do you have a WiFi at your company to which you could connect the iPhone and try connecting that way instead of using 3G?
We could at least see whether the problem is in the machine or the network.

Re: Fully featured OpenWrt build for the WNDR3700

I've already tried it with WiFi and received the same error. I will try changing the authentication method and let you know. Thanks.

1,784

Re: Fully featured OpenWrt build for the WNDR3700

Sorry for the stupid question - but am I right in guessing that the daily builds have stopped (in the main download directory) unless there's something significant changed in the trunk?  I probably missed the thread a few pages back, but is the 'test' folder just experimental stuff?

1,785

Re: Fully featured OpenWrt build for the WNDR3700

@arokh. Yes I'm able to reproduce my wifi problem, but I can't see anything in the standard log that would indicate this problem. Is there a different log that I should be looking at? I've seen quite  a few changes in ath9k that were committed in the past few days should I wait for a newer build with these?

1,786

Re: Fully featured OpenWrt build for the WNDR3700

@blinkinek

If it works through 3G then obviously nothing is wrong with your pptp server, rather your company's wifi doesn't support GRE passthrough.

@donatom3

Hard to say, there's always ath9k fixes in trunk who knows what they are actually fixing.

1,787

Re: Fully featured OpenWrt build for the WNDR3700

@donatom I'm having a similar problem with r28057.  After flashing, everything works fine, but once I enable the wide channel on the N radio, the router becomes unresponsive (can't even ping it over ethernet).  If leave the channel setting alone, the router seems stable.  I am able to undo it by reflashing the firmare or by rebooting the router and turning off wifi with the h/w switch as soon as the N (blue) radio light comes on.  Then I can ssh/luci in and undo the channel width setting before re-enabling wifi.  If you wait too long to turn off wifi, the router again becomes unresponsive, so a little bit of a race condition there.  I have a wndr3700v2 bought just a few days ago.  Hoping for a new build soon in the hopes that the ath9k fixes in trunk resolve the problem.

1,788 (edited by dusty_wrt54g 2011-09-02 23:04:10)

Re: Fully featured OpenWrt build for the WNDR3700

Is anyone else seeing periodic hyperactive wireless authentication with ipods/iphones/ipads?  Stuff like this on the 2.4 ghz radio using channel 1 with 40 mhz width with WPA2 PSK (CCMP) encryption is a frequent occurrence with our idevices.  They seem to have a bit of lag at times, although I don't seem to see that with our wireless laptops:

Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-00000049
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004A
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004B
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004C
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004D
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:44:36 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:44:36 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:44:37 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004E
Sep  2 17:44:37 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004F
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)

This could also be something odd with Apple's wifi implementation since I would periodically get "WLAN access rejected: incorrect security" errors from properly configured ipods when my WNDR3700 v1 was running stock Netgear firmware.

I'm also wondering if some of those atheros fixes in the trunk build may help with some of this.

Re: Fully featured OpenWrt build for the WNDR3700

dusty_wrt54g wrote:

Is anyone else seeing periodic hyperactive wireless authentication with ipods/iphones/ipads?  Stuff like this on the 2.4 ghz radio using channel 1 with 40 mhz width with WPA2 PSK (CCMP) encryption is a frequent occurrence with our idevices.  They seem to have a bit of lag at times, although I don't seem to see that with our wireless laptops:

Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-00000049
Sep  2 17:43:12 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004A
Sep  2 17:43:30 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004B
Sep  2 17:43:34 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004C
Sep  2 17:43:40 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004D
Sep  2 17:44:24 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:44:36 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:44:36 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:44:37 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004E
Sep  2 17:44:37 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: authenticated
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx IEEE 802.11: associated (aid 4)
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx RADIUS: starting accounting session 4E5D777E-0000004F
Sep  2 17:45:21 WNDR3700 daemon.info hostapd: wlan0: STA xx:xx:xx:xx:xx:xx WPA: pairwise key handshake completed (RSN)

This could also be something odd with Apple's wifi implementation since I would periodically get "WLAN access rejected: incorrect security" errors from properly configured ipods when my WNDR3700 v1 was running stock Netgear firmware.

I'm also wondering if some of those atheros fixes in the trunk build may help with some of this.

I'm using "option encryption psk2" here, with HT20, and no big problems with lots of associations.

Have you tried erasing the network config on the device and have it re-detect the type of security and network settings? I find that often the saved settings expect a different type of network security (TKIP) from when I previously configured the network.

I'm not using arohk's build, but a newer one I compiled based on 28096. From what I can gather, the changes were related to decreasing the amount of buffers in the wireless stack (to improve latency under load).

It seems lots of changes are going into ath9k right now. I might wait a while for it to stabilize before making another build.

Overall though, even with my WRT54GL using Tomato, I remember the iPod's and iPhone frequently losing connection and reassociating. They did spam the log a lot.

You may want to try increasing the DHCP lease, perhaps it's too short for them? (unrelated to authentication, but it could help with slow connecting after the timeout).

Re: Fully featured OpenWrt build for the WNDR3700

hechacker1 wrote:

I'm using "option encryption psk2" here, with HT20, and no big problems with lots of associations.

Have you tried erasing the network config on the device and have it re-detect the type of security and network settings? I find that often the saved settings expect a different type of network security (TKIP) from when I previously configured the network.

I'm not using arohk's build, but a newer one I compiled based on 28096. From what I can gather, the changes were related to decreasing the amount of buffers in the wireless stack (to improve latency under load).

It seems lots of changes are going into ath9k right now. I might wait a while for it to stabilize before making another build.

Overall though, even with my WRT54GL using Tomato, I remember the iPod's and iPhone frequently losing connection and reassociating. They did spam the log a lot.

You may want to try increasing the DHCP lease, perhaps it's too short for them? (unrelated to authentication, but it could help with slow connecting after the timeout).

I have tried deleting/recreating the network connection and that hasn't helped much and my DHCP lease is set at two days, so I would figure that would be OK for a device that has it's wifi turned off more frequently than that.

It could be that the apple idevices are just really chatty over wifi for whatever reason.  I just don't know what to make of it...

Thanks,

dusty_wrt54g

1,791

Re: Fully featured OpenWrt build for the WNDR3700

I installed the 8/22/2011 firmware on my WNDR3700v2 but I am having some issues with a Verbatim 2TB external USB hard drive.  It appears to do into hd-idle and won't wake up unless I turn the drive off and on.  The drive is USB 2.0 and it was format as ext3 using gparted on Mint Linux.

Here is the system log from the point when I turn the drive off and back on.

Sep  3 19:22:53 OpenWrt kern.info kernel: usb 1-1: USB disconnect, device number 2
Sep  3 19:23:07 OpenWrt kern.info kernel: usb 1-1: new high speed USB device number 3 using ar71xx-ehci
Sep  3 19:23:07 OpenWrt kern.info kernel: scsi1 : usb-storage 1-1:1.0
Sep  3 19:23:08 OpenWrt kern.notice kernel: scsi 1:0:0:0: Direct-Access     SAMSUNG  HD204UI               PQ: 0 ANSI: 2 CCS
Sep  3 19:23:08 OpenWrt kern.notice kernel: sd 1:0:0:0: Attached scsi generic sg0 type 0
Sep  3 19:23:08 OpenWrt kern.notice kernel: sd 1:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
Sep  3 19:23:08 OpenWrt kern.notice kernel: sd 1:0:0:0: [sda] Write Protect is off
Sep  3 19:23:08 OpenWrt kern.debug kernel: sd 1:0:0:0: [sda] Mode Sense: 28 00 00 00
Sep  3 19:23:08 OpenWrt kern.err kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Sep  3 19:23:08 OpenWrt kern.err kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Sep  3 19:23:08 OpenWrt kern.info kernel:  sda: sda1
Sep  3 19:23:08 OpenWrt kern.err kernel: sd 1:0:0:0: [sda] Assuming drive cache: write through
Sep  3 19:23:08 OpenWrt kern.notice kernel: sd 1:0:0:0: [sda] Attached SCSI disk
Sep  3 19:23:08 OpenWrt kern.info kernel: EXT4-fs (sda1): recovery complete
Sep  3 19:23:08 OpenWrt kern.info kernel: EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)

Here's the result of when I issue the mount command.

root@OpenWrt /etc# mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
tmpfs on /dev type tmpfs (rw,noatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,noatime,mode=600)
/dev/mtdblock4 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlayfs (rw,relatime)
debugfs on /sys/kernel/debug type debugfs (rw,relatime)
none on /proc/bus/usb type usbfs (rw,relatime)
/dev/sda1 on /mnt/sda1 type ext2 (rw,relatime,user_xattr,barrier=1,data=ordered)

1. Does anyone have any ideas about why the drive will not wake automatically when I try to access it?

2. Does anyone know why it is mounted as ext2 after I turn it off and back on?

3. Does anyone know why it appears to be mounted as usb 1.1 rather than usb 2.0?

Thanks.

1,792 (edited by hechacker1 2011-09-03 19:49:59)

Re: Fully featured OpenWrt build for the WNDR3700

dusty_wrt54g wrote:
hechacker1 wrote:

I'm using "option encryption psk2" here, with HT20, and no big problems with lots of associations.

Have you tried erasing the network config on the device and have it re-detect the type of security and network settings? I find that often the saved settings expect a different type of network security (TKIP) from when I previously configured the network.

I'm not using arohk's build, but a newer one I compiled based on 28096. From what I can gather, the changes were related to decreasing the amount of buffers in the wireless stack (to improve latency under load).

It seems lots of changes are going into ath9k right now. I might wait a while for it to stabilize before making another build.

Overall though, even with my WRT54GL using Tomato, I remember the iPod's and iPhone frequently losing connection and reassociating. They did spam the log a lot.

You may want to try increasing the DHCP lease, perhaps it's too short for them? (unrelated to authentication, but it could help with slow connecting after the timeout).

I have tried deleting/recreating the network connection and that hasn't helped much and my DHCP lease is set at two days, so I would figure that would be OK for a device that has it's wifi turned off more frequently than that.

It could be that the apple idevices are just really chatty over wifi for whatever reason.  I just don't know what to make of it...

Thanks,

dusty_wrt54g

Probably unrelated, but I have these settings in my "config wifi-device radio0"

        option frag     2302
        option rts      2300

You could try lowering the fragmentation and RTS threshold. I've read anecdotally this could help with networks that are very "chatty" as you say.

If you want to turn off RTS, set it equal or greater than Frag. (having it on reduces collisions, but decreases throughput)

I also have "option wmm      1" in my config wifi-iface section, but I don't think the ath9k driver has WMM in openwrt yet.

Re: Fully featured OpenWrt build for the WNDR3700

sethjvm wrote:

I installed the 8/22/2011 firmware on my WNDR3700v2 but I am having some issues with a Verbatim 2TB external USB hard drive.  It appears to do into hd-idle and won't wake up unless I turn the drive off and on.  The drive is USB 2.0 and it was format as ext3 using gparted on Mint Linux.

1. Does anyone have any ideas about why the drive will not wake automatically when I try to access it?

This I can't tell you since I haven't ever used hd-idle. Try disabling it and see whether it works fine.
On desktops I use hdparm for that.

3. Does anyone know why it appears to be mounted as usb 1.1 rather than usb 2.0?

Sep  3 19:22:53 OpenWrt kern.info kernel: usb 1-1: USB disconnect, device number 2
Sep  3 19:23:07 OpenWrt kern.info kernel: usb 1-1: new high speed USB device number 3 using ar71xx-ehci

Where do you get that idea from? The usb 1-1? That's the usb device node number, not the usb type.

As you can see it says "high speed USB device [...] using ar71xx-ehci".
The "high speed" means it is a USB2 device.
Besides that, ehci is a USB2 host controller, so don't worry, it's USB2.

1,794

Re: Fully featured OpenWrt build for the WNDR3700

Thanks for the response.  I see what you mean regarding my third question.  My bad.

I am a little concerned about hd-idle and how it might affect the longevity of the drive.

Thanks

Re: Fully featured OpenWrt build for the WNDR3700

I'd disable hd-idle.
After making sure it works fine that way, I'd try hdparm.

From the hdparm man page:

       -B     Get/set Advanced Power Management feature, if the drive supports it. A low value means aggressive power
              management  and  a  high value means better performance.  Possible settings range from values 1 through
              127 (which permit spin-down), and values 128 through 254 (which do not permit spin-down).  The  highest
              degree of power management is attained with a setting of 1, and the highest I/O performance with a set?
              ting of 254.  A value of 255 tells hdparm to disable Advanced Power Management altogether on the  drive
              (not all drives support disabling it, but most do).

       -S     Put the drive into idle (low-power) mode, and also set the standby (spindown) timeout  for  the  drive.
              This  timeout  value  is used by the drive to determine how long to wait (with no disk activity) before
              turning off the spindle motor to save power.  Under such circumstances, the drive may take as  long  as
              30  seconds  to respond to a subsequent disk access, though most drives are much quicker.  The encoding
              of the timeout value is somewhat peculiar.  A value of zero means "timeouts are disabled":  the  device
              will not automatically enter standby mode.  Values from 1 to 240 specify multiples of 5 seconds, yield?
              ing timeouts from 5 seconds to 20 minutes.  Values from 241 to 251 specify from 1 to  11  units  of  30
              minutes, yielding timeouts from 30 minutes to 5.5 hours.  A value of 252 signifies a timeout of 21 min?
              utes. A value of 253 sets a vendor-defined timeout period between 8 and 12 hours, and the value 254  is
              reserved.  255 is interpreted as 21 minutes plus 15 seconds.  Note that some older drives may have very
              different interpretations of these values.

On my server I use "-B127 -S120" which allows spin down (after 10mins) but favors performance.

1,796 (edited by dusty_wrt54g 2011-09-04 02:27:03)

Re: Fully featured OpenWrt build for the WNDR3700

hechacker1 wrote:

Probably unrelated, but I have these settings in my "config wifi-device radio0"

        option frag     2302
        option rts      2300

You could try lowering the fragmentation and RTS threshold. I've read anecdotally this could help with networks that are very "chatty" as you say.

If you want to turn off RTS, set it equal or greater than Frag. (having it on reduces collisions, but decreases throughput)

I also have "option wmm      1" in my config wifi-iface section, but I don't think the ath9k driver has WMM in openwrt yet.

Interesting.  I had frag and rts set at defaults (2346 & 2347 like stock Netgear I presume) and the speedtest numbers on my ipod touch actually improved a bit when I lowered them, where I would have assumed that throughput would have decreased.  Still lots of authentications in the log though...

1,797 (edited by hechacker1 2011-09-04 03:16:35)

Re: Fully featured OpenWrt build for the WNDR3700

dusty_wrt54g wrote:
hechacker1 wrote:

Probably unrelated, but I have these settings in my "config wifi-device radio0"

        option frag     2302
        option rts      2300

You could try lowering the fragmentation and RTS threshold. I've read anecdotally this could help with networks that are very "chatty" as you say.

If you want to turn off RTS, set it equal or greater than Frag. (having it on reduces collisions, but decreases throughput)

I also have "option wmm      1" in my config wifi-iface section, but I don't think the ath9k driver has WMM in openwrt yet.

Interesting.  I had frag and rts set at defaults (2346 & 2347 like stock Netgear I presume) and the speedtest numbers on my ipod touch actually improved a bit when I lowered them, where I would have assumed that throughput would have decreased.  Still lots of authentications in the log though...

Well, most Ethernet frame traffic is 1500 bytes in length, so 1500 + some 802.11 overhead would probably be optimal for most normal web traffic.

The larger 802.11 frames are more useful when dealing with other protocols.

If lowering your frag and rts helped, it could be that you do have some network collisions, and you may need to lower it more to make it more fair for all your devices to get a transmit slot.

Usually routers have the RTS disabled (when RTS is larger or equal to Frag). You can use RTS + FRAG, or just each separately. RTS ensures each device gets a clear channel to send. Frag splits packets up to the limit (so if a packet gets lost, it doesn't hurt if only a partial has to be retransmitted).

Re: Fully featured OpenWrt build for the WNDR3700

@arokh:

Did you played with iPhone 4 and IPSec VPN with your build and got it working? You have patched ipsec-tools heavily in yours.

1,799 (edited by Eugen1968 2011-09-04 19:37:21)

Re: Fully featured OpenWrt build for the WNDR3700

I tried mount Netgear USB disk with NFS on XP, but request user and password.
I edit "exports" config file by adding "no_auth_nlm" but not luck.
Default user and password not working. How disable it ?

1,800

Re: Fully featured OpenWrt build for the WNDR3700

Why are there no more daily builds? Personally, I would like to test how wireless performance has developed...