3,051

Re: Fully featured OpenWrt build for the WNDR3700

Comitizer wrote:
arokh wrote:

Netatalk was cut for space reasons. It's available as a package though, you could install it if you have a V2 or extroot. Another alternative is to set up TimeMachine to a sparse bundle disk image through SMB, works well and doesn't need yet another filesharing daemon.

I'm using Lion, I didn't think that it worked with the sparse bundle trick. Does it?  Ideally I'd like to host the backup on my WHS.

Last time I tried it was Snow Leopard, I see now that there are issues with Lion. However, there seems to be a way:

http://msftguy.blogspot.no/2011/07/lion-time-machine-and-afp-feature-bits.html

@MidGe

If the router has established an internet connection the problem should be easy to find out. Ping an external IP address (not DNS name) from your router. If it doesn't work, the problem is with the connection. If it does work, try to ping the same address from your workstation. If that doesn't work, the problem is with the firewalling rules. Start with the basics, make sure you can reach the outside world and that the firewall is properly forwarding packets.

I doubt the issue is with the fat build, as it's built from the same tree with a slightly different package set.

3,052

Re: Fully featured OpenWrt build for the WNDR3700

Ok, here are my results of the install of the normal build fro Arokh.

1. installed sysupgrade normal r32482 using LuCI, not keeping current settings (unticked).
2. Neede to re-boot workstation as I could not:
2,1 connect through the browser
2.2 unable bring ifdown eth0 or ifup eth0
2.3 ifconfig did not show an ip4 address but did show the eth0
3 After re-boot I connected to LuCI and changed password4. tried to connect to another website: could not find the site (looking like dns problem to me)
4. unpowered modem
5. rebooted router (without modem)
6. tried to connect to router: unable to do so
7. ifdown: interface eth0 not configured
8: ifup: Ignoring unknown interface eth0=eth0.
9. ifconfig: shows eth0 with inet6 address but no ip4
10.reboot workstation
11. started browser.. tried to connect to router got login screen
12. typing in my password..  router died and rebooted
13 when router backup could not connect thru LuCI
14 second attempt.. rebooting workstation
15. connected to LuCI via browser succesfull
16 turn on modem
17 modem connected to router
18. modem connected to internet
19. status in LuCI show ip4 connected
20. cannot connect to the internet via browser
21. reboot router with modem on
22. tried to connect to router: unable to do so
23. ifdown: interface eth0 not configured
24: ifup: Ignoring unknown interface eth0=eth0.
25. ifconfig: shows eth0 with inet6 address but no ip4
26. reboot workstation
27. started browser.. tried to connect to router got login screen
28. typing in my password..  router died and rebooted
29. when router back up could not connect thru LuCI
30. second attempt... rebooting workstation
31 repeat 6 to 9 smile
32 rebooting workstation
34 started browser. this time using anew session so that I would not end up on the reboot screen in LuCI
35. could connect to router via LuCI
36 status shows IP4 Wan status connected
37 cannot connect to the net via the browser
38 cannot ping external (unknown host)
39 I am at a loss!  smile sad

Next I will follow Arokh suggestion above and report back here  smile

3,053 (edited by MidGe 2012-06-22 09:50:13)

Re: Fully featured OpenWrt build for the WNDR3700

Ok, I tried to ping from the command line. I got no reply.

However, the modem light flashes during the ping. This means that the ping request went from ws to router (of course very likely as I can get LuCI), it then went from router to modem, and then maybe back or not, to the router, but definitely not from the router back to ws.

Note, I have had no problems with stock firmware or with dd-wrt. This problem is a bit beyond my level of skills it seem. I quite accept even that the problem is my end, but just prior to install OpenWRT, I re-installed stock firmware and everything was OK and working, I used it to install OpenWRT, so why would it have stopped now?  The firewall rules are supposed to work out of the box with this normal build, right. There are NO firewall rules currently implemented on my ws! I just don't know where or what to look for.  It seems like sabotage, and I would think so if I was paranoid. LOL  A leftover from my dd-wrt excursion, perhaps?  LOL

Seriously. what steps do I need to take now to systematically research this issue? Please, bear in mid that I am NOT, not yet anyway, a network expert. So make the steps clear enough, with not too many assumptions about what I may or ought to know.

Thanks a ton.

PS, sorry I missed the bit about pinging from the router...  I'll be back in ten minutes or so with that answer

3,054

Re: Fully featured OpenWrt build for the WNDR3700

Ok, I tried pinging a known ip from the router and that fails. However, I noticed that the modem LAN light, the one connected to the router was flashing in sync with the pinging. So it seems that the problem is somewhere between the modem to external world to modem to router.

Could be the modem then? But I have never touched the modem, the connecting to the modem has been automagically made by the stock firmware or the dd-wrt firmware and I assume (uh! oh! sad  ) the OpenWRT firmware???

If not so, I will have to dig up the modem manual (?) and what I need to do the modem?

Is that it?  Does OpenWRT expect something from the modem, or does it responds and handle that itself?

3,055

Re: Fully featured OpenWrt build for the WNDR3700

How is the connection with your modem set up? PPPoE? DHCP? Any way, now is probably a good time to create a thread in the "general discussion" section to troubleshoot your connection to the modem, as this is not an issue related to the changes in my build.

3,056

Re: Fully featured OpenWrt build for the WNDR3700

Ok Arokh,

I will start a thread in the "general discussion".

Thank you very much for your help and for your build. I am looking forward to use it when I get this issue sorted out. It is really a mix that is close to what I ideally need.

Regarding your question, the modem is connecting to the ISP via a PPPoE connection.

Thanks again

3,057 (edited by e4865 2012-06-22 22:48:26)

Re: Fully featured OpenWrt build for the WNDR3700

Hey arokh, really enjoying your builds for over a year now. Just one thing is missing to me: As even the 5 GHz band is filling up here right now, I want to use the legally allowed channels 100-140 (I am located in the EU) but I can't since my WNDR3700 comes with 0x00 regulatory domain set in EEPROM. I can only use US channels (which are partly not allowed here) or less. Is there any chance that you provide a build with CONFIG_ATH_USER_REGD=y or similar so I can set my region properly?

I tried to build your sources on my own but it seems to me that it does not work properly ("make" builds a 3700v2 image only and your build.sh script has some hardcoded directories so it does not work for me).

Hope you are willing to help! Thank you in advance!

3,058

Re: Fully featured OpenWrt build for the WNDR3700

ferob wrote:

@eric111

Try to replace your current /usr/lib/crda/regulatory.bin file with this.

Thank you!

3,059

Re: Fully featured OpenWrt build for the WNDR3700

ferob wrote:

@eric111

Try to replace your current /usr/lib/crda/regulatory.bin file with this.

Hi Ferob,

This works great! Thank you very much!

Cheers, Eric

Re: Fully featured OpenWrt build for the WNDR3700

arokh wrote:
Comitizer wrote:
arokh wrote:

Netatalk was cut for space reasons. It's available as a package though, you could install it if you have a V2 or extroot. Another alternative is to set up TimeMachine to a sparse bundle disk image through SMB, works well and doesn't need yet another filesharing daemon.

I'm using Lion, I didn't think that it worked with the sparse bundle trick. Does it?  Ideally I'd like to host the backup on my WHS.

Last time I tried it was Snow Leopard, I see now that there are issues with Lion. However, there seems to be a way:

http://msftguy.blogspot.no/2011/07/lion-time-machine-and-afp-feature-bits.html

Hmmm...I'll have to give that a try.  Thanks.

3,061

Re: Fully featured OpenWrt build for the WNDR3700

I've upgraded from some r31x build to r32498 and now I can't access my modem thru the router anymore. its an adsl2 pppoe connection, router IP 192.168.1.1, modem is 10.0.0.1. I've set it up like its described in the wiki http://wiki.openwrt.org/doc/howto/access.modem.through.nat#gui.version and that used to work with the older build. any help?

3,062 (edited by ladoga 2012-06-25 20:40:51)

Re: Fully featured OpenWrt build for the WNDR3700

Just a small wish.

It would make irssi package lot more useful if irssi was compiled with the proxy module. (./configure --with-proxy).
libirc_proxy.so only takes ca. 27KB.

3,063 (edited by bibabart 2012-06-26 09:28:00)

Re: Fully featured OpenWrt build for the WNDR3700

I tried serveral alternate builds on my 3700v1 and want to install kmod-macvlan. The module will not install because it's incompatible with the used kernel. The package installs ok on the normal build, but that one is too big because i need to install some extra packages for IPTV purposes. What can I do to install kmod-macvlan on the alternate build?

3,064

Re: Fully featured OpenWrt build for the WNDR3700

lo_ol, works fine here. You can't expect any help without providing any detail.

3,065

Re: Fully featured OpenWrt build for the WNDR3700

e4865 wrote:

I tried to build your sources on my own but it seems to me that it does not work properly ("make" builds a 3700v2 image only and your build.sh script has some hardcoded directories so it does not work for me).

You need to copy a normal or alt configuration from the config/release directory. The .config that's in place from the tarball is the fat config which only builds for V2 or higher.

I don't think CONFIG_ATH_USER_REGD will do what you want. Mine is set to 0x0 as well, but even if I modify regulatory.bin to allow everything for world, channels 52-140 cannot be used.

3,066

Re: Fully featured OpenWrt build for the WNDR3700

jow wrote:

lo_ol, works fine here. You can't expect any help without providing any detail.

well excuse me but i'm quite a noob. I don't really know what details you need to know but i'll try..
the modem is in bridged mode, it runs a telnet server and a webinterface, and the router does the PPPoE stuff. Modem IP 10.0.0.1 and the router (WNDR3700v2) is at 192.168.1.1. the build i'm using is r32498.
Fist i gave the wan interface (eth1) an IP Alias that I called 'modem'. IP 10.0.0.2, subnet 255.255.255.0 in Interfaces - WAN in Luci
then i went to Firewall - Zone Settings - Zone 'wan' - Advanced Settings and typed '!modem' in the 'Restrict Masquerading to given destination subnets' field.
at the end I've added these two lines in Firewall - Custom Rules
# modem
iptables -t nat -I postrouting_rule -s 192.168.1.0/24 -d 10.0.0.1 -j SNAT --to 10.0.0.2
iptables -I zone_lan_forward -s 192.168.1.0/24 -d 10.0.0.1 -j ACCEPT

however I can't even ping the modem at 10.0.0.1

3,067

Re: Fully featured OpenWrt build for the WNDR3700

@e4865

Just tried a build with CONFIG_ATH_USER_REGD. I was wrong, it will indeed allow those channels, but power output seems to be restricted at 17dBm for 5GHz. Seem to remember discussions about this way back and figured it was best to leave it off.

Anyone got opinions on this?

3,068

Re: Fully featured OpenWrt build for the WNDR3700

lo_ol: those custom rules are redundant, remove them. Also check the output of "ip addr show dev eth1", it should list two "inet" lines.

3,069

Re: Fully featured OpenWrt build for the WNDR3700

ip addr show dev eth1 only brings up one inet line
inet 10.0.0.2/24 brd 10.0.0.255 scope global eth1:1
and an IPv6 line
device pppoe-wan has the public IP

the full output is

root@WNDR3700v2 /root# ip addr show dev eth1
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP ql
en 1000
    link/ether a0:21:b7:9f:4d:62 brd ff:ff:ff:ff:ff:ff
    inet 10.0.0.2/24 brd 10.0.0.255 scope global eth1:1
    inet6 fe80::a221:b7ff:xxxx:xxxx/64 scope link
       valid_lft forever preferred_lft forever

i'm flashing build r31158 for testing..

3,070

Re: Fully featured OpenWrt build for the WNDR3700

This looks odd. Recent builds with netifd should not create named aliases at all. Are you sure that you're running a recent build?

3,071

Re: Fully featured OpenWrt build for the WNDR3700

i've flashed build r31158 for testing and it works with that build they way it was used to work. however if I remove these two custom rules and then restart the firewall it stops working
I could swear the above output was with r32498 on wink but I've just flashed it again, definitely build r32498, and now i get

root@WNDR3700v2 /root# ip addr show dev eth1
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP ql
en 1000
    link/ether a0:21:b7:9f:4d:62 brd ff:ff:ff:ff:ff:ff
    inet6 fe80::a221:b7ff:xxxx:xxxx/64 scope link
       valid_lft forever preferred_lft forever

3,072

Re: Fully featured OpenWrt build for the WNDR3700

Paste your /etc/config/network

3,073

Re: Fully featured OpenWrt build for the WNDR3700

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option mtu '1492'

config interface 'wan'
        option ifname 'eth1'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'pppoe'
        option username 'xxx'
        option password 'xxx'
        
config switch
        option name 'rtl8366s'
        option reset '1'
        option blinkrate '2'
        option max_length '3'
        option enable_vlan4k '1'

config switch_vlan
        option device 'rtl8366s'
        option vlan '1'
        option ports '0 1 2 3 5t'

config switch_port
        option device 'rtl8366s'
        option port '1'
        option led '6'

config switch_port
        option device 'rtl8366s'
        option port '2'
        option led '9'


config switch_port
        option device 'rtl8366s'
        option port '5'
        option led '2'

config alias 'modem'
        option proto 'static'
        option interface 'wan'
        option ipaddr '10.0.0.2'
        option netmask '255.255.255.0'

3,074

Re: Fully featured OpenWrt build for the WNDR3700

Ok, it is because you're using PPPoE.
Remove the modem alias and add

config interface 'modem'
        option ifname 'eth1'
        option proto 'static'
        option ipaddr '10.0.0.2'
        option netmask '255.255.255.0'

3,075

Re: Fully featured OpenWrt build for the WNDR3700

thanks I've done that. interface modem now shows up in Luci network-interfaces as well however i still can't ping my modem