2,976

Re: Fully featured OpenWrt build for the WNDR3700

hnyman, using crda is still possible, but only for countries not covered by the internal regdb.

2,977

Re: Fully featured OpenWrt build for the WNDR3700

jow wrote:

hnyman, using crda is still possible, but only for countries not covered by the internal regdb.

Yep, and it is easy for us who compile own firmware and can toggle the compiler switch to continue using crda reversing r31954. But the bulk of users who download snapshots have to live with the built-in database that is built into the wifi drivers, correct?

I have always used the default regulatory.bin, so I am quite ok with the change. I am just anticipating the feedback that will probably materialize after users accustomed to using a modified crda run into issues after the next firmware update...

Ps. the internal regdb seems to cover over 120 (major) countries, so the "countries not covered by the internal regdb" will represent rather small proportion of the Openwrt users.

2,978

Re: Fully featured OpenWrt build for the WNDR3700

Hey arokh, just wanted to come and thank you for all your work! I've been lurking in this thread since the beginning and yesterday loaded your latest build on my 3700v2. Working absolutely perfect (with your mentioned avahi fix) and the netatalk 2.2.2 from your repo is working perfectly with Lion's native backup daemon. Thank you for allowing me to have what I thought I had purchased in the first place!!!! big_smile

2,979

Re: Fully featured OpenWrt build for the WNDR3700

@djh816

Glad you like it smile

2,980

Re: Fully featured OpenWrt build for the WNDR3700

An odd question, but please help! Does anyone have a copy of arokh's alternate r30486 (preferably NA version) available for the WNDR3700v1? Could you please post it for me to download?

I'm looking for this as I have this running on my WNDR3800 and I was able to build and compile kmod-i2c-core, kmod-video-core and kmod-video-uvc. With these installed alongside the stock mjpg-streamer, I was able to add a webcam to the box. The problem is, that I have been unable to replicate my past success with the newer builds. I'm still investigating the reason, but suspect it is to do with the newer kernel.

So please... anyone? Spare some old code?

cheers,
   J.

2,981

Re: Fully featured OpenWrt build for the WNDR3700

@arokh With 32044 L2TP now works again. Thanks smile

Unfortunatly I now have another problem with ipv6 on tunnelbroker.
I have henet defined under networks and radv setup.

I can ping6 ipv6.google.com from the router ok.

No ipv6 access from lan side yet since I haven't added the ipv6 address to the lan interface.
This where things go badly... when I add ipv6addr and ipv6gw under the lan section in /etc/config/networks I can no longer access/ping the router from the lan.

It looks lan interface crashes after the ipv6 section is added (I can still VPN to the router).
I have to reset the router to factory to connect to again (even after reboot).

Any ideas?

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option 'ip6addr' '2001:xxx:xxxx:x::1/64'
    option 'ip6gw' '2001:xxx:xxxx:x::/64'

2,982

Re: Fully featured OpenWrt build for the WNDR3700

The ipv6gw looks wrong, it shouldn't carry a mask. Also shouldn't it end with :1 or something?

2,983

Re: Fully featured OpenWrt build for the WNDR3700

Is the ip6gw needed at all? I think that radvd is providing the routing information for LAN clients. I think that my ipv6 tunnel config does not have any explicit gateway definition at the router's LAN interface.

(And isn't the tunnel interface the actual gateway?)

2,984 (edited by avbohemen 2012-06-05 09:08:16)

Re: Fully featured OpenWrt build for the WNDR3700

arokh wrote:

OK, I got IPSec/L2TP working again. The issue was that I enabled "Back to My Mac" on my MBA, apparently it forwards UDP 4500 to the local machine via UPnP. This is stupid because it makes IPSec on the router unavailable.

Ah, I see you figured it out too. I just did this morning wink Looking at the logs for l2tp, I saw the same messages as when I had a wrong config with setkey.conf. Doing a restart of racoon gave a couple of syntax errors. It looks like the switch to netifd has changed the way uci works. Manually running "/etc/setkey.conf <wan-ip-address>" solved the thing.

I also looked at your diff for /etc/init.d/racoon, I see you are using /lib/functions/network.sh now, from https://dev.openwrt.org/changeset/31935/trunk Have the developers left the UCI system in exchange for more scripts??

Re: Fully featured OpenWrt build for the WNDR3700

arokh wrote:

Looks like you'd have to change regdb.txt before building. Maybe better if I just revert back to using crda?

Another way would be to build with CONFIG_ATH_USER_REGD set. That way, the router listens to the country setting you make in the config, instead of the one burned into the eeprom on the wireless card (which is often wrong for a lot of netgear routers). If you set CONFIG_ATH_USER_REGD, you do not need to use a custom/hacked regulatory.bin at runtime (or regdb.txt at build time).

2,986 (edited by rolfl 2012-06-05 13:48:04)

Re: Fully featured OpenWrt build for the WNDR3700

@jow and @hnyman,

You were correct, ip6gw was the culprit.
ip6gw was not needed and everything works fine without it.

Thank you !!!

-R


rolfl wrote:

@arokh With 32044 L2TP now works again. Thanks smile

Unfortunatly I now have another problem with ipv6 on tunnelbroker.
I have henet defined under networks and radv setup.

I can ping6 ipv6.google.com from the router ok.

No ipv6 access from lan side yet since I haven't added the ipv6 address to the lan interface.
This where things go badly... when I add ipv6addr and ipv6gw under the lan section in /etc/config/networks I can no longer access/ping the router from the lan.

It looks lan interface crashes after the ipv6 section is added (I can still VPN to the router).
I have to reset the router to factory to connect to again (even after reboot).

Any ideas?

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option 'ip6addr' '2001:xxx:xxxx:x::1/64'
    option 'ip6gw' '2001:xxx:xxxx:x::/64'
hnyman wrote:

Is the ip6gw needed at all? I think that radvd is providing the routing information for LAN clients. I think that my ipv6 tunnel config does not have any explicit gateway definition at the router's LAN interface.

(And isn't the tunnel interface the actual gateway?)

jow wrote:

The ipv6gw looks wrong, it shouldn't carry a mask. Also shouldn't it end with :1 or something?

2,987

Re: Fully featured OpenWrt build for the WNDR3700

Doing a little more digging, I found the following kernel log messages after boot-up when I plug in the webcam. Why the difference?

WNDR3700 - kernel 3.3.7
[  142.680000] usb 1-1: new high-speed USB device number 2 using ehci-platform

WNDR3800 - kernel 3.2.5
[  192.210000] usb 1-1: new high-speed USB device number 2 using ath79-ehci
[  192.580000] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0825)
[  192.690000] input: UVC Camera (046d:0825) as /devices/platform/ar71xx-ehci/usb1/1-1/1-1:1.0/input/input1
Juggler wrote:

An odd question, but please help! Does anyone have a copy of arokh's alternate r30486 (preferably NA version) available for the WNDR3700v1? Could you please post it for me to download?

I'm looking for this as I have this running on my WNDR3800 and I was able to build and compile kmod-i2c-core, kmod-video-core and kmod-video-uvc. With these installed alongside the stock mjpg-streamer, I was able to add a webcam to the box. The problem is, that I have been unable to replicate my past success with the newer builds. I'm still investigating the reason, but suspect it is to do with the newer kernel.

So please... anyone? Spare some old code?

cheers,
   J.

2,988

Re: Fully featured OpenWrt build for the WNDR3700

Umm, arokh you have a trac for this issue but did you ever find how to fix nzbget's par2 check issue? Both official and nzbget-svn gives this error.. It seems to be connected to the libpar2 or more likely missing par2cmdline. Do you have any solution?

2,989

Re: Fully featured OpenWrt build for the WNDR3700

Yes, I attached a patch (010-par2cmdline-0.4-packed.patch in my tree) to the ticket (https://dev.openwrt.org/ticket/8479). It's applied in my build and par repairs work fine.

2,990 (edited by cmn 2012-06-06 18:51:48)

Re: Fully featured OpenWrt build for the WNDR3700

In conclusion, is there a way to enable 13 channels on a running router with stock OWrt image? I mean, without recompiling or flashing a non-stock image.

2,991 (edited by Juggler 2012-06-07 01:12:34)

Re: Fully featured OpenWrt build for the WNDR3700

I flashed with the oldest release in the archives, r32012. This is still on the newer kernel 3.3.7; my suspicion right now is that the newer kernel is using a different set of drivers than the older (3.2.5) one.

Can anyone share a release with an older kernel (WNDR3700v1, NA-alternate)? I would like to test my theory...

Juggler wrote:

Doing a little more digging, I found the following kernel log messages after boot-up when I plug in the webcam. Why the difference?

WNDR3700 - kernel 3.3.7
[  142.680000] usb 1-1: new high-speed USB device number 2 using ehci-platform

WNDR3800 - kernel 3.2.5
[  192.210000] usb 1-1: new high-speed USB device number 2 using ath79-ehci
[  192.580000] uvcvideo: Found UVC 1.00 device <unnamed> (046d:0825)
[  192.690000] input: UVC Camera (046d:0825) as /devices/platform/ar71xx-ehci/usb1/1-1/1-1:1.0/input/input1

2,992

Re: Fully featured OpenWrt build for the WNDR3700

Change set 31793 removed UVC. Is that the reason?

https://dev.openwrt.org/changeset/31793

2,993

Re: Fully featured OpenWrt build for the WNDR3700

Hi all,

I've been trying to get the native IPv6 working with Time Warner Cable.
Do any of yo have native IPv6 working with TWC or comcast?

I can get native IPv6 working if I plug a win7 computer directly into the modem.

With OpenWRT on the other hand I can't seem to reach the internet with ping from router or lan.
I'm using wide-dhcp6c on top of arokh's r32044 alt build.

I'm using the dhcp6c pd and na options as indicted as need in the isp howto http://wiki.openwrt.org/doc/howto/ipv6.isp for Comcast.
The WAN interface gets assigned a /128 address and the LAN a /64 address.

I'm thinking the routing may not be configured correctly.

Any suggestions or recomendations on howto debug this?

ifconfig

br-lan    Link encap:Ethernet  HWaddr 30:46:9A:02:28:DB
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::3046:9aff:fe02:28db/64 Scope:Link
          inet6 addr: 2605:6000:100a:c02f:3246:9aff:fe02:28db/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3496 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2989 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:571051 (557.6 KiB)  TX bytes:1174878 (1.1 MiB)

eth1      Link encap:Ethernet  HWaddr 30:46:9A:02:28:DC
          inet addr:66.xx.xx.xx  Bcast:66.xx.xx.255  Mask:255.255.252.0
          inet6 addr: fe80::3246:9aff:fe02:28dc/64 Scope:Link
          inet6 addr: 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6/128 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:10272 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1439 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1173080 (1.1 MiB)  TX bytes:240055 (234.4 KiB)
          Interrupt:5

eth0      Link encap:Ethernet  HWaddr 32:46:9A:02:28:DB
          inet6 addr: fe80::3046:9aff:fe02:28db/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3465 errors:0 dropped:4 overruns:22 frame:0
          TX packets:3352 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:667097 (651.4 KiB)  TX bytes:1247909 (1.1 MiB)
          Interrupt:4

eth0.1    Link encap:Ethernet  HWaddr 32:46:9A:02:28:DB
          inet6 addr: fe80::3046:9aff:fe02:28db/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:3370 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3318 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:583170 (569.5 KiB)  TX bytes:1231252 (1.1 MiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:113 errors:0 dropped:0 overruns:0 frame:0
          TX packets:113 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:10052 (9.8 KiB)  TX bytes:10052 (9.8 KiB)

ip -6 route

2605:6000:100a:c02f::/64 dev br-lan  proto kernel  metric 256
2605:6000:ffc0:2b:7c7f:d235:c3e3:add6 dev eth1  proto kernel  metric 256
fe80::/64 dev eth0  proto kernel  metric 256
fe80::/64 dev eth0.1  proto kernel  metric 256
fe80::/64 dev br-lan  proto kernel  metric 256
fe80::/64 dev eth1  proto kernel  metric 256
fe80::/64 dev wlan0  proto kernel  metric 256
fe80::/64 dev wlan1  proto kernel  metric 256
root@OpenWrt /root#

/etc/config/networks

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option 'ip6addr' '0::1/128'

config interface 'lan'
        option ifname 'eth0.1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'

config interface 'wan'
        option ifname 'eth1'
        option proto 'dhcp'

/etc/config/dhcp6c

config 'dhcp6c' 'basic'
        option 'enabled' '1'                            # 1 = enabled; 0 = disabled
        option 'interface' 'wan'                        # This is the interface the DHCPv6 client will run on
        option 'dns' 'dnsmasq'                          # Which DNS server you run (only dnsmasq currently supported)
        option 'debug' '1'                              # 1 = enable debugging; 0 = disable debugging

        # Send options (1 = send; 0 = do not send)
        option 'pd' '1'                                 # Prefix Delegation
        option 'na' '1'                                 # Non-Temporary Address
        option 'rapid_commit' '1'                       # Rapid Commit

        # Request options (1 = request; 0 = do not request)
        option 'domain_name_servers' '1'
        option 'domain_name' '0'
        option 'ntp_servers' '0'
        option 'sip_server_address' '0'
        option 'sip_server_domain_name' '0'
        option 'nis_server_address' '0'
        option 'nis_domain_name' '0'
        option 'nisp_server_address' '0'
        option 'nisp_domain_name' '0'
        option 'bcmcs_server_address' '0'
        option 'bcmcs_server_domain_name' '0'

        # Override the used DUID, by default it is derived from the interface MAC
        # The given value must be uppercase and globally unique!
        #option 'duid' '00:03:00:06:D8:5D:4C:A5:03:F2'

        # Script to run when a reply is received
        option 'script' '/usr/bin/dhcp6c-state'

# Define one or more interfaces on which prefixes should be assigned
config 'interface' 'loopback'
        option 'enabled' '0'                            # 1 = enabled; 0 = disabled
        option 'sla_id' '1'                             # Site level aggregator identifier specified in decimal (subnet)
        option 'sla_len' '0'                            # Site level aggregator length (64 - size of prefix being delegated)
                                                        # e.g. /60 from ISP -> 64 - 60 = 4

config 'interface' 'lan'
        option 'enabled' '1'
        option 'sla_id' '0'
        option 'sla_len' '0'

/etc/config/radvd

config interface
        option interface 'lan'
        option AdvSendAdvert '1'
        option ignore '0'
        option AdvManagedFlag '0'
        option AdvOtherConfigFlag '0'
        option AdvDefaultPreference 'high'

config prefix
        option interface 'lan'
        option AdvOnLink '1'
        option AdvAutonomous '1'
        option ignore '0'

config route
        option interface 'lan'
        list prefix ''
        option ignore '0'

config rdnss
        option interface 'lan'
        option ignore '0'

config dnssl
        option interface 'lan'
        list suffix ''
        option ignore '1'

route -A inet6

Kernel IPv6 routing table
Destination                                 Next Hop                                Flags Metric Ref    Use Iface
2605:6000:100a:c02f::/64                    ::                                      U     256    0        0 br-lan
2605:6000:ffc0:2b:7c7f:d235:c3e3:add6/128   ::                                      U     256    0        0 eth1
fe80::214:f1ff:fee4:4931/128                fe80::214:f1ff:fee4:4931                UC    0      612       0 eth1
fe80::/64                                   ::                                      U     256    0        0 eth0
fe80::/64                                   ::                                      U     256    0        0 eth0.1
fe80::/64                                   ::                                      U     256    0        0 br-lan
fe80::/64                                   ::                                      U     256    0        0 eth1
fe80::/64                                   ::                                      U     256    0        0 wlan0
fe80::/64                                   ::                                      U     256    0        0 wlan1
::1/128                                     ::                                      U     0      0        1 lo
2605:6000:100a:c02f::/128                   ::                                      U     0      0        1 lo
2605:6000:100a:c02f:3246:9aff:fe02:28db/128 ::                                      U     0      2        1 lo
2605:6000:ffc0:2b:7c7f:d235:c3e3:add6/128   ::                                      U     0      34       1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::/128                                  ::                                      U     0      0        1 lo
fe80::3046:9aff:fe02:28db/128               ::                                      U     0      0        1 lo
fe80::3046:9aff:fe02:28db/128               ::                                      U     0      0        1 lo
fe80::3046:9aff:fe02:28db/128               ::                                      U     0      13       1 lo
fe80::3246:9aff:fe02:28db/128               ::                                      U     0      0        1 lo
fe80::3246:9aff:fe02:28dc/128               ::                                      U     0      242       1 lo
fe80::3246:9aff:fe02:28dd/128               ::                                      U     0      0        1 lo
ff02::1/128                                 ff02::1                                 UC    0      2        0 eth1
ff02::1:2/128                               ff02::1:2                               UC    0      1        0 br-lan
ff00::/8                                    ::                                      U     256    0        0 eth0
ff00::/8                                    ::                                      U     256    0        0 eth0.1
ff00::/8                                    ::                                      U     256    0        0 br-lan
ff00::/8                                    ::                                      U     256    0        0 eth1
ff00::/8                                    ::                                      U     256    0        0 wlan0
ff00::/8                                    ::                                      U     256    0        0 wlan1

2,994

Re: Fully featured OpenWrt build for the WNDR3700

Well what happens if you ping6 ?

2,995 (edited by rolfl 2012-06-09 14:48:03)

Re: Fully featured OpenWrt build for the WNDR3700

jow wrote:

Well what happens if you ping6 ?

I was wrong previously, with the default setup I get network unreachable:

PING ipv6.google.com (2607:f8b0:4000:801::1013): 56 data bytes
ping6: sendto: Network is unreachable


If I add a default route, ping6 just hangs until I ^C
route -A inet6 add default dev eth1
PING ipv6.google.com (2607:f8b0:4000:801::1013): 56 data bytes

2,996

Re: Fully featured OpenWrt build for the WNDR3700

My ISP (Free Télécom) offers a form of IPv6 native managed by its own modem. In practice my router WNDR3700 manages the IPv4 and the ISP's modem supports IPv6.
So I make a brouting.
I installed these two packages.

ebtables
kmod-ebtables

And I'm installing the broute as:

ebtables -t broute -A BROUTING -p ! ipv6 -i eth1 -j DROP
ebtables -A FORWARD -p ! ipv6 -o eth1 -j DROP
brctl addif br-lan eth1
ebtables -A OUTPUT -p ! ipv6 -o eth1 -j DROP

2,997

Re: Fully featured OpenWrt build for the WNDR3700

@Manani
Thanks for suggestion, I tried it but still couldn't ping.

@arokh
Would you please add the ebtable and kmod-ebtable to the alt build packages, they seem to be missing and trunk is not compatible.



Manani wrote:

My ISP (Free Télécom) offers a form of IPv6 native managed by its own modem. In practice my router WNDR3700 manages the IPv4 and the ISP's modem supports IPv6.
So I make a brouting.
I installed these two packages.

ebtables
kmod-ebtables

And I'm installing the broute as:

ebtables -t broute -A BROUTING -p ! ipv6 -i eth1 -j DROP
ebtables -A FORWARD -p ! ipv6 -o eth1 -j DROP
brctl addif br-lan eth1
ebtables -A OUTPUT -p ! ipv6 -o eth1 -j DROP

2,998

Re: Fully featured OpenWrt build for the WNDR3700

Part of my network config

config interface 'lan'
    option ifname 'eth0.1'
    option type 'bridge'
    option proto 'static'
    option ipaddr '192.168.1.1'
    option netmask '255.255.255.0'
    option accept_ra '1'
    option gateway '78.xxx.xx.254' #from my ISP
    option dns '212.27.40.240 212.27.40.241 2a01:e00::1 2a01:e00::2' #from my ISP

config interface 'wan'
    option ifname 'eth1'
    option _orig_ifname 'eth1'
    option _orig_bridge 'false'
    option proto 'static'
    option ipaddr '78.xx.xx.xx/24' #from my ISP
    option netmask '255.255.255.0'
    option gateway '78.xx.xx.254' #from my ISP
    option accept_ra '1'

2,999

Re: Fully featured OpenWrt build for the WNDR3700

rolfl wrote:

@arokh
Would you please add the ebtable and kmod-ebtable to the alt build packages, they seem to be missing and trunk is not compatible.

I'm used to force install

Example

opkg --force-depends install http://downloads.openwrt.org/snapshots/trunk/ar71xx/packages/ebtables_2.0.10-4-1_ar71xx.ipk

3,000

Re: Fully featured OpenWrt build for the WNDR3700

@jow

Here is the ping6 results:
root@OpenWrt /root#  ping6 -I br-lan ipv6.google.com
PING ipv6.google.com (2607:f8b0:4000:800::1011): 56 data bytes
ping6: sendto: Network is unreachable
root@OpenWrt /root#  ping6 -I eth1 ipv6.google.com
PING ipv6.google.com (2607:f8b0:4000:800::1011): 56 data bytes
ping6: sendto: Network is unreachable


I have attached the dhcp6c output after a restart.
Do you see anything strange?
Any significance to the two racoon errors at the end?


Jun  9 12:21:24 OpenWrt user.notice dhcp6c: stopping dhcp6c
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: release_ia: release an IA: PD-0
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_reset_timer: reset a timer on eth1, state=RELEASE, timeo=0, retrans=986
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: client6_send: a new XID (ab1600) is generated
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set client ID (len 10)
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set server ID (len 14)
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set elapsed time (len 2)
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD prefix
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: client6_send: send release to ff02::1:2
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: remove_ia: remove an IA: PD-0
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: remove_siteprefix: remove a site prefix 2605:6000:100a:c02f::/64
Jun  9 12:21:24 OpenWrt daemon.info avahi-daemon[2858]: Withdrawing address record for 2605:6000:100a:c02f:3246:9aff:fe02:28db on br-lan.
Jun  9 12:21:24 OpenWrt daemon.info avahi-daemon[2858]: Registering new address record for fe80::3046:9aff:fe02:28db on br-lan.*.
Jun  9 12:21:24 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_remove_event: removing an event on eth1, state=INIT
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set client ID (len 10)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set server ID (len 14)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA address
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set identity association
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set elapsed time (len 2)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: client6_send: send release to ff02::1:2
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_reset_timer: reset a timer on eth1, state=RELEASE, timeo=1, retrans=1852
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set client ID (len 10)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set server ID (len 14)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set elapsed time (len 2)
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD prefix
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: client6_send: send release to ff02::1:2
Jun  9 12:21:25 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_reset_timer: reset a timer on eth1, state=RELEASE, timeo=1, retrans=1923
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set client ID (len 10)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set server ID (len 14)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA address
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set identity association
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set elapsed time (len 2)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: client6_send: send release to ff02::1:2
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_reset_timer: reset a timer on eth1, state=RELEASE, timeo=2, retrans=3541
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set client ID (len 10)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set server ID (len 14)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copy_option: set elapsed time (len 2)
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD prefix
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: copyout_option: set IA_PD
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: client6_send: send release to ff02::1:2
Jun  9 12:21:27 OpenWrt daemon.debug dhcp6c[3518]: dhcp6_reset_timer: reset a timer on eth1, state=RELEASE, timeo=2, retrans=3883
Jun  9 12:21:29 OpenWrt daemon.err radvd[3558]: poll error: Interrupted system call
Jun  9 12:21:29 OpenWrt daemon.warn radvd[3558]: Exiting, sigterm or sigint received.
Jun  9 12:21:30 OpenWrt daemon.info radvd[3643]: version 1.8.3 started
Jun  9 12:21:30 OpenWrt user.notice dhcp6c: starting dhcp6c
Jun  9 12:21:31 OpenWrt user.notice dhcp6c: Using MAC address DUID 00:03:00:06:30:46:9A:02:28:DC
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: get_duid: extracted an existing DUID from /var/dhcp6c_duid: 00:03:00:06:30:46:9a:02:28:dc
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[interface] (9)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <5>[eth1] (4)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>begin of closure [{] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[send] (4)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[ia-pd] (5)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[send] (4)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[ia-na] (5)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[send] (4)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[rapid-commit] (12)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[script] (6)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>["/usr/bin/dhcp6c-state"] (23)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[request] (7)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[domain-name-servers] (19)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of closure [}] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[id-assoc] (8)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>[pd] (2)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>begin of closure [{] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[prefix-interface] (16)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <5>[br-lan] (6)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>begin of closure [{] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[sla-id] (6)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[sla-len] (7)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of closure [}] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of closure [}] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>[id-assoc] (8)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>[na] (2)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>[0] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <13>begin of closure [{] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of closure [}] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: cfdebug_print: <3>end of sentence [;] (1)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: configure_pool: called
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3663]: clear_poolconf: called
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_reset_timer: reset a timer on eth1, state=INIT, timeo=0, retrans=724
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_send: a new XID (f27a77) is generated
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copy_option: set client ID (len 10)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyout_option: set identity association
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copy_option: set rapid commit (len 0)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copy_option: set elapsed time (len 2)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copy_option: set option request (len 2)
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyout_option: set IA_PD
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_send: send solicit to ff02::1:2
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_reset_timer: reset a timer on eth1, state=SOLICIT, timeo=0, retrans=1078
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_recv: receive advertise from fe80::214:f1ff:fee4:4931 on eth1
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option client ID, len 10
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:03:00:06:30:46:9a:02:28:dc
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option server ID, len 14
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:01:00:01:17:04:84:60:00:50:56:85:00:44
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option identity association, len 40
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_NA: ID=0, T1=302400, T2=483840
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option: get DHCP option IA address, len 24
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option:   IA_NA address: 2605:6000:ffc0:2b:8d81:e0e4:74dc:94f3 pltime=604800 vltime=604800
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option IA_PD, len 41
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_PD: ID=0, T1=302400, T2=483840
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_recv: receive advertise from fe80::214:f1ff:fee4:4931 on eth1
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option client ID, len 10
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:03:00:06:30:46:9a:02:28:dc
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option server ID, len 14
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:01:00:01:17:04:92:65:00:50:56:9d:00:64
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option identity association, len 40
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_NA: ID=0, T1=188250, T2=301200
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option: get DHCP option IA address, len 24
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option:   IA_NA address: 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6 pltime=376501 vltime=376501
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option IA_PD, len 41
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_PD: ID=0, T1=182911, T2=292658
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_recv: receive reply from fe80::214:f1ff:fee4:4931 on eth1
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option client ID, len 10
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:03:00:06:30:46:9a:02:28:dc
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option server ID, len 14
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   DUID: 00:01:00:01:17:04:92:65:00:50:56:9d:00:64
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option identity association, len 40
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_NA: ID=0, T1=188250, T2=301200
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option: get DHCP option IA address, len 24
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option:   IA_NA address: 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6 pltime=376501 vltime=376501
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_get_options: get DHCP option IA_PD, len 41
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]:   IA_PD: ID=0, T1=182911, T2=292658
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option: get DHCP option IA_PD prefix, len 25
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: copyin_option:   IA_PD prefix: 2605:6000:100a:c02f::/64 pltime=365823 vltime=365823
Jun  9 12:21:31 OpenWrt daemon.debug dhcp6c[3664]: client6_recvreply: executes /usr/bin/dhcp6c-state
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: client6_script: script "/usr/bin/dhcp6c-state" terminated
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: get_ia: make an IA: PD-0
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: update_prefix: create a prefix 2605:6000:100a:c02f::/64 pltime=365823, vltime=365823
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: ifaddrconf: add an address 2605:6000:100a:c02f:3246:9aff:fe02:28db/64 on br-lan
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: get_ia: make an IA: NA-0
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: update_address: create an address 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6 pltime=376501, vltime=376501
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: ifaddrconf: add an address 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6/128 on eth1
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_remove_event: removing an event on eth1, state=REQUEST
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_remove_event: removing server (ID: 00:01:00:01:17:04:92:65:00:50:56:9d:00:64)
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: dhcp6_remove_event: removing server (ID: 00:01:00:01:17:04:84:60:00:50:56:85:00:44)
Jun  9 12:21:32 OpenWrt daemon.debug dhcp6c[3664]: client6_recvreply: got an expected reply, sleeping.
Jun  9 12:21:33 OpenWrt daemon.info racoon: INFO: 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6[500] used as isakmp port (fd=30)
Jun  9 12:21:33 OpenWrt daemon.info racoon: INFO: 2605:6000:ffc0:2b:7c7f:d235:c3e3:add6[4500] used as isakmp port (fd=31)
Jun  9 12:21:33 OpenWrt daemon.info avahi-daemon[2858]: Registering new address record for 2605:6000:100a:c02f:3246:9aff:fe02:28db on br-lan.*.
Jun  9 12:21:33 OpenWrt daemon.info avahi-daemon[2858]: Withdrawing address record for fe80::3046:9aff:fe02:28db on br-lan.
Jun  9 12:21:33 OpenWrt daemon.info racoon: INFO: 2605:6000:100a:c02f:3246:9aff:fe02:28db[500] used as isakmp port (fd=32)
Jun  9 12:21:33 OpenWrt daemon.info racoon: INFO: 2605:6000:100a:c02f:3246:9aff:fe02:28db[4500] used as isakmp port (fd=33)
Jun  9 12:21:33 OpenWrt daemon.info racoon: ERROR: privsep_bind (Cannot assign requested address) = -1
Jun  9 12:21:33 OpenWrt daemon.info racoon: [2605:6000:100a:c02f::] ERROR: failed to bind to address 2605:6000:100a:c02f::[500] (Cannot assign requested address).
Jun  9 12:21:33 OpenWrt daemon.info racoon: ERROR: privsep_bind (Cannot assign requested address) = -1
Jun  9 12:21:33 OpenWrt daemon.info racoon: [2605:6000:100a:c02f::] ERROR: failed to bind to address 2605:6000:100a:c02f::[4500] (Cannot assign requested address).
Jun  9 12:21:34 OpenWrt daemon.err radvd[3644]: poll error: Interrupted system call
Jun  9 12:21:34 OpenWrt daemon.warn radvd[3644]: Exiting, sigterm or sigint received.
Jun  9 12:21:34 OpenWrt daemon.info radvd[3703]: version 1.8.3 started