Topic: Unable to change TX power on WNDR3700

Hi,

I've installed Backfire 10.03.1-rc2 and got both 2.4GHz and 5GHz bands working out of the box. I tried to use the GUI to change the TX power resulting in the following additional line in my /etc/config/wireless for wlan0 for example:

option 'txpower' '23'

But when I run the 'wifi' command I get:

root@OpenWrt:~# wifi
Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device wlan0 ; Invalid argument.

Also I'm unable to get the maximum supported power using the following command:

root@OpenWrt:~# iwlist wlan0 txpower
wlan0     unknown transmit-power information.

Another strange observation is the iwconfig output where 18dBm and 30dBm show up!

wlan0     IEEE 802.11bgn  Mode:Master  Frequency:2.442 GHz  Tx-Power=18 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off
          
wlan1     IEEE 802.11an  Mode:Master  Frequency:5.805 GHz  Tx-Power=30 dBm   
          RTS thr:off   Fragment thr:off
          Power Management:off

When I bought my WNDR-3700 two days ago, I flashed it with DD-WRT and the "iwmlist wlan0 txpower" command would report 23dm max for both bands. I was also able to change the TX power up to this maximum.

Is this a limitation of the current driver? Is the reported TX power correct?

Thanks
Alphazo

Re: Unable to change TX power on WNDR3700

Hi!

Did you find any information about this?I cannot change tx-power above 20 dBm too.'Iwlist wlan0 txpower' reports the same as yours.
DD-WRT uses madwifi driver,not mac80211/ath9k,also Netgear factory firmware(I think it's binary only).Both can set tx-power above 20 dBm.
I found a patch for mac80211,with that I could play with antenna configuration through /proc filesystem,but the signal is still weak.
Tried openwrt trunk,latest ath9k/mac80211 driver and still no success.My good old Asus Wl500g Premium is unbeatable by Netgear.
Fuck this internal antenna thing,I'm now experimenting with applying an external antenna to the router,as 20 dBm would be enough to cover the distance I need(Wl-500gP's power is 84,but it has an ext. antenna).

Re: Unable to change TX power on WNDR3700

Any news on this?

Re: Unable to change TX power on WNDR3700

You cannot change the power settings with iwconfig on ath9k. In most recent trunk the iw package has been updated to adjust txpower. I have no clue if in fact it works, but it's suppose to. You could try and update just your iw package and see if it works. Type iw at the command prompt and you will see the new list of options. I think it's going to be some time before you can alter the wifi config file for it to happen, but atleast for now you can do it via command line.

Re: Unable to change TX power on WNDR3700

Changing the txpower with "iwconfig" works too, just not to 23dbm. The regulatory db caps the maximum output to 20dbm.

Re: Unable to change TX power on WNDR3700

foxtroop11 wrote:

You cannot change the power settings with iwconfig on ath9k. In most recent trunk the iw package has been updated to adjust txpower. I have no clue if in fact it works, but it's suppose to. You could try and update just your iw package and see if it works. Type iw at the command prompt and you will see the new list of options. I think it's going to be some time before you can alter the wifi config file for it to happen, but atleast for now you can do it via command line.

I'll try it,thanks.

Re: Unable to change TX power on WNDR3700

jow wrote:

Changing the txpower with "iwconfig" works too, just not to 23dbm. The regulatory db caps the maximum output to 20dbm.

I guess it's not regdomain that limits,I tried in trunk with ath9k compiled with changing regdb support,set regdomain to CA or USA(it allows 27dBm),and still doesn't work.
I've just found out that "iw list" shows 20dBm in all frequencies,so it can be hw limit,or that I can set regdomain,but the hw or driver doesn't care about that.

Re: Unable to change TX power on WNDR3700

Same here on my WNDR3700. No matter what, the 2.4GHz radio doesn't budge above 20dbm. I just can't figure out why the stock firmware consistently produces ~6db more signal at the same power level than OpenWRT. I wouldn't normally care, but I need those last 10 feet of coverage in my case.

Re: Unable to change TX power on WNDR3700

kj0 wrote:

DD-WRT uses madwifi driver,not mac80211/ath9k,also Netgear factory firmware(I think it's binary only).Both can set tx-power above 20 dBm.

You can set tx-power above 20 dBm with DD-WRT but it doesn't mean that it IS actually above 20 dBm.

10

Re: Unable to change TX power on WNDR3700

antsh wrote:

Same here on my WNDR3700. No matter what, the 2.4GHz radio doesn't budge above 20dbm. I just can't figure out why the stock firmware consistently produces ~6db more signal at the same power level than OpenWRT. I wouldn't normally care, but I need those last 10 feet of coverage in my case.

You should try out a patch,described here.I got better signal by enabling just selected antennas.
Anyway,as a workaround for signal levels,I disassembled my brand new router,soldered a pigtail cable in,and attached an external antenna to it.I use 2,4GHz for a 802.11g client only,so this lonely antenna should be enough.I had to cover about 150m through 2 windows and open air.For both the router's antenna and client antenna I applied a paraboloid reflector(search youtube for windsurfer antenna) and get a stable link about 10-11Mbit speed.For now i'm pleased with this speed,it,s enough to retire my old router.Sooner or later it'll be solved by openwrt/ath9k devs,as both is under heavy development.

11

Re: Unable to change TX power on WNDR3700

fyi wrote:
kj0 wrote:

DD-WRT uses madwifi driver,not mac80211/ath9k,also Netgear factory firmware(I think it's binary only).Both can set tx-power above 20 dBm.

You can set tx-power above 20 dBm with DD-WRT but it doesn't mean that it IS actually above 20 dBm.

Yes,i know it.Just mentioned,anyway,I don't really care about DD-WRT,just played with it.If i remember correct,i read somewhere they'll be using ath9k too,but i'm not sure.

Re: Unable to change TX power on WNDR3700

foxtroop11 wrote:

You cannot change the power settings with iwconfig on ath9k. In most recent trunk the iw package has been updated to adjust txpower. I have no clue if in fact it works, but it's suppose to. You could try and update just your iw package and see if it works. Type iw at the command prompt and you will see the new list of options. I think it's going to be some time before you can alter the wifi config file for it to happen, but atleast for now you can do it via command line.

Here is what I get on my TP-Link WR841ND router v5, with Backfire 10.03.1RC3:

root@OpenWrt:~# iw list
Wiphy phy0
        Band 1:
                Capabilities: 0x11ce
                        HT20/HT40
                        SM Power Save disabled
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 7935 bytes
                        DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: 8 usec (0x06)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (27.0 dBm)
                        * 2417 MHz [2] (27.0 dBm)
                        * 2422 MHz [3] (27.0 dBm)
                        * 2427 MHz [4] (27.0 dBm)
                        * 2432 MHz [5] (27.0 dBm)
                        * 2437 MHz [6] (27.0 dBm)
                        * 2442 MHz [7] (27.0 dBm)
                        * 2447 MHz [8] (27.0 dBm)
                        * 2452 MHz [9] (27.0 dBm)
                        * 2457 MHz [10] (27.0 dBm)
                        * 2462 MHz [11] (27.0 dBm)
                        * 2467 MHz [12] (disabled)
                        * 2472 MHz [13] (disabled)
                        * 2484 MHz [14] (disabled)
                Bitrates (non-HT):
                        * 1.0 Mbps
                        * 2.0 Mbps (short preamble supported)
                        * 5.5 Mbps (short preamble supported)
                        * 11.0 Mbps (short preamble supported)
                        * 6.0 Mbps
                        * 9.0 Mbps
                        * 12.0 Mbps
                        * 18.0 Mbps
                        * 24.0 Mbps
                        * 36.0 Mbps
                        * 48.0 Mbps
                        * 54.0 Mbps
        max # scan SSIDs: 4
        Coverage class: 0 (up to 0m)
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
        Supported commands:
                 * new_interface
                 * set_interface
                 * new_key
                 * new_beacon
                 * new_station
                 * new_mpath
                 * set_mesh_params
                 * set_bss
                 * authenticate
                 * associate
                 * deauthenticate
                 * disassociate
                 * join_ibss
                 * (null)
                 * (null)
                 * Unknown command (59)
                 * set_wiphy_netns
                 * Unknown command (65)
                 * connect
                 * disconnect

But I get "unknown transmit-power information" message if try to check it with following command:

root@OpenWrt:~# iwlist txpower
lo        no transmit-power information.

eth0      no transmit-power information.

eth1      no transmit-power information.

br-lan    no transmit-power information.

wlan0     unknown transmit-power information.

          Current Tx-Power=27 dBm       (501 mW)

mon.wlan0  unknown transmit-power information.

          Current Tx-Power=27 dBm       (501 mW)

What can be done to fix this?