Topic: Atheros AR2317 AP61

I am trying to install some openwrt version on my development board Atheros AR5BAP-0061GA which has Atheros AR2317 chip.
This board has 4MB Flash and 8MB RAM and I know this is the minimum requirement for Openwrt to be able to be installed, but not much will be possible to run, this is exactly what is happening, my web interface is not working as my wireless and sometimes the system stop running.

http://oldwiki.openwrt.org/MinimumSyste … ments.html

I have been installed all the x-wrt versions and all openwrt versions, and the problem still running.

Here goes my question, does someone know how to modify some version to be able to install correctly on my board, for example, kick out some parts and get a new "clean" version or another way to get openwrt running on a 8MB RAM board or a hardware way to get this solved.

I appreciate any ideas