Topic: Kamikaze 8.09.2

The OpenWrt team would like to announce the release of Kamikaze 8.09.2

The official binaries, generated from the 8.09.2 svn tag, can be found here: http://downloads.openwrt.org/kamikaze/8.09.2/

This is the last update of the 8.09 release series, with the following notable changes:
* pptp nat contracting removed on brcm-2.4,  cause of dnat off-by-one port forwarding bug
* added antenna gpio support for nanostation loco2
* backported swconfig and IP-175C support for DIR-300 and similar atheros devices
* added a combined atheros image format with sysupgrade support
* fixed ethernet issues on fonera+
* fixed wgt634u regresssion introduced in 8.09.1
* disabled tcp ecn by default
* improved sysupgrade reliability
* added mtd support for fis table layout on redboot based systems
* add support for creating VMware VMDK images for x86
* fixed ipv6 interface setup on boot
* numerous madwifi fixes
* fixed ImageBuilder and SDK
* fixed failsafe mode on fonera+ and fonera 2.0
* fixed memory leaks in miniupnpd
* fixed escaping issues in ddns-scripts
* update X-Wrt to 8.09.2
* update LuCI to v0.8.8
* security fixes for openswan, tiff, libpng, kernel, curl, gnutls, openssl and dnsmasq

For a complete list of changes refer to https://dev.openwrt.org/milestone/Kamikaze%208.09.2

Note: The brcm47xx still won't work for those of you needing broadcom wifi, stick to brcm-2.4.
We will tell you when it does work.

Yours truly,
--
The release management team
Andy Boyett & Nicolas Thill

Re: Kamikaze 8.09.2

KAMIKAZE (8.09.1, r16278)


root@OpenWrt:~# dbhub
dbhub: can't resolve symbol '__uClibc_start_main'



gives me this error !!!          please help

Re: Kamikaze 8.09.2

felesteanu wrote:

gives me this error !!!          please help

Whatever "dbhub" is, it was compiled for the wrong uClibc version.

Re: Kamikaze 8.09.2

Yarrrr goddamnit guys, I was in the middle of some major haxoring while the -RC2 repository was pulled from below my feet wink Time to reflash and recompile toolchain...

5 (edited by felesteanu 2010-01-11 00:21:37)

Re: Kamikaze 8.09.2

What solution would be to install dbhub on Kamikaze (8.09.1, r16278) or that you could recommend me an Asus WL500 GP V2
   pls help

Re: Kamikaze 8.09.2

Gotta love folks that hijack news threads instead of starting their own...  smile


Devs, great work on 8.09.2!

Re: Kamikaze 8.09.2

Whether the monitor mode is available on WRT54GL for this version kamikaze? In 8.09.1 was not available.

PrzemWas

8 (edited by felesteanu 2010-01-11 15:55:45)

Re: Kamikaze 8.09.2

I installed Kamikaze (8.09.2, r18961) but still gives me the same error when I start .. :
    root @ OpenWrt: ~ # dbhub
dbhub: can not resolve symbol '__uClibc_start_main'
root @ OpenWrt: ~ #
 

  I installed and packages for dbhub: libpthread - libssl but unfortunately the same story
   What can you recommend a router WL500 gp v2??? dbhub want to install it.

Or what version of openwrt (or something) on an Asus wl500gp v2 run dbhub

Re: Kamikaze 8.09.2

!!!!

Re: Kamikaze 8.09.2

Congratulation. Great job, guys!!! Looking forward to upgrade my old trusty WGT634U.

@felesteanu: Why don't you use trac to report a bug?! Spaming the forum is bad idea...

8.09 - Netgrear WGT634U + Creative Xmod USB Audio, USB Drive, USB Hub, Dallas 1-wire sensors

Re: Kamikaze 8.09.2

Very nice.

I'm looking forward to installing 8.09.2 on my WL500gP v1 with atheros wifi card.

Re: Kamikaze 8.09.2

Do you expect to make brcm47xx Wi-Fi working for the next version? Will it be soon?

13

Re: Kamikaze 8.09.2

Telordya wrote:

Do you expect to make brcm47xx Wi-Fi working for the next version? Will it be soon?

It more or less depends on the progress of b43, it works okay in current trunk revisions but is not on-par with the performance of wl.o

~ JoW

Re: Kamikaze 8.09.2

Hi,

openwrt developers, thanks for your great work!

Is it possible to do a direct upgrade from 8.09.1 to 8.09.2 via opkg?

Something like that:
sed -i 's/8.09.1/8.09.2/' /etc/opkg.conf
opkg update
opkg upgrade

Or is it necessary to reinstall openwrt completely?
I am running my openwrt installation from an USB device. From my point of view it should be possible to do a direct upgrade via opkg.

Regards Claus

Re: Kamikaze 8.09.2

Bartman007 wrote:

This is the last update of the 8.09 release series

"last" as "latest" / "newest" or maybe "there won't be any more updates for 8.09" ?

Re: Kamikaze 8.09.2

claus wrote:

Hi,

openwrt developers, thanks for your great work!

Is it possible to do a direct upgrade from 8.09.1 to 8.09.2 via opkg?

Something like that:
sed -i 's/8.09.1/8.09.2/' /etc/opkg.conf
opkg update
opkg upgrade

Or is it necessary to reinstall openwrt completely?
I am running my openwrt installation from an USB device. From my point of view it should be possible to do a direct upgrade via opkg.

Regards Claus

Hi Claus,

I might be mistaken, but I think you can "upgrade" using mtd command directly from device itself. Beware you WILL loose all your settings, as this will overwrite device's flash...

HTH

8.09 - Netgrear WGT634U + Creative Xmod USB Audio, USB Drive, USB Hub, Dallas 1-wire sensors