Topic: redboot stuck on == Executing boot script

Hello everyone!

I am locked out of redboot. I set BOOTP configuration to true and now I need DHCP server to assing ip address. So, I installed one on Ubuntu linux, but now I have another problem: I can't abort the booting process of the firmware.
Telnet client shows

Trying 192.168.1.1...
Connected to 192.168.1.1
Escape character is '^]'.
== Executing boot script in 2.690 seconds - enter ^C to abort

and then nothing after I press CTRL-C.(Also tried with putty on linux and all I get is a blank screen) I also noticed that I lose ping response after I try to interrupt.
Could it be because I set incorrect Ip for DHCP server and it doesn't match the one I set in Default server IP address in redboot?
Ok another question. Is it possible to set BOOTP to false and Default server IP address to 0.0.0.0 outside of the Redboot? I still have access to DD-WRT.

I have Arlink AR335W (DIR 300)
Thanks in advance.

2 (edited by mazilo 2008-11-24 04:42:09)

Re: redboot stuck on == Executing boot script

You will need to create ~/.telnetrc with the content as shown below:

192.168.1.1
        mode line

Make sure you have TAB (not spaces) before the mode line.

Mazi

Re: redboot stuck on == Executing boot script

mazilo wrote:

You will need to create ~/.telnetrc with the content as shown below:

192.168.1.1
        mode line

Make sure you have TAB (not spaces) before the mode line.

What will this do ? Where should I create this file ?

Re: redboot stuck on == Executing boot script

Dmitry wrote:
mazilo wrote:

You will need to create ~/.telnetrc with the content as shown below:

192.168.1.1
        mode line

Make sure you have TAB (not spaces) before the mode line.

What will this do ? Where should I create this file ?

Ok I think I understand now. I put this in my user's home folder and it will enable the mode line function that was disabled. Shouldn't there be a port number after ip ?

192.168.1.1 9000
        mode line

Re: redboot stuck on == Executing boot script

I recommend using putty.  You can install it on ubuntu with "apt-get install putty".

All the defaults are correct, and upon connecting it will type a ^C so you do not have to worry about this

6 (edited by Dmitry 2008-11-24 22:54:33)

Re: redboot stuck on == Executing boot script

phorn wrote:

I recommend using putty.  You can install it on ubuntu with "apt-get install putty".

All the defaults are correct, and upon connecting it will type a ^C so you do not have to worry about this

For some reason I couldn't connect with putty, but the built-in telnet worked perfectly after I created /.telnetrc.

Thanks to both of you for your help. 

Do you know if network patch is inluded in new build of Kamikaze ?

Re: redboot stuck on == Executing boot script

This is working for me too under archlinux:

You will need to create ~/.telnetrc with the content as shown below:
192.168.1.1
        mode line

Re: redboot stuck on == Executing boot script

I found the steps at http://www.shadowandy.net/2007/09/mini- … ir-300.htm that helped me.

In short,

  1. Hold on to the reset behind the DIR-300.

  2. Power on the DIR-300 while holding on to the reset button. Hold the reset button for 30 seconds while it is booting.

  3. Release the reset button

  4. Telnet to 192.168.20.81 on port 9000

  5. You should be greeted by the RedBoot prompt. RedBoot>