Topic: Kamikaze WiFi problem

Apologies in advance if this is a dumb newbie question.  My WRT54GL is setup with OpenWRT Kamikaze 7.09.  For the most part, it is working great for hardwired connections.  However, I have several laptops and have set them up to connect via WiFi.  They all seem to be connecting fine, they are even being given IP addresses by the DHCP server on the WRT54GL box, but after that the laptops seem unable to access the network.   Pings don't work, nor does SSH or HTTP.  The OpenWRT box cannot ping the laptops, the laptops cannot ping the OpenWRT box and the laptops cannot ping each other.  I can't figure out what I have done wrong.  Does anyone have any suggestions?  I promise that I made every effort to resolve this on my own, but I can't find anyone who has had a similar problem.  My best guess is that the WiFi is not bridging to the LAN, but that's just an uneducated guess.



Thank you in advance for your help,

Sean

Re: Kamikaze WiFi problem

I figured a few things out.  First of all, if I completely disable encryption, everything works.  If I enable WEP and set the WEP key, there are no error messages in the logs, but I see something odd in the iwconfig output:

wl0       IEEE 802.11-DS  ESSID:"SeanOpenWrt3"
          Mode:Master  Frequency:2.462 GHz  Access Point: 00:1D:7E:18:AF:54
          Tx-Power:19 dBm
          RTS thr:2347 B   Fragment thr:2346 B

          Encryption key:<too big>
          Link Noise level:-91 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:8791  Invalid misc:0   Missed beacon:0

I don't know why it thinks the encryption key is too big.  My encryption key is 26 characters, all of which are numeric (so they are valid Hex characters).  I tried all kinds of encryption keys, but get the same result.  When I use the "wlc wepkey" command, it show nothing for the wepkey.  If I try to set the wep key using the "wlc wepkey" command, I get the following error:

root@ChrisOpenWRT:/etc/config# wlc wepkey 12345678901234567890123456
Command 'set wepkey' failed: -1


I tried with quotes, same result.  I tried every length for the key, starting with 26 hex characters and working down to 1, but they all produced the same error.  Why can't I set my WEP key?

Re: Kamikaze WiFi problem

Below works for me to configure WEP encryption using UCI (/etc/config/wireless):

http://wiki.openwrt.org/OpenWrtDocs/Kam … 6a7bd92393

1x ASUS WL-700g Encore (Kamikaze 7.09, BCM947xx//953xx [2.4])
1x ASUS WL-500g Premium with Wistron CM9 WiFi card (Kamikaze 7.09, BCM947xx//953xx [2.4])
1x Linksys WRT54GL v1.1 with 512MB MMC card mod, optimized MMC driver (Kamikaze trunk r9548, BCM947xx//953xx [2.4])
NO support via PM.

Re: Kamikaze WiFi problem

That makes no sense to me, but I can confirm that it worked!!!

Thank you forum2006!! 

Here is the only part of your link that I followed:

uci set wireless.cfg2.encryption=wep
uci set wireless.cfg2.key1=<WEP_key_in_hex_format>
uci set wireless.cfg2.key=1
uci commit wireless && wifi

I don't understand it, but I'm glad you helped me fix it!

Re: Kamikaze WiFi problem

I have the same problem. My router is linksys wrt54g3g installing kamikaze 7.07. Wifi connection seems like unstable but lan connect has no problem.
ssh to kamikaze box using desktop pc, and run "wifi up", the wifi connection works again.
i write a cron job to run above instruction every half hour. "*/30 * * * * wifi up". in half hour, the wifi connection problem also incurred sometimes. but i cannot find a better solution.
before this post, i thought upgrading to kamikaze 7.09 can settle the problem. maybe it not.

6 (edited by empraptor 2007-11-17 20:57:35)

Re: Kamikaze WiFi problem

I had the same problem.

I have WRT54GL v1.1 running Kamikaze 7.09 on kernel 2.4.34.  I edited "/etc/config/wireless" directly to set the "key1" option to a 26-digit hexadecimal value and set "key" to 1.  "iwconfig" would show

Encryption key:<too big>

under the wireless interface.  My laptop would show that it was associated with the AP and try to acquire addresses and all but never really got connected.  And it'd ask for the passkey every few minutes.

Following the solution suggested here did not fix the problem.  But following the instruction on the same document to set up WPA worked beautifully.  I guess I'm happy now since WPA is recommended over WEP anyway.

http://wiki.openwrt.org/OpenWrtDocs/Kam … bd6b8b71b2

(I haven't tried WPA2.  I don't know how well my router would perform while doing WPA2)

*** WPA on my box turned out to be unstable.  128-bit WEP works now.  Please see post below ***

7 (edited by empraptor 2007-11-17 21:12:03)

Re: Kamikaze WiFi problem

So I thought WPA was working perfectly. But then it started dropping out on me every now and then. I can't find a pattern to it. But I did leave the SSH connection to the router open on my desktop and the error message "wl0: Invalid argument" was displayed repeatedly.

Sometimes the connection gets reestablished after a while and sometimes it doesn't.  I if I get impatient I reboot the router.

So I gave the instructions for WEP setup on OpenWRT Kamikaze one more try, except this time instead of using my old WEP key I followed all the steps and generated a new key as instructed. And now 128-bit WEP works! I'll have to see if it's stable but I'm hopeful.  Assume it's all fine and dandy if I don't post here again.

Also, the "Encryption key:<too big>" still appears when I run "iwconfig".  Maybe 128-bit key is too big to display in what they allocated for the field to use?  I dunno.

Re: Kamikaze WiFi problem

I'll add to this that while 64-bit wep resulted in no connectivity, 128-bit wep works fine.  Don't ask me why. tongue

Re: Kamikaze WiFi problem

Ive been also having issues with wifi stability.
It is disconnecting now and then.
Now switched to WPA2 gonna see what it changes.
Is it normal that I see Encryption key: off in iwconfig ?

wl500gp

Re: Kamikaze WiFi problem

calebz wrote:

It is disconnecting now and then.

I figured out, that this problem occours when my wrt54gl is up for a few days. After a reboot the problem disappears for 3-6 days. I also noticed that the client card may have an influence on this problem.

calebz wrote:

Now switched to WPA2 gonna see what it changes.

Does the switch to WPA fix the wifi problem or not?

Re: Kamikaze WiFi problem

I've been testing the development branch (trunk) for ~2 weeks on an Asus WL-500g Premium v1, wireless incl. It has never produced a single deauthentication with any client, while Kamikaze 7.09 has shown ample. smile I think this is because in trunk they fixed a queuing race condition issue somewhere. I recommend that you check out trunk from svn, and make your own firmware from sources.

calebz wrote:

Is it normal that I see Encryption key: off in iwconfig ?

What follows might not exactly be precise, but this is how I think WPA works. So, what you see in iwconfig is the encryption key for the 'basic' 802.11 protocol. It can run in Open or Shared mode, where Shared means a preshared WEP secret, while Open means no WEP secret. So if you use WEP you should see a value there (afaik).
Now. For WPA, the AP advertises an Open network. When the client tries to connect, it queries the AP-chosen authentication method from the 802.11x standard (where x is not a number, but a letter x smile). This is where WPA, WPA2, etc. kick in. The client is not allowed to associate with the AP (even if it is theoretically open), unless it can successfully authenticate with the chosen 802.11x method.