Using a WRT54GL, my goal was to separate the LAN from the WLAN, but bridge one port (4) with the WLAN for expansion, and also bridge one port (1) with the WAN as a bypass.  I've had great success with this configuration on 7.06 and 7.07, but it's not working so well with 7.09.  Specifically, the WLAN works and the LAN works, but the special ports are playing dead.  Any tips on extra config changes necessary for 7.09?

/etc/config/network:

#### VLAN configuration
config switch eth0
        option vlan0    "1 2 5*"
        option vlan1    "3 4 5"
        option vlan2    "0 5"

#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0

#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   10.23.1.1
        option netmask  255.255.255.0

#### WAN configuration
config interface        wan
        option ifname   "eth0.1"
        option proto    dhcp

#### WLAN configuration
config interface        wlan
        option type     bridge
        option ifname   "eth0.2"
        option proto    static
        option ipaddr   10.23.2.1
        option netmask  255.255.255.0

/etc/config/wireless:

config wifi-device  wl0
        option type     broadcom
        option channel  1
        option disabled 0

config wifi-iface
        option device   wl0
        option network  wlan
        option mode     ap
        option ssid     OpenWrt
        option hidden   0
        option encryption none

/etc/config/dhcp:

config dhcp
        option interface lan
        option start 100
        option limit 150
        option leasetime 12h

config dhcp
        option interface wan
        option ignore 1

config dhcp
        option interface wlan
        option start 100
        option limit 150
        option leasetime 12h

added to /etc/init.d/firewall:

config_get WLAN wlan ifname

#allow
iptables -A FORWARD -i $WLAN -o $WLAN -j ACCEPT
[ -z "$WAN" ] || iptables -A FORWARD -i $WLAN -o $WAN -j ACCEPT

(Last edited by wch on 11 Oct 2007, 17:02)