OpenWrt Forum Archive

Topic: HowTo configure a Bridged Client with Kamikaze ???

The content of this topic has been archived on 18 Apr 2018. There are no obvious gaps in this topic, but there may still be some posts missing at the end.

In the WitheRussian HowTo I found a ClientModeHowto, but it is using this command:

nvram set wl0_mode=wet

Does "wet" mode has an equivalent in the Kamikaze release 7.6?
Is the Bridged Client Mode available in Kamikaze SVN ?

Please describe a complete HowTo for Bridged (not Routed) Client mode in Kamikaze !

Thanx
CC

I tried Bridged client mode in Kamikaze, no luck, did not work for me.
Then, I went back to white Russ 0.9, it works great now ....

In Kamikaze, I modified the /etc/config/wireless file......change ap/sta to wet
You can try that too, and let me know if it works.....

nathan.

Last I heard, a 'wet'-compatible mode is never going to be implemented in Kamikaze sad See http://forum.openwrt.org/viewtopic.php?id=7189&p=2

A possible solution involving parprouted and dhcp-forwarder is outlined here: http://wiki.openwrt.org/WirelessBridgeWithWPAHowto

Unfortunately, the parprouted home page appears to be down at the moment, and the manpage says it's only tested with 2.4 kernels: http://downloads.openwrt.org/people/nic … ted.8.html

It has been suggested that ebtables can do MAC NAT. However this by itself won't be sufficient without some ARP spoofing and some DHCP massaging.

For now your best bet is to run WhiteRussian, but over time that will become less of a viable solution.

candlerb wrote:

Last I heard, a 'wet'-compatible mode is never going to be implemented in Kamikaze sad See http://forum.openwrt.org/viewtopic.php?id=7189&p=2

I found that thread already, thanx !

I don't understand why this mode is not supported anymore, because it is a very important use case, often needed !!!

CC

just use the regular station mode and bridge it by setting 'option network lan' in the wifi-iface section. that'll bridge the wifi to the lan.
the scripts should detect that and enable the wet mode automatically

nbd wrote:

just use the regular station mode and bridge it by setting 'option network lan' in the wifi-iface section. that'll bridge the wifi to the lan.
the scripts should detect that and enable the wet mode automatically

Hi nbd
First of all, thanx for your fantastic work in OpenWrt !!!

You mean that the WhiteRussian "wet" mode (bridged client mode)
is configured now in kamikaze doing this:
    uci set wireless.cfg2.mode=sta
    uci set wireless.cfg2.network=lan
?

I think additional we have to start the br-lan bridge by doing this too:
    uci set network.lan.type=bridge
Correct ?

CC

nbd wrote:

just use the regular station mode and bridge it by setting 'option network lan' in the wifi-iface section. that'll bridge the wifi to the lan.
the scripts should detect that and enable the wet mode automatically

OK, I can confirm this does work - very cool!

I tested with a Buffalo AirStation WHR-G54S and my own build of Kamikaze 7.07. What I did was:
(1) ipkg install kmod-brcm-wl wlc (these were missing on my unit, and without them "wifi up" gave odd errors about broadcom not being supported)
(2) vi /etc/config/network

...
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    dhcp
...

(3) vi /etc/config/wireless

config wifi-device      wl0
        option type     broadcom
        option channel  5
        option disabled 0
config wifi-iface
        option device   wl0
        option network  lan
        option mode     sta
        option ssid     MYSSID
        option hidden   0
        option encryption wep
        option key      1122334455

With this, the unit itself was able to join the wireless network. Then, plugging a laptop into a LAN port, I was able to pick up an IP address from the same network. tcpdump on another machine showed the Broadcast flag had been set in the DHCP request; and looking at the ARP cache on another machine, I could see the same MAC address for both the OpenWrt box and the laptop:

$ arp -an
? (10.69.255.103) at 00:16:01:4B:6D:6D [ether] on eth0    # << the OpenWrt box
? (10.69.255.102) at 00:16:01:4B:6D:6D [ether] on eth0    # << the laptop

So all in all, this has all been implemented completely.

Question: is this just enabling the existing functionality in the closed Broadcom 2.4 driver? Which means it may not be available to Atheros users, and/or may be lost when we move to a 2.6 Broadcom driver?

Regards, Brian.

What packages does one need to install for this work work, especially with WPA. It's not clear to me whether some previous packages needed in WR0.9 are preinstalled in Kamikaze.

All I needed was 'wlc' and 'kmod-brcm-wl', but I was using only WEP. For WPA I expect you'll need 'nas' as well.

Nas appears to already be installed. If you run ipkg list it says nas. Also I have already configured a clean install of 707 and it connects to a WPA protect WDS so it seems fine to me.

I set up WPA as recommend, using a clean 707 installation. I installed as this topic recommended and it seemed to work, but now it most certainly does not!

I saw this page but it appears to go much farther than the forum topic above (which is actually confirmed working.
http://wiki.openwrt.org/ClientModeKamik … leHowto%29

NOTE: could it be that my password has 39 characters? Or that it has semi-colons ';' in it? Other idea is that possibly there is some problem attaching to a 0.9 Whiterussian AP? It's using:

wl0_akm=psk psk2
wl0_crypto=tkip+aes

If there is anything in the whiterussian AP that's being connected to that I can change?

Is WPA supplicant required? They're all WRT54GS or WRT54GS.

I have not installed anything and the below is exactly what I have been configuring (except obscured password/SSID). All other values are default and appear to be find when compared to the suggestions in this thread.

uci set system.cfg1.hostname='hostname'

uci set wireless.wl0.channel=3
uci set wireless.wl0.disabled=0
uci set wireless.cfg2.network=lan
uci set wireless.cfg2.mode=sta
uci set wireless.cfg2.ssid='yep'
uci set wireless.cfg2.encryption=psk2
uci set wireless.cfg2.key='blahblah'

uci set network.eth0.vlan0="0 1 2 3 4 5*"
uci set network.eth0.vlan1="5"
uci set network.lan.ipaddr=192.168.1.13
uci set network.lan.gateway=192.168.1.10
uci set network.lan.dns=192.168.1.10
uci set network.wan.proto=none

uci commit

rm /etc/init.d/firewall
rm /etc/init.d/dnsmasq

(Last edited by napierzaza on 1 Aug 2007, 12:24)

Arrgh, no one has an idea?

Okay, I've installed WPA-Supplicant and it still does not come up. My other access point is now only running psk2 and TKIP, I tried the other way too (psk and AES) and no such luck. It's just not coming up into the network for some reason

Sounds a bit topsy-turvey to me: psk is tkip, and psk2 is aes.

Okay, well I supposed that would be why you don't have to set both in Kamikaze. It's weird that you had to previously I guess! That's one thing to check out!

Okay, apparently it was the funny settings on the gateway AP with WR0.9. The mode will not work if the system you are connecting to is working with both psk and psk2 (not just the client should be using only one of them!) and also the funny "both" settings I have won't work either. Nothing needs to be installed, just the settings I have posted above will make it work.

(Last edited by napierzaza on 3 Aug 2007, 22:10)

candlerb wrote:

Question: is this just enabling the existing functionality in the closed Broadcom 2.4 driver? Which means it may not be available to Atheros users, and/or may be lost when we move to a 2.6 Broadcom driver?

I'd like to know this too.  I tried to set up bridging on one of my new Meraki Minis today, and if I use the setup described in this thread it doesn't work.  Every time the wired device plugged into the mini sends a packet to anything besides the mini, it dumps this to the console:

br-lan: port 2(ath0) entering disabled state
br-lan: port 2(ath0) entering learning state
br-lan: topology change detected, propogating
br-lan: port 2(ath0) entering forwarding state

Anyway, I'm guessing from this that 'wet' is a linksys specific thing (going along with the WET part numbers on some of their bridges) and that I would need to set up MAC NAT with ebtables myself.

drow wrote:
candlerb wrote:

Question: is this just enabling the existing functionality in the closed Broadcom 2.4 driver? Which means it may not be available to Atheros users, and/or may be lost when we move to a 2.6 Broadcom driver?

I'd like to know this too.  I tried to set up bridging on one of my new Meraki Minis today, and if I use the setup described in this thread it doesn't work.  Every time the wired device plugged into the mini sends a packet to anything besides the mini, it dumps this to the console:

br-lan: port 2(ath0) entering disabled state
br-lan: port 2(ath0) entering learning state
br-lan: topology change detected, propogating
br-lan: port 2(ath0) entering forwarding state

Anyway, I'm guessing from this that 'wet' is a linksys specific thing (going along with the WET part numbers on some of their bridges) and that I would need to set up MAC NAT with ebtables myself.

I see the same with 7.09 on a WGT634U. Using fixed IP adresses, static ARP entries and ebtables, the bridge is working though. Upgrading ebtables could probably remove the need for the ARP entries.

Jochen

The discussion might have continued from here.