Zyxel switch GS1900-24E not booting after install OpenWrt

Hello i have sadly flashed the Openwrt image in the second partition, but it has to be in the first partition.
Now its not booting and i get no IP.
Is there a way to reset it to choose the other image with original firmware.

More infos i have found here.

Thanks for help!

That would probably be serial recovery.

@bmork any other idea?

1 Like

Any Infos how to Do that serial recovery?

You mean, how to hook it up or what commands to issue?

EDIT: Basically, you need to follow the instructions given for "U-Boot TFTP method" in this commit: https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=b515ad10a6e1bd5c5da0ea95366fb19c92a75dea (you referenced the GS1900-24HPv2, which is similar)

1 Like

ok got it, other way to "unbrick" is not available?
Do it need to use the normal power cable or only the serial adapter connection?
Does this adapter work?

Don't think so, unfortunately.

But hold a second before buying anything - The initramfs image, which is the one you're supposed to flash from OEM, should boot from the second partition. How exactly did you install OpenWrt and what did you try to connect to it?

Note that LED configuration might be wrong, so don't put too much into a dark LED.

You power the switch as usual and connect only TX, RX and GND to the adapter. The adapter is powered by USB.

Yes, looks fine. A bit expensive maybe, but we can hope it's not a fake... Make sure you set the adapter for 3.3V. That's the IO pin voltage - You should not connect Vcc as already mentioned.


I have seen that openwrt is flashed successfully but the ip is on other subnet, now i can connect via to luci and ssh is working. Still need to flash the sysupdate image.
I have flashed via original firmware web ui.


Running sysupgrade will install the sysupgrade image in the first partition. But you probably have to manually set the bootpartition varilable:

fw_setsys bootpartition 0

Does't look like we do that automatically


yes tried that from openwrt upgrade page but after reboot still in recovery (initramfs) mode.

That was the trick, now its online completely! Great! :grinning:

Big thanks guys!

1 Like

Just a suggestion, get yourself a 3.3V usb2serial adapter nevertheless, cp2102 and friends should be available for about a fiver with local shipping or around 1.50 EUR directly dispatched from China.


I have already the serial FTDI adapter i posted above.

Even better. The serial console header is fortunately easily accessible on these devices (just 3 standard Philips head screws and the populated header is marked and ready), with serial console access, these devices are pretty resilient.

1 Like
root@OpenWrt:~# fw_printsys

When i Set bootpartition to 1 i will get the original Firmware?

Usually, yes. But since you accidentally flashed OpenWrt to the second slot, you overwrote it with the initramfs image.

1 Like

Ok i understand. How to fix that without serial If possible.

Download the firmware from ZyXEL, unzip it, scp the *.bix file to /tmp/oem.bix or whatever and run

mtd -e runtime2 write /tmp/oem.bix runtime2

I don't guarantee anything. Haven't actually tried this. Better have that USB TTL adapter ready :slight_smile:

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.