ZyXEL NSA310b Device to Openwrt

Folks
I accidentally discovered that the NSA310 that I use as a filer has an OpenWrt image. I thought, perhaps I can move this device also onto Openwrt as it shows that there is even a factory install image:

http://downloads.openwrt.org/releases/18.06.1/targets/kirkwood/generic/openwrt-18.06.1-kirkwood-zyxel_nsa310b-squashfs-factory.bin

It says that I should make a serial cable but that is just too much trouble. Is the documentation outdated? Can I just install factory.bin and move it into the openwrt domain or the migration will be much more involved. Please help.

Anil

https://openwrt.org/toh/zyxel/nsa310b

You may need to upgrade your uboot, downloads.openwrt.org/releases/19.07.2/targets/kirkwood/generic/u-boot-nsa310/u-boot.kwb
and use the latest 19.07.2 firmware ; http://downloads.openwrt.org/releases/19.07.2/targets/kirkwood/generic/openwrt-19.07.2-kirkwood-zyxel_nsa310b-squashfs-factory.bin

But you may need to flash them from uboot, so with a ttl/serial access for admin console.

1 Like

Thanks Chief. It appears that initially we need an old USB and a serial to USB cable and installing of headers on motherboard. Without which there is no hack to get OpenWRT on NSA310 in steps.

Anil

You need an USB TTL converter like these
https://www.ftdichip.com/Products/Cables/USBTTLSerial.htm

Got it. Many thanks. Marking it solved and will restart if I run into a problem.

I was going to use the stock firmware on NSA310 but when it refused to recognize my EXT4 formatted disk, I took out my tools and box of electronics. To my surprise, the mother board already has the headers installed and initially, I made a mistake and bricked it but then I booted it using serial cable and then installed factory bin and then upgraded to latest 19.07 tar file.

All well so far. the fan isn't running and so it might get hot but that is for tomorrow to find out.

It is a cool device and reminds me of my one of the router Netgear WNDR4700 running 19.07 openwrt.

I will write a recipe and post here for others to benefit from.

Thanks.