Zyxel NR7101 challenges?

Hello. This is my first post on this forum. I have zyxel nr7101 version from telnor. Doesn't run me dhcp. I do not know if this is a problem in their configuration or if I have a damaged RJ45 port section. Certainly, the power supply does not work after af / at (for some reason it broke in the previous user, maybe later I will be interested in it and fix it). However, it works like I connected directly to the 12V board. In the uart console, when I put the plug into the RJ45 port, I see up and when I remove it down. I do not know if this means that the data bus is ok and the telnor has simply disabled dhcp or I really have a damaged RJ45 port. Can it somehow be clearly checked?

Besides, I have a log:

Z-LOADER V1.30 | 06/03/2020 08:39:30

NetLoop, call eth_halt!

NetLoop, call eth_init!
Trying Eth0 (10/100-M)

Waitting for RX_DMA_BUSY status Start ... done

Multiboot Listening ... 0

Booting image at bc14017c ...

Image Name: OpenWrt Linux-3.10.14
Image Type: MIPS Linux Kernel Image (lzma compressed)
Data Size: 14707522 Bytes = 14 MB
Load Address: 80001000
Entry Point: 80001000

This entry worries me:

NetLoop, call eth_halt!

NetLoop, call eth_init!
Trying Eth0 (10/100-M)

Is it ok?

I don't have in my log:

Hit ESC key to stop autoboot: 1

Is it normal?

Will you help?

@bmork any ideas?

Looks normal to me, but obviously incomplete.

The device page has full boot logs for both OEM and OpenWrt, including the bootloader part of the logs. Should be fairly easy to compare with those if you are in doubt: https://openwrt.org/toh/zyxel/nr7101#bootlogs

The Telenor factory config sets the device up as a "bridge". There won't be any DHCP addresses available for the LAN port unless it has a mobile network connection. And the default APNs are tied to the SIM provided with the device. Which implies that an active "Trådløst Bredbånd" service is required for DHCP on the LAN port,unless you change OEM configuration or install OpenWrt.

1 Like

Does this router (from telnor) even have any static IP address through which I can go to ssh and http?

How to check what is its current static address? Ultimately, I want to have openwrt on it. Everything else is dentures, not soft

Okay, after disabling the commands and checking with ifconfig, I know that it reports to The webgui pops up. Someone knows what the password can be. Admin and 1234 not working. root and password supervisor doesn't go either

Similar, but possibly a different password problem.

I just got a Telenor unit from Finn, and I managed to get the serial connection established with no problems. After the boot sequence seems to pause at "RILCMD STATE: RS_INIT ============> RS_IDLE", and I push a key, I am taken to a password prompt ("NR7101 login:").

Is this the point at which the supervisor password is required? I tried the generator from the other NR7101 thread with no luck, but is there another password for this stage in the process?

I have also tried admin, root, and supervisor with admin, root, supervisor, and 1234 as possible password combinations, but nothing seems to be accepted at this stage.

Am I maybe one of the unlucky ones with a newer unit with a different type of supervisor password? It appears to be from early 2022.

I have also tried resetting the configuration using the button.

I guess your device serial is above S210z1 :upside_down_face:

Yes, it's S210Z2! Do you know if it has to be 0 after Z, or is 1 also okay? Just want to make sure I understand correctly. Thanks!

My experience is that 1 is ok, but not 2..

hei har en nr7101 fra telia men får ikke logget inn via web gui. vilken usb kabael bruker du for konsoll og har du pinout , ev bilde ?
Hi, I have a nr 7101 from Telia but cannot log in via the web gui. which usb cable do you use for the console and do you have the pinout, possibly a picture?

something like https://www.amazon.de/dp/B07CQTC8P2/

checked the wiki page ?

1 Like

<$ zyxel_pwgen/getsupervisor.sh S200Z34000000

Hi what Are the last 8 Numbers from my serialisering Are 13 signs ?

read the rest of the wiki about the password ?

The output is the “Old algorithm supervisor password” applicable for the NR7101.

Yes cp2102 is good

Pinout is here

1 Like

Yes, but apparently only for Telenor branded units with a low serial number. YMMV

My serial is S200Z390xxxxx

that's why he was told to check the wiki page ...


This serial should be ok.

Hi the på gen cmd , do i have to charge to my serial ?
3265f4ce And this Numbers ?
$ zyxel_pwgen/getsupervisor.sh S200Z34000000

is -----^ your serial ?