ZyXEL NBG6817 Armor Z2 not reachable, but nmap sees it

I tried to change the IP-address of the ZyXEL NBG6817 Armor Z2 to 192.168,178.2 and I executed "apply unchecked". Afterwards the router is not reachable via ping, ssh, Firefox. Details what I did before: Changing router IP-Adress with 21.02.0 - #4 by linuxuser

nmap -PR -sn

Starting Nmap 7.80 ( https://nmap.org ) at 2021-10-17 19:37 CEST
Nmap scan report for
Host is up (0.00026s latency).
MAC Address: ..:..:..:.. (Zyxel Communications)
Nmap scan report for
Host is up.
Nmap done: 256 IP addresses (2 hosts up) scanned in 28.03 seconds

Any ideas what I could try?

1 Like

Thnaks, not sure what to do:

To enter failsafe mode, follow one of the procedures listed below:

Recommended for most users: Wait for a flashing LED and press a button. This is usually the easiest method once you figure out the correct moment.

For most users and most devices, the LEDs now (2018) provide sufficient clues as to timing to be able to avoid older recommendations to “press the XXX button as fast as you can until …” for entering failsafe mode.

Any button or a special button with the Armor Z2?

On devices with a physical reset button, OpenWrt can be reset to default settings without serial or SSH access.

Power on the device and wait for the status led to stop flashing (or go into failsafe mode, as described above).
Press and hold the reset button for 10 seconds.
Release the reset button.

The Armor Z2 has a red reset button on the backside. After power on after a while the LEDs stop blinking. So can I simply press the reset button then?

A picture of the reset button you can see here: https://www.zyxel.ch/assets/global/images/products/72/Back/Zyxel_ARMOR-Z2_7325.jpg

THe Armor Z2 has 2 images installed, 1 stable 20.02 and the other is a 20rc-version. Could this help me? But I don't know how to boot the other system.

There are multiple options, all of them working:

  • you can let your device fully boot up (wait ~2 minutes after powering up) and then press the reset button for >10s to reset the device
  • you can press any button at the right time during start up (in practice this means quickly pressing the button multiple times in quick succession, as you can't really see the exactly right time), to enter the failsafe environment (to either 'surgically' fix your configuration problem or invoke firstboot and just reset everything, like in the first approach). Any button really means any recognized button, for practical purposes the WPS button makes most sense, as the reset button has other functions while the bootloader is running (yes, the WPS button is also overloaded with FIT recovery in the bootloader, but different topic), also wait ~5 seconds after power-on before starting to 'spam' the button.
  • you could use push-button tftp recovery, which is rather mature and reliable for this device, but utter overkill for this situation
  • even more overkill, serial console access (really not needed here, but also an option).

The nbg6817 is rather reliable in this regard, with multiple layers of fallback recover mechanisms, you have to really try with intent to 'kill it for good'.

1 Like

Very simple, if you know what you must do. Pressing the reset button, when the router is on, solved it, I have access again.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.