Zyxel NBG6716 Update to 21.02.0-rc4

Great, tanks a lot! Works for me!

tried also to upgrade my NBG6716 from 19.07.8 (ar71xx) to 21.02.0 (ath79. Unfortunately I forced to install without keeping the settings. What seems a very bad idea.Couldn't get access to it. Even ping doesn't work.
Tried hardware reset with 30-30-30 and at least Tftpd but nothing worked. So my question did I really bricked the device or is there still hope for it? Any suggestions I can try?

With regards Sindbad6

I tried it too but TFTP worked for me. You have to use a switch, direct cable don't work.

Hi Guenter,

thanks for your reply. Why I need a switch? Atleast the NBG6716 includes a switch by itself, as I can see it. I mean all devices connected with cable are still accessable like on a unmanaged switch.

Okay, I tried again with an unmanaged switch in between, but the result is the same. The no download and there is no request from the router visible on the status of the my active atftpd.

You can try tftpd64 with binding ip, like this.

Hi Tassapan,
thanks for your reply. As I can see tftpd64 is for windows. I'm using Ubuntu.

This may help.
Setting up TFTP Server on Linux

Yes, it helps a bit, in the way that my atftp can't listen on port 69, which probably causes the problem. Maybe you can help me to change this. I'm not familiar with that, I'm afraid.

You can check with this.

sudo netstat -lunp | grep 69

Gives no result back. atftpd is running started with the command below:

sudo atftpd --daemon --no-fork --logfile - /srv/tftp

Okay, know I connected my lan adapter with IP again to my laptop and I get this:

udp 0 0*

But still no upolad.

To initiate I switch off the router press the button with the key (wps) and switch on again. Is this right?

Try this instead.
How can I make my tftp server visible/available on my local network?
And, yes, keep pressing WPS button while power on.

Press and hold the wps button for some time by booting.

I got a step further. Entered the command below in the terminal. With this port 69 is opened now.

sudo iptables -A INPUT -p udp --dport 69 -j ACCEPT

And I got this status message from atftpd:

Serving ras.bin to

What makes me really happy and optimistic for the next steps.

Now the LEDs are blinking as wild for 15 minutes or so. I think I should still wait until this is finished. Right?

So, my patient was gone. I switched off and on again and ....
it is running again. I'm in contact with it.

Thanks to both of you for your support. It gaves me all the little hints I needed to get it working again.
Thanks a lot!

What do you mean? The v21 upgrade was successful?

So dont need to do the zloader password to uboot method?

Does this work with the smaller 4mb nor and 128mb nand versions?

Can anyone do a dmesg to check if they were successful for v21 in 4mb and 128mb setup? Thx

I can say Flash 16 MB / RAM 256 MB works with tftp-method. I think you have to test the smaller device by yourself. But 4 MB RAM are not supportet in V 21.02

Yes, I was able to install release using the file "openwrt-21.02.0-ath79-nand-zyxel_nbg6716-squashfs-factory.bin". via tfttp. I just had to rename it to "ras.bin". After that of course, all settings were gone and I had to reconfigure the system completely.

The belonging NBG6716 has the recommended amount of memories for this release. So this is not a evidence that it works also with less of it. I would follow the hints of the experts, what I'm not.

its 4mb spi and 128mb nand, and 256mb ram

so i need to desolder the 4mb spi and replace with 8mb spi for the kernel to fit?

can i load the kernel over usb or tftp instead?


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.