Zyxel NBG6616 Bootloop in 18.0.6 and

This message is to inform devolopers about missing support fro NGB6616 in the newest version of openwrt. I have tried to upgrade my NGB6616 to 18.0.6 and (directly from lede 17 and from recovery/tftp). Both firmwares causes bootloop, and I cannot use the router before I applied stock firmware from the recovery. I also used trunk from today with the same sad result.
I have now revertet to which works.

commit e3022727658166e736198529582a46abf2397ea4 (origin/openwrt-18.06)
Author: Matthias Schiffer
Date:   Mon Aug 27 20:25:01 2018 +0200

    ar71xx/generic: enable Zyxel NBG6616 in kernel config again
    The NBG6616 shares a config symbol with the NBG6716. It was accidentally
    removed from the config when the ar71xx-tiny target was split off.

For posterity:

I can confirm the above commit does indeed fix the bootloop problem on my NBG6616.

I tested this by cherry-picking the commit onto the 18.06 branch, then building the image.

I can also confirm, using the compiled snapshot from https://downloads.openwrt.org/snapshots/targets/ar71xx/generic/openwrt-ar71xx-generic-NBG6616-squashfs-factory.bin
I used the tftp recovery method- and spend a little time to recall, that snapshots are without Luci :slight_smile:

Hi I also upgraded to the latest snapshot and while the reflashing was successful and the device is working, I am now unable to log in to router via ssh. And since this is a snapshot it doesn't have LuCI and therefore I now have no way of accessing my router.

When I try to log in via ssh it just immediately closes the connection when I enter the correct username and password. The same thing happens with both root and other users. If I enter a wrong password/user I get the normal "Access denied" reply. Any ideas on what went wrong here or how I can fix this?

First guess: you have set non-standard shell for the user(s) and that non-standard shell is not installed, so the actual login fails.

If that is true, you should still be able to enter the failsafe mode and edit /etc/passwd to set normal ash shell for root

1 Like

Ah yes you are right, I had installed bash previously and I had forgotten about it. I fixed the issue just now by pressing the factory reset -button on the router and after that I was able to log in again and install LuCI. I then installed bash and restored the backup settings which I had made earlier and now ssh works again with all users. Thanks!