ZyXEL Keenetic Viva bricking

Hello. I am new to OpenWrt.

Version: v21.02.2
Device: ZyXEL Keenetic Viva
I am trying to flash OpenWrt to my ZyXEL Keenetic Viva router. But after flashing I can't connect to it via ethernet.

Steps to reproduce:

  • Download factory firmware (and verify checksum) from Firmware Selector
  • Flash the firmware through the native web interface of the router (NDMS). On the System.Files tab, replace the "firmware" file with the "openwrt-21.02.2-ramips-mt7620-zyxel_keenetic-viva-squashfs-factory" file
  • The flashing procedure will begin
  • After flashing, it is not possible to connect to the router via ethernet

I also tried flashing v19.07.4 with the same result.

After some googling, I found that this router may have a problem with the switch. Came across this workaround: https://github.com/openwrt/openwrt/pull/2820

I tried building the firmware with this workaround by following the steps from here: https://openwrt.org/docs/guide-developer/toolchain/use-buildsystem
The only changes in menuconfig. I left the rest as default:

- Target system: MediaTek RAlink MIPS
- Subtarget: MT7620 based boards
- Target Profile: ZyXEL Keenetic Viva
- Luci=>Collections=>luci / luci-ssl

Changed the files as mentioned in the workaround:

  • target/linux/ramips/dts/mt7620a_zyxel_keenetic-viva.dts
  • target/linux/ramips/mt7620/base-files/etc/board.d/02_network

I flashed the built factory firmware through the native web interface, the result is the same :slight_smile:

To be clear, you were able to attempt 3 times. So your router isn't bricked?

How did you restore the router?

Why did you re-add something that was added 2+ years ago?

Can you better explain your issue (e.g. when you say "I can't connect to it via Ethernet" - please explain if you get network connectivity though, IP, etc....and also what exactly you're asking?

(I thought you may be asking how to unbrick your device...but your description doesn't appear as if your device is bricked...perhaps I've mistaken.)

  • Also, how long did you wait?
  • How did you determine flashing was complete?
1 Like

ZyXEL has a native firmware recovery tool

The router is connected directly to the ethernet port of the computer. The ethernet port LED on the router is off.

I can't connect to Luci at

On linux laptop:
[eklypa@mylaptop ~]$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 68:b5:99:e2:52:3c brd ff:ff:ff:ff:ff:ff
    altname enp7s0
    inet6 fe80::aa23:2ab:2bf7:1074/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 0e:ba:4e:5b:bd:6a brd ff:ff:ff:ff:ff:ff permaddr 88:53:2e:83:07:93
On Windows pc
Windows IP Configuration
Ethernet adapter Ethernet:

   Connection-specific DNS Suffix  . :
   Link-local IPv6 Address . . . . . : fe80::f85a:7933:8d0b:65f2%13
   Autoconfiguration IPv4 Address. . :
   Subnet Mask . . . . . . . . . . . :
   Default Gateway . . . . . . . . . :

The LEDs start to led constantly, without blinking.
As a test, I tried to reflash and wait 30 minutes. The result is the same.

I am asking why is OpenWrt not working on my router? Maybe I'm doing something wrong? It has been officially supported for quite some time, as far as I know.