ZyXEL GS1900-8HP v2 VLAN 100 and missing 'Switch' section in Web GUI

Hello,

Recently I've flashed stable OpenWrt version 21.02 on ZyXEL GS1900-8HP v2. With a few struggles I've managed to to that successfully. Unfortunately, I couldn't ssh into it at first. After searching forums for solution I've found that I need to setup my network card on my laptop to tag packets with VLAN 100 and connect to port 1 on the switch via ethernet cable. After that, everything worked smoothly. I could ssh into my switch as well as browse Web GUI. My question is how do I set my switch to behave as regular flashed OpenWrt device (plug & play into my router or other switches and grab IP automatically) without tagging ports and also I've found missing 'Switch' section on Web GUI for GS1900-8HP v2.

Any help is appreciated.

Edit: Included network config, changed title name and correct typo, add screenshots for comparison.

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/xx'

config device 'switch'
	option name 'switch'
	option type 'bridge'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config bridge-vlan 'wan_vlan'
	option device 'switch'
	option vlan '1'
	option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'

config device
	option name 'switch.1'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'wan'
	option device 'switch.1'
	option proto 'dhcp'

config interface 'wan6'
	option device 'switch.1'
	option proto 'dhcpv6'

config bridge-vlan 'lan_vlan'
	option device 'switch'
	option vlan '100'
	option ports 'lan1:t'

config device
	option name 'switch.100'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config interface 'lan'
	option device 'switch.100'
	option proto 'static'
	option ipaddr '192.168.1.136'
	option netmask '255.255.255.0'
	option ip6assign '60'

Here are the screenshots for comparison on the mentioned missing 'Switch' section.

According to this post I've corrected default network config which now works as it should (no VLAN 100, automatically grabs IP address and works on port 1 as well).

New default config for ZyXEL GS1900-8HP v2:

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxx:xxxx:xxxx::/xx'

config device 'switch'
	option name 'switch'
	option type 'bridge'
	option macaddr 'xx:xx:xx:xx:xx:xx'

config bridge-vlan 'lan_vlan'
	option device 'switch'
	option vlan '1'
	option ports 'lan1 lan2 lan3 lan4 lan5 lan6 lan7 lan8'

config interface 'lan'
	option device 'switch.1'
	option proto 'dhcp'

config device 'lan_switch_1_dev'
	option name 'switch.1'
	option macaddr 'xx:xx:xx:xx:xx:xx'

However there's still missing 'Switch' section in Web GUI.

2 Likes

Just save this info to others with the same problem.

The switch section are now into menu ("Network"), "Interfaces".

you will find one TAB (Devices), inside it the "Switch", and the "Configure"

I Hope this help.