ZyXEL Armor Z2 (NBG6817 / AC2600)


Yesterday I had a go at installing OpenWRT on my ZyXEL Armor Z2 (NBG6817 / AC2600).

I got the "factory" installation image from: https://downloads.openwrt.org/snapshots/targets/ipq806x/generic/openwrt-ipq806x-zyxel_nbg6817-squashfs-factory.bin

The installation was successful and I can SSH into the router but it doesn't have a GUI (LuCI). Given that I am not going to start using this as my router until I have set it up via a GUI, how would I go about installing the GUI?


As suggested in the wiki page, you can downgrade to 18.06.1 (including luci by default) - or (sticking to snapshots) by connecting your nbg6817's WAN port to your existing router (by default it will fetch an IP via DHCP) and opkg update && opkg install luci from a ssh shell.

Both 18.06.1 and current snapshots will run fine on the nbg6817, just the safe/ easy factory image (which is strongly preferred over the old manual installation approach) could only be added after 18.06.x was released.

Ah brilliant! Thank you so much :smile:

That worked, I now have OpenWRT with LuCI.

I am now running:

| Title            | Value                                                                      |
| Hostname         | OpenWrt                                                                    |
| Model            | ZyXEL NBG6817                                                              |
| Architecture     | ARMv7 Processor rev 0 (v7l)                                                |
| Firmware Version | OpenWrt SNAPSHOT r8958-8c485fbb25 / LuCI Master (git-18.363.79759-1893892) |
| Kernel Version   | 4.14.90                                                                    |

Looking through the wiki again, I see this line:

openwrt-ipq806x-zyxel_nbg6817-squashfs-factory.bin can be flashed directly from the stock OEM webinterface, older 18.06.x release images can be flashed from there via “sysupgrade -n <sysupgrade-image.bin>.

So, am I right in thinking that I did the right thing by upgrading to the snapshot release?

I am still a bit new to this; up/downgrading appears to be: sysupgrade -n <sysupgrade-image.bin> but what should I enter for <sysupgrade-image.bin>?

Ignore that last message, I figured it out.

For anyone else attempting this, I googled zyxel_nbg6817-squashfs-sysupgrade.bin which bought me to https://downloads.openwrt.org/releases/18.06.1/targets/ipq806x/generic/

I then downloaded this in my browser and used the LuCI interface to "upgrade" to this version. LuCI did not question the fact that I was downgrading -- it just worked.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.