Zyxel 3301 Plus Guide to revert back to Oem firmware

I have been trying to boot back to oem rom of zyxel 3301 plus but was unable to do so
I have tried using force sysupgrade to oem
Tried with tftp but static IP and bin name is unknown so didn't work out for me
Not sure about UART serial

If anyone knows a way please let me know

There is limited information in the git commit about flashing to OpenWrt, but I suppose you have read this already, since you have installed OpenWrt.
Maybe the developer who authored the commit has an idea.

1 Like

Thanks for the reply
I did try to contact them @hauke @avalentin
Maybe they can help me out hopefully :smile:

@bjorn Any input would be helpful

OEM firmware

1 Like

I have the firmware but I cannot boot into OEM firmware do you know any way
I tried tftp on with ras.bin in root directory but router didn't respond to it was holding wps push buttons
Tried through sysupgrade but it doesn't overwrite the openwrt firmware

@Tarmgass @bmork I believe this has same SoC as NR7101
Any methods that u might suggest to boot OEM firmware?

Last update
Tried everything that I knew failed so far I guess I'm stuck unless someone comes up with a method to try out
Thanks to the people who tried to help me out I guess I am out of luck

can you connect with ssh ?

WinScp copy oem.firmware -> tmp
cd /tmp
after mtd write oem.firmware "partition ?"

1 Like

Yes I have access to ssh
Can u please specify the command mtd write filename.bin partition
Partition=which partition should it point to
I'm new to this so could please explain me a little bit?

i have not this product !!!

cat /proc/mtd

you will have the name of the partitions similar as:

 cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00080000 00020000 "Bootloader"
mtd1: 00080000 00020000 "Config"
mtd2: 00080000 00020000 "factory"
mtd3: 00400000 00020000 "kernel"
mtd4: 07180000 00020000 "ubi"

I have kept the file as ras.bin in /tmp
cd /tmp
mtd write ras.bin partition
These 2 commands should do it?
I don't know what to specify as partition

root@OpenWrt:~# cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00080000 00020000 "uboot"
mtd1: 00080000 00020000 "uboot_env"
mtd2: 00040000 00020000 "factory"
mtd3: 01ec0000 00020000 "Kernel"
mtd4: 01ec0000 00020000 "kernel2"
mtd5: 00100000 00020000 "wwan"
mtd6: 03ee0000 00020000 "ubi"

These are the partitions what should be the command brother?

Firmware name- ras.bin
Copied to /tmp directory

What should be the command

Thank you

mtd write ras.bin Kernel or kernel2


Thanks aton brother
It really worked
Didn't know that this device had 2 kernel partitions
It would have been impossible without YOU

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.