ZTE MF286R no permission to use nandwrite

I'm facing an issue with my ZTE MF286R router. I'm trying to use the nandwrite command to write data to /dev/mtd16, but I'm encountering a permission problem. The error message I get is: "Operation not permitted."

admin@(none):~# nandwrite -p /dev/mtd16 /var/usb_disk/openwrt-23.05.0
-ath79-nand-zte_mf286r-initramfs-kernel.bin
Writing data to [ 3210.460000] illeagl access !!!
block 0 at offset 0x0
libmtd: error!: cannot write 2048 bytes to mtd16 (eraseblock 0, offset 0)
        error 1 (Operation not permitted)
nandwrite: error!: /dev/mtd16: MTD write failure
           error 1 (Operation not permitted)
Data was only partially written due to error
: Operation not permitted

I tried using cat /proc/driver/sensor_id but no file exists

admin@(none):~# cat /proc/driver/sensor_id
cat: can't open '/proc/driver/sensor_id': No such file or directory
admin@(none):/proc/driver# ls
cpu_id          ddr_id          nand_flash_id   nor_flash_id    snd-page-alloc

Can anyone provide guidance on how to gain the required permissions to execute nandwrite successfully?

Any help would be greatly appreciated.

Thank you!

Seems like this installation method doesn't work on your specific device. Attach serial console and install using one of the other described methods.

Are you absolutely sure about mtd16, i.e. have you check the content of /proc/mtd?

I tried the first method by stopping autoboot but I can't set my computer's IP to 192.168.0.22, after changing the configuration in the network card I got a different IP
obraz

how do those two relate ?

if you have DHCP disabled, the IP have to be set manually.

I set it manually but after confirming the configuration it is not saved

that's unforunately an OS issue, not related to openwrt, but you could always boot an
openwrt live image from a flash drive, configure the IP and enable the TFTPd in dnsmasq.