ZTE MF286D - QMI How to Force 3G or 4G?

I have OpenWRT with QMI working but cannot see how to set / force 4G only or 3G only. 3G is a much faster & stronger service where I'm living so I'd like to set that. At the moment, the router switches between 3G & 4G at random intervals.
Is there a menu that has the capability to set 3G or 4G , or perhaps a CLI command?

Thanks

config interface 'wan'
        option proto 'qmi'
        ...
        option modes 'umts'
        ...
1 Like

Thanks for the pointer, I tried -option modes 'lte'- in /etc/config/network and the router booted into LTE but I was not able to access the internet, removing the line booted back to 3G and all working again. I tried lte as it is not the mode that the router normally starts but does switch to from time to time.

Hope it's OK to re-start an old thread but the subject remains the same so thought it best to post here.
My ZTE MF 286D keeps switching to 4G, although I think that I have the network config set to 3G only, please snip of config file below. 3G is much better where I live so I'd like to keep that all the time.
Is there something else that I'm missing or doing wrong?
Thanks

config interface 'wwan'
	option proto 'qmi'
	option device '/dev/cdc-wdm0'
	option apn 'internet'
	option auth 'none'
	option pdptype 'ipv4'
	option modes 'umts, cdma'

You definitely don't need cdma in modes.
Don't use modes, send once from a terminal: AT+ZSNT=2,0,0

I tried that as well some time ago, still no luck...

AT+ZSNT?
+ZSNT: 2,0,0

Try at+zbandi=2
What band(s) do you use with 3G?

You can also try AT+WS46=22, but check the current and supported values first:

AT+WS46?
AT+WS46=?

I think it's Band 1 (Three UK).
Unfortunately CellMapper is not correct for the 3G services where I live as it shows towers that don't exist, but AFAIK, Band 1 is correct Three UK 3G.

AT+WS46 gives:

AT+WS46=?
+WS46: (12,22,25,28,29)

I tried at+zbandi=2 but somehow lost internet connection although so far as I could see the router was still connected. Rebooted the router and it's back on 4G LTE.

I do not see why you need Cellmapper. The question I asked could be answered by checking the modem.
Try AT+WS46=22 then give it a moment and check with AT+ZCELLINFO?

I'm no expert when it comes to AT commands or 3G/4G routers, so I used Cellmapper to see what bands were being used locally as that's what I do when I'm looking to see what 4G services there are.

So, without any other changes AT+ZCELLINFO? gives:

AT+ZCELLINFO?
+ZCELLINFO: 2989830, 229, LTE B20, 6175

After AT+WS46=22 I get back:

AT+WS46=22

Then after AT+WS46=22 & after a couple of minutes AT+ZCELLINFO?, I now get just

AT+ZCELLINFO?

Update:

Seems that it takes a few minutes for AT+ZCELLINFO? to be updated.
I now have:

AT+ZCELLINFO?
+ZCELLINFO: 23, 11501245, WCDMA 2100

Unfortunately, nothing seems to have changed.
I noticed it had switched back to 4g & now see:

AT+ZCELLINFO?
+ZCELLINFO: 2989830, 229, LTE B20, 6175

Then you can probably just disable B20.

Didn't know I could do that.... How do I disable B20?

Thanks

AT+ZNLOCKBAND=1,0,88000045,0
that will limit the LTE band list to B1 B3 B7 B28 B32

As I only need Band 1 for the moment, I tried:

AT+ZNLOCKBAND=1,0,1,0

Now, if I query the modem with AT+ZNLOCKBAND?
I get:

AT+ZNLOCKBAND?
+ZNLOCKBAND: 1,400380

The modem lost connection for a while & I rebooted it just in case but it's working again now.

Do you have a list of AT+ZNLOCKBAND codes?
I got a partial list that does not include B28 but have calculated it at 8000000 based on the list below

The list I have is:

Band locking examples:
AT+ZNLOCKBAND=1,0,1,0 - Band 1
AT+ZNLOCKBAND=1,0,4,0 - Band 3
AT+ZNLOCKBAND=1,0,40,0 - Band 7
AT+ZNLOCKBAND=1,0,80000,0 - Band 20
AT+ZNLOCKBAND=1,0,41,0 - Band B1 +B7
AT+ZNLOCKBAND=1,0,45,0 - Band B1 + B3 + B7
AT+ZNLOCKBAND=1,0,80040,0 Band 7 + 20
AT+ZNLOCKBAND=1,0,80005,0 Band 20 + 1 +3
AT+ZNLOCKBAND=1,0,2,0 - Band 2
AT+ZNLOCKBAND=1,0,10,0 - Band 5
AT+ZNLOCKBAND=1,0,80000000,0 - Band 32

Thanks for your help today.

I've just restarted the WWAN interface after a couple of days without seeing a connection to LTE, the interface came back up with a 3G connection whereas before it would often start on 4G so I'm marking this as Solved for now at least and will update if things change.
As I'm using 3UK, it's fairly straightforward to limit the modem to Band 1 for 3G only:

AT+ZNLOCKBAND=1,0,1,0

Many thanks to @AndrewZ

This is not what I recommended.
With this command you set the LTE bands to B1 only.

I know it's not what you recommended but I did leave it for a couple of days after posting what I'd done and got no feedback so assumed you were ok with it.
From looking at the 3UK Band list, they only use Band1 for 3G and don't use Band 1 for LTE, so I don't really get why I would want to limit the LTE band list to B1 B3 B7 B28 B32?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.