ZTE MF286D can't get connection over LTE

I don't know if i understood corectly...
interface restart logs from luci:

Tue Aug 27 16:27:19 2024 daemon.notice netifd: lte (2629): Stopping network lte
Tue Aug 27 16:27:19 2024 daemon.notice netifd: lte (2629): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Tue Aug 27 16:27:19 2024 daemon.notice netifd: Interface 'lte' is now down
Tue Aug 27 16:27:19 2024 daemon.notice netifd: Interface 'lte' is setting up now
Tue Aug 27 16:27:19 2024 daemon.notice netifd: lte (2637): Waiting for SIM initialization
Tue Aug 27 16:27:20 2024 daemon.warn odhcpd[1303]: No default route present, overriding ra_lifetime!

router start logs: https://pastebin.com/g3SFa4rR password: 333

don't set IP type to IPV4V6 until you're 100% sure that provider supports IPv6

please refer to https://openwrt.org/docs/guide-user/network/wan/wwan/ltedongle

See also ZTE MF286D LTE modem not working with QMI - #14 by AndrewZ
Thanks to @Leo-PL for reminder.

1 Like

Looks to me like the modem isn't registered right at the startup, try to increase option delay to, say, 30 or 60 seconds. Does your SIM require PIN? What's the modem LED colour at startup?

This matches, but please double check if your ISP wants dual-stack connectivity. What is your operator?

virgin mobile from Poland but it's uses play cell towers.
the led color is blue. My sim don't reqire PIN.

every time i use command AT+CGDCONT? it freezes after and even ctr+c don't help

AT+CGDCONT?
+CGDCONT: 1,"IP","internet","0.0.0.0",0,0,0,0

OK
root@OpenWrt:/# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdc4:84b2:ad72::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'lan2'
        list ports 'lan3'
        list ports 'lan4'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config interface 'wan'
        option device 'wan'
        option proto 'dhcp'

config interface 'wan6'
        option device 'wan'
        option proto 'dhcpv6'

config interface 'lte'
        option proto 'qmi'
        option device '/dev/cdc-wdm0'
        option pdptype 'ipv4'
        option apn 'internet'
        option auth 'none'
        option delay '60'

Tue Aug 27 16:03:41 2024 daemon.notice netifd: lte (1734): Waiting for SIM initialization
Tue Aug 27 16:03:52 2024 daemon.notice netifd: lte (1734): Failed to parse message data
Tue Aug 27 16:03:52 2024 daemon.notice netifd: lte (1734): PIN verification is disabled
Tue Aug 27 16:03:53 2024 daemon.notice netifd: lte (1734): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
Tue Aug 27 16:03:54 2024 daemon.notice netifd: lte (1734): Waiting for network registration
Tue Aug 27 16:03:55 2024 daemon.notice netifd: lte (1734): Starting network lte

You need to show more lines.
The best way to get the releveant information from the log is to run logread -f and then restart the interface in Luci.

root@OpenWrt:/# logread -f
Tue Aug 27 16:03:17 2024 daemon.warn odhcpd[1273]: No default route present, overriding ra_lifetime!
Tue Aug 27 16:03:24 2024 daemon.err uhttpd[1398]: [info] luci: accepted login on /admin/network/network for root from 192.168.1.3
Tue Aug 27 16:03:30 2024 daemon.notice netifd: lte (2412): Stopping network lte
Tue Aug 27 16:03:30 2024 daemon.notice netifd: lte (2412): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Tue Aug 27 16:03:30 2024 daemon.notice netifd: Interface 'lte' is now down
Tue Aug 27 16:03:30 2024 daemon.notice netifd: Interface 'lte' is setting up now
Tue Aug 27 16:03:31 2024 daemon.warn odhcpd[1273]: No default route present, overriding ra_lifetime!

You need to wait!

nothing more happens

root@OpenWrt:/# logread -f
Tue Aug 27 16:07:41 2024 daemon.notice netifd: lte (2547): Stopping network lte
Tue Aug 27 16:07:41 2024 daemon.notice netifd: lte (2547): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Tue Aug 27 16:07:41 2024 daemon.notice netifd: Interface 'lte' is now down
Tue Aug 27 16:07:41 2024 daemon.notice netifd: Interface 'lte' is setting up now
Tue Aug 27 16:07:42 2024 daemon.warn odhcpd[1273]: No default route present, overriding ra_lifetime!
Tue Aug 27 16:08:41 2024 daemon.notice netifd: lte (2556): Waiting for SIM initialization
Tue Aug 27 16:16:01 2024 daemon.warn odhcpd[1273]: No default route present, overriding ra_lifetime!

Have you changed the timeout in the connection script?

yes to 10000
after reboot

Tue Aug 27 16:03:17 2024 daemon.notice netifd: lte (2430): Stopping network lte
Tue Aug 27 16:03:17 2024 daemon.notice netifd: lte (2430): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Tue Aug 27 16:03:17 2024 daemon.notice netifd: Interface 'lte' is now down
Tue Aug 27 16:03:17 2024 daemon.notice netifd: Interface 'lte' is setting up now
Tue Aug 27 16:03:18 2024 daemon.warn odhcpd[1296]: No default route present, overriding ra_lifetime!
Tue Aug 27 16:03:34 2024 daemon.warn odhcpd[1296]: No default route present, overriding ra_lifetime!
Tue Aug 27 16:04:17 2024 daemon.notice netifd: lte (2438): Waiting for SIM initialization
Tue Aug 27 16:04:28 2024 daemon.notice netifd: lte (2438): Failed to parse message data
Tue Aug 27 16:04:28 2024 daemon.notice netifd: lte (2438): PIN verification is disabled
Tue Aug 27 16:04:29 2024 daemon.notice netifd: lte (2438): Device does not support 802.3 mode. Informing driver of raw-ip only for wwan0 ..
Tue Aug 27 16:04:29 2024 daemon.notice netifd: lte (2438): Waiting for network registration
Tue Aug 27 16:04:31 2024 daemon.notice netifd: lte (2438): Starting network lte

Then use a terminal like picocom and check

at+cereg?
at+cgdcont?
at+cgpaddr
root@OpenWrt:/# picocom /dev/ttyUSB2
picocom v3.1

port is        : /dev/ttyUSB2
flowcontrol    : none
baudrate is    : 9600
parity is      : none
databits are   : 8
stopbits are   : 1
escape is      : C-a
local echo is  : no
noinit is      : no
noreset is     : no
hangup is      : no
nolock is      : no
send_cmd is    : sz -vv
receive_cmd is : rz -vv -E
imap is        :
omap is        :
emap is        : crcrlf,delbs,
logfile is     : none
initstring     : none
exit_after is  : not set
exit is        : no

Type [C-a] [C-h] to see available commands
Terminal ready
at+cereg?
+CEREG: 0,1

OK
at+cgdcont?
+CGDCONT: 1,"IP","internet","0.0.0.0",0,0,0,0

OK
at+cgpaddr
+CGPADDR: 1,100.100.156.106

OK

Well, you're registered and got an IP address from the carrier.
One more check please: ati
No need to copy/paste the program help :wink:

ati
Manufacturer: ZTE CORPORATION
Model: MF286DMODULE
Revision: BD_MF286DMODULEV1.0.0B03
SVN: 01
IMEI: 1223231311242243 #changed it
+GCAP: +CGSM

OK

Update the modem firmware to BD_TELIAMF286DV1.0.0B12 or later.
Then I would flash the OEM Nordic_B12 (or later) to the router and use it in a bridge mode, but you can keep trying with OpenWrt if you wish.

how to do it? and why in bridege mode?

Please use search.

I'm 100% sure it's IPv4-only. Also virgin uses virgin-internet APN according to the provider database found in Debian.

I think both of them work/don't

Terminal ready
at+cereg?
+CEREG: 0,1

OK
at+cgdcont?
+CGDCONT: 1,"IP","virgin-internet","0.0.0.0",0,0,0,0

OK
at+cgpaddr
+CGPADDR: 1,10.79.105.190

OK

Wed Aug 28 09:52:04 2024 daemon.notice netifd: lte (2600): Stopping network lte
Wed Aug 28 09:52:04 2024 daemon.notice netifd: lte (2600): Command failed: ubus call network.interface notify_proto { "action": 0, "link-up": false, "keep": false, "interface": "lte" } (Permission denied)
Wed Aug 28 09:52:04 2024 daemon.notice netifd: Interface 'lte' is now down
Wed Aug 28 09:52:04 2024 daemon.notice netifd: Interface 'lte' is setting up now
Wed Aug 28 09:52:05 2024 daemon.warn odhcpd[1296]: No default route present, overriding ra_lifetime!
Wed Aug 28 09:53:04 2024 daemon.notice netifd: lte (2608): Waiting for SIM initialization