Zte mf286/286a no 5ghz wifi

Hi all,

I'm in a bit of trouble finding 5ghz radio wifi driver(at least i think thats the issue) for my device. I guess i have in-between model of zte286 - zte286a, on device itself it says 286a, but installing 286a firmware i got kernel panic. So i tried 286 instead and Viola, after setup everything works as supposed too, apart from 5ghz wifi. etc/config/wireless shows only one radio and any other command to check wireless devices through terminal also only shows 1 radio(2.4ghz one). I tried plenty qca98xx packages to no avail.

Is there any way to find 5ghz driver and/or module name itself? Without reinstalling original firmware of course.

Okay, figured it out. In case anyone else needs it in the future
Make sure you have 'ath10k-board-qca9888" and "ath10k-firmware-qca9888" installed and help system find it during boot, via this command through ssh:

dd if=/dev/mtd1 bs=1 skip=20480

count=12064 of=/lib/firmware)

/ath10k/QCA9888/hw2.0/board.bin

Reboot and thats it

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.