ZTE MF190 gsm modem qmi not working by configuring luci-proto-qmi

Hello,

I have a usb dongle ZTE MF190 and I added a network interface in the web configuration using qmi cellular protocol but it does NOT work (Rx is 0 and Tx is 0), BUT WORKS like this:

//run this cmds
wds=uqmi -s -d /dev/cdc-wdm0 --get-client-id wds
uqmi -d /dev/cdc-wdm0 --set-client-id wds,"$wds" --start-network myapn

and in web config add interface wwan , protocol dhcp , physical interface wwan0

//version:
OpenWrt 19.07.4 r11208-ce6496d796 / LuCI openwrt-19.07 branch git-20.247.75781-0d0ab01

web interface log:

Fri Nov 20 05:44:27 2020 kern.info kernel: [  212.833626] usb 1-1: new high-speed USB device number 2 using ehci-pci
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.046374] option 1-1:1.0: GSM modem (1-port) converter detected
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.053989] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.063364] option 1-1:1.1: GSM modem (1-port) converter detected
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.070832] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.080377] option 1-1:1.2: GSM modem (1-port) converter detected
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.087901] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.191473] qmi_wwan 1-1:1.3: cdc-wdm0: USB WDM device
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.200093] qmi_wwan 1-1:1.3 wwan0: register 'qmi_wwan' at usb-0000:00:03.2-1, WWAN/QMI device, 76:91:73:a0:fe:e0
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.211849] usb-storage 1-1:1.4: USB Mass Storage device detected
Fri Nov 20 05:44:27 2020 kern.info kernel: [  213.264995] scsi host0: usb-storage 1-1:1.4
Fri Nov 20 05:44:28 2020 kern.notice kernel: [  214.331808] scsi 0:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
Fri Nov 20 05:44:29 2020 kern.notice kernel: [  214.357956] sd 0:0:0:0: [sda] Attached SCSI removable disk
Fri Nov 20 05:44:29 2020 kern.info kernel: [  214.623456] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
Fri Nov 20 05:44:29 2020 kern.info kernel: [  214.632255] option 1-1:1.0: device disconnected
Fri Nov 20 05:44:38 2020 daemon.notice netifd: Interface 'wwancelular' is setting up now
Fri Nov 20 05:44:39 2020 daemon.notice netifd: wwancelular (2053): Waiting for SIM initialization
Fri Nov 20 05:44:40 2020 daemon.notice netifd: wwancelular (2053): PIN verification is disabled
Fri Nov 20 05:46:31 2020 daemon.notice netifd: wwancelular (2266): Stopping network wwancelular
Fri Nov 20 05:46:31 2020 daemon.notice netifd: wwancelular (2266): Command failed: Permission denied
Fri Nov 20 05:46:31 2020 daemon.notice netifd: Interface 'wwancelular' is now down
Fri Nov 20 05:46:31 2020 daemon.notice netifd: Interface 'wwancelular' is setting up now
Fri Nov 20 05:46:32 2020 daemon.notice
---dmesg :
[  212.833626] usb 1-1: new high-speed USB device number 2 using ehci-pci
[  213.046374] option 1-1:1.0: GSM modem (1-port) converter detected
[  213.053989] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB0
[  213.063364] option 1-1:1.1: GSM modem (1-port) converter detected
[  213.070832] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB1
[  213.080377] option 1-1:1.2: GSM modem (1-port) converter detected
[  213.087901] usb 1-1: GSM modem (1-port) converter now attached to ttyUSB2
[  213.191473] qmi_wwan 1-1:1.3: cdc-wdm0: USB WDM device
[  213.200093] qmi_wwan 1-1:1.3 wwan0: register 'qmi_wwan' at usb-0000:00:03.2-1, WWAN/QMI device, 76:91:73:a0:fe:e0
[  213.211849] usb-storage 1-1:1.4: USB Mass Storage device detected
[  213.264995] scsi host0: usb-storage 1-1:1.4
[  214.331808] scsi 0:0:0:0: Direct-Access     ZTE      MMC Storage      2.31 PQ: 0 ANSI: 2
[  214.357956] sd 0:0:0:0: [sda] Attached SCSI removable disk
[  214.623456] option1 ttyUSB0: GSM modem (1-port) converter now disconnected from ttyUSB0
[  214.632255] option 1-1:1.0: device disconnected
lsusb -t
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=uhci_hcd/2p, 12M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/2p, 480M
    |__ Port 1: Dev 2, If 0, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 1: Dev 2, If 1, Class=Vendor Specific Class, Driver=option, 480M
    |__ Port 1: Dev 2, If 2, Class=Vendor Specific Class, Driver=option, 480M
    |__ Port 1: Dev 2, If 3, Class=Vendor Specific Class, Driver=qmi_wwan, 480M
    |__ Port 1: Dev 2, If 4, Class=Mass Storage, Driver=usb-storage, 480M
lsusb
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 002: ID 19d2:0017 ZTE WCDMA Technologies MSM 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

did you install the 3G/LTE Luci addon for USB 3G specific configuration ?

If I remember correctly, when adding a new WWAN interface, there's a specific 3g/LTE option
with this addon installed.

Might be different when it's QMI though.

Yes I followed the link indicated by you. This part did not work for me --> Install the package luci-proto-qmi using Luci (System → Software) and configure the modem using LuCi (Network → Interfaces). I could not make it work when I add an interface by choosing protocol = "qmi cellular".

I also followed this guide https://teklager.se/en/knowledge-base/openwrt-4g-wwan-configuration/ which is quite similar, but did not work either.

worked only when I added in /etc/rc.local the following:
wds=uqmi -s -d /dev/cdc-wdm0 --get-client-id wds
uqmi -d /dev/cdc-wdm0 --set-client-id wds,"$wds" --start-network myapn --autoconnect

and in interfaces i added an interface wwan with protocol dhcp and in physical settings i choose wwan0.

works like this so I leave it like this

Hi

You have "Command failed: Permission denied" in the Web interface log. Have you set the correct APN and username/password, if you use that?