ZTE MF17T on TP-Link TL-WDR4900 running OpenWrt 18.06.2 [SOLVED]

Hi there!

I've got a ZTE MF17T modem from the mobile provider https://www.drei.at (Hutchison Austria)
I'd like to get it working together with my TP-Link TL-WDR4900 which I upgraded to OpenWrt 18.06.2 r7676-cddd7b4c77 / LuCI openwrt-18.06 branch (git-19.020.41695-6f6641d) for the occasion.

The modem worked out of the box on my Manjaro laptop, giving this output on dmesg:

[  +0,329930] usb 2-2: new high-speed USB device number 9 using xhci_hcd
[  +0,152073] usb 2-2: New USB device found, idVendor=19d2, idProduct=1405, bcdDevice=53.25
[  +0,000002] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  +0,000001] usb 2-2: Product: ZTE Technologies MSM
[  +0,000001] usb 2-2: Manufacturer: ZTE,Incorporated
[  +0,000000] usb 2-2: SerialNumber: 1234567890ABCDEF
[  +0,006243] cdc_ether 2-2:1.0 usb0: register 'cdc_ether' at usb-0000:00:14.0-2, ZTE CDC Ethernet Device, 06:11:93:17:2c:a8
[  +0,004105] usb-storage 2-2:1.2: USB Mass Storage device detected
[  +0,000234] scsi host5: usb-storage 2-2:1.2
[  +0,018035] cdc_ether 2-2:1.0 enp0s20u2: renamed from usb0

On my TP-Link TL-WDR4900 i see this output on dmesg:

[  198.596446] usb 1-1.1: new full-speed USB device number 4 using fsl-ehci
[  198.764450] usb 1-1.1: new high-speed USB device number 5 using fsl-ehci

And I've found this in /sys/kernel/debug/usb/devices:

T:  Bus=01 Lev=02 Prnt=02 Port=00 Cnt=01 Dev#=  5 Spd=480  MxCh= 0
D:  Ver= 2.00 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=19d2 ProdID=1225 Rev=53.25
S:  Manufacturer=ZTE,Incorporated
S:  Product=ZTE Technologies MSM
S:  SerialNumber=1234567890ABCDEF
C:* #Ifs= 1 Cfg#= 1 Atr=80 MxPwr=500mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

I've installed these packages:

# opkg find *usb*
kmod-usb-core - 4.9.152-1
kmod-usb-net - 4.9.152-1
kmod-usb-net-cdc-ether - 4.9.152-1
kmod-usb-net-rndis - 4.9.152-1

But I could not find any of those:

Unknown package 'kmod-usb2'.
Unknown package 'kmod-usb3'.
Unknown package 'kmod-usb-uhci'.
Unknown package 'kmod-usb-ohci'.
Unknown package 'kmod-usb-serial-option'.
Unknown package 'kmod-usb-serial'.
Unknown package 'kmod-usb-serial-wwan'.
Unknown package 'kmod-usb-net-cdc-mbim'.
Unknown package 'umbim'.

Though I don't know if any of those would be absolutely necessary in my situation, I just stumbled upon them in various OpenWrt wiki entries, like those:


Can somebody help me get this to work? I'm sadly quite out of my element here.

UPDATE: okey so it seems those opkg failures have been caused by the cache beeing cleared quite fast, so when I ran opkg update immediately before any opkg install call makes it find the packages it couldn't before.

Now it registered as a cdc ethernet device:

[ 5270.034812] cdc_ether 1-1.1:1.0 usb0: register 'cdc_ether' at usb-fsl-ehci.0-1.1, ZTE CDC Ethernet Device, ea:31:f4:96:9a:e7

UPDATE2: I've been able to create an interface and firewall zone and it works now as expected. So the only thing that hindered me initially was that the opkg cache seems to be lost quite fast.

solved it myself, see updates in first post.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.