Zotac Zbox C1660 X86 Installation

Hello,

I am having trouble starting OpenWRT normally after flashing the 21.02.3 generic-ext4-combined-efi image to my SSD.

I get the following error message when booting up the system: disk 'sda1.gpt1' not found.

From what little information is available to me it seems that GRUB 2 is trying to locate the needed data from the wrong location on my SSD

Here is what I do not know how to do yet:

  1. How to locate where to point GRUB 2 is looking for the data
  2. How to point GRUB 2 in the right direction from the boot menu.

Googling wasn't especially helpful, so I would be grateful if someone could help me out.

1 Like

Just to rule out the most common misconceptions, how exactly did you write OpenWrt to your disk? Did you disable secure boot?

Thank you for taking the time to respond. I am happy to answer these questions as I am new to running OpenWRT on x86. To answer your questions:

I removed the SSD from the device, hooked it up to my main Windows 11 PC with a USB to SATA cable, formatted the SSD using Windows 11's disk managment tool (with a FAT32 filing system). I proceeded to wipe the whole disc's partition using diskpart. I also checked the SSD for any errors (none found). I proceeded to use Balena etcher to flash the x86 OpenWRT image onto the SSD. When that was all done, I put the SSD back into the intended x86 device and started it up as per usual. I got to the GRUB 2 menu where the boot options are OpenWRT or OpenWRT(failsafe). When I choose any of these two options, the system gives me the error as per my original post.

I have checked this in the installation device's BIOS and this option was disabled. Am I right in stating that OpenWRT installations do not support this feature?

When in grub, press e, and post a pic of the settings for the openwrt boot configuration.

Correct, and in all likeliness it'll never do (plain UEFI, yes - secure boot, no).

Thank you @frollic and @slh for taking an interest and trying to help a fellow human out. I managed to get OpenWRT to load using the Command option in the GRUB 2 bootloader.

Here is what I did:
I used the ls line command to list all the available partitions.
I noticed that the partition (HD1,GPT 1) was the partition that the bootloader was looking for. I used the set root=(hd1,gpt 1) line command to tell GRUB 2 where the correct partition is to look in. It then successfully loaded and booted OpenWRT. Using WinSCP, I then tunnelled into the router and changed the default values of the grub.cfg in /boot/grub/ to point to the right partition on each start-up. Still not entirely sure why the GRUB bootloader was looking for a partition on the SSD that did not exist, but this at least solved the problem for me.