ZBT WG3526 4G to LAN doesn't work

Hello I have a ZBT WG3526 with 4G modem it works well between 4G and WIFI but not between 4G and LAN!

While between WIFI and LAN it works very well!

Is there a feature to activate or is it not possible?

Thanks.

should work out of the box.

post your /etc/config/network file

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd*******:4873::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'f8:*******:df:a8'

config interface 'wan'

That's all of it?

What's the deal with lan and lan_dev?

Yes it vas the return when i type vi /etc/config/network file

The network file is incomplete -- you only captured the first screenful.
Try the following (and let's see the other files, too.)

Please copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
`root@Router:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd**:****:****::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0.1'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device 'lan_dev'
        option name 'eth0.1'
        option macaddr 'f8:**:**:**:**:**'

config interface 'wan'
        option ifname 'eth0.2'
        option proto 'dhcp'
        option metric '10'

config device 'wan_dev'
        option name 'eth0.2'
        option macaddr 'f8:**:**:**:**:**'

config interface 'wan6'
        option ifname 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

config interface '4g'
        option ifname 'usb0'
        option proto 'dhcp'
        option model '/usr/sbin/quectel_gobinet'
        option metric '20'`
root@Router:~# cat /etc/config/wireless

config wifi-device 'mt7603e'
        option type 'mt7603e'
        option vendor 'ralink'
        option band '2.4G'
        option radio '1'
        option disabled '0'
        option region '1'
        option txpower '100'
        option wifimode '9'
        option channel '0'
        option bw '1'
        option ht_extcha '1'
        option ht_bsscoexist '0'

config wifi-iface
        option device 'mt7603e'
        option ifname 'ra0'
        option network 'lan'
        option mode 'ap'
        option ssid 'WIFI*********'
        option encryption 'psk2+ccmp'
        option key '********************************'

config wifi-device 'mt7612e'
        option type 'mt7612e'
        option vendor 'ralink'
        option band '5G'
        option radio '1'
        option autoch '2'
        option disabled '0'
        option aregion '0'
        option txpower '100'
        option wifimode '14'
        option bw '2'
        option channel '165'

config wifi-iface
        option device 'mt7612e'
        option ifname 'rai0'
        option network 'lan'
        option mode 'ap'
        option ssid 'WIFI-5G*******'
        option encryption 'psk2+ccmp'
        option key '******************************************'
root@Router:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.auto'
        option localservice '1'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

root@Router:~# cat /etc/config/firewall
config defaults
        option syn_flood        1
        option input            ACCEPT
        option output           ACCEPT
        option forward          REJECT
# Uncomment this line to disable ipv6 rules
#       option disable_ipv6     1

config zone
        option name             lan
        list   network          'lan'
        option input            ACCEPT
        option output           ACCEPT
        option forward          ACCEPT

config zone
        option name             wan
        list   network          'wan'
        list   network          'wan6'
        list   network          '4g'
        list   network          '4g2'
        option input            REJECT
        option output           ACCEPT
        option forward          REJECT
        option masq             1
        option mtu_fix          1

config forwarding
        option src              lan
        option dest             wan

# We need to accept udp packets on port **,
# see https://dev.openwrt.org/ticket/****
config rule
        option name             Allow-DHCP-Renew
        option src              wan
        option proto            udp
        option dest_port        **
        option target           ACCEPT
        option family           ipv4

# Allow IPv4 ping
config rule
        option name             Allow-Ping
        option src              wan
        option proto            icmp
        option icmp_type        echo-request
        option family           ipv4
        option target           ACCEPT

config rule
        option name             Allow-IGMP
        option src              wan
        option proto            igmp
        option family           ipv4
        option target           ACCEPT

# Allow DHCPv6 replies
# see https://dev.openwrt.org/ticket/*****
config rule
        option name             Allow-DHCPv6
        option src              wan
        option proto            udp
        option src_ip           fc00::/6
        option dest_ip          fc00::/6
        option dest_port        546
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-MLD
        option src              wan
        option proto            icmp
        option src_ip           fe80::/10
        list icmp_type          '130/0'
        list icmp_type          '131/0'
        list icmp_type          '132/0'
        list icmp_type          '143/0'
        option family           ipv6
        option target           ACCEPT

# Allow essential incoming IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Input
        option src              wan
        option proto    icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        list icmp_type          router-solicitation
        list icmp_type          neighbour-solicitation
        list icmp_type          router-advertisement
        list icmp_type          neighbour-advertisement
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

# Allow essential forwarded IPv6 ICMP traffic
config rule
        option name             Allow-ICMPv6-Forward
        option src              wan
        option dest             *
        option proto            icmp
        list icmp_type          echo-request
        list icmp_type          echo-reply
        list icmp_type          destination-unreachable
        list icmp_type          packet-too-big
        list icmp_type          time-exceeded
        list icmp_type          bad-header
        list icmp_type          unknown-header-type
        option limit            1000/sec
        option family           ipv6
        option target           ACCEPT

config rule
        option name             Allow-IPSec-ESP
        option src              wan
        option dest             lan
        option proto            esp
        option target           ACCEPT

config rule
        option name             Allow-ISAKMP
        option src              wan
        option dest             lan
        option dest_port        ***
        option proto            udp
        option target           ACCEPT

# include a file with users custom iptables rules
config include
        option path /etc/firewall.user


### EXAMPLE CONFIG SECTIONS
# do not allow a specific ip to access wan
#config rule
#       option src              lan
#       option src_ip   192.168.**.**
#       option dest             wan
#       option proto    tcp
#       option target   REJECT

# block a specific mac on wan
#config rule
#       option dest             wan
#       option src_mac  00:**:**:**:**:**
#       option target   REJECT

# block incoming ICMP traffic on a zone
#config rule
#       option src              lan
#       option proto    ICMP
#       option target   DROP

# port redirect port coming in on wan to lan
#config redirect
#       option src                      wan
#       option src_dport        **
#       option dest                     lan
#       option dest_ip          192.168.**.**
#       option dest_port        **
#       option proto            tcp

# port redirect of remapped ssh port (******) on wan
#config redirect
#       option src              wan
#       option src_dport        *******
#       option dest             lan
#       option dest_port        **
#       option proto            tcp

### FULL CONFIG SECTIONS
#config rule
#       option src              lan
#       option src_ip   192.168.**.**
#       option src_mac  00:**:**:**:**:**
#       option src_port **
#       option dest             wan
#       option dest_ip  194.**.**.**
#       option dest_port        **
#       option proto    tcp
#       option target   REJECT

#config redirect
#       option src              lan
#       option src_ip   192.168.**.**
#       option src_mac  00:**:**:**:**:**
#       option src_port         ****
#       option src_dport        **
#       option dest_ip  194.**.**.**
#       option dest_port        **
#       option proto    tcp

what version of OpenWrt are you using?

ubus call system board
root@Router:~# ubus call system board
{
        "kernel": "4.4.61",
        "hostname": "Router",
        "system": "MediaTek MT7621 ver:1 eco:3",
        "model": "ZBT-WG3526",
        "release": {
                "distribution": "LEDE",
                "version": "SNAPSHOT",
                "revision": "22.0714_114130",
                "codename": "reboot",
                "target": "ramips\/mt7621",
                "description": "LEDE Reboot SNAPSHOT 17.01"
        }
}

This is a really old version of OpenWrt and it is EOL and unsupported. Further, it looks like this may be a custom fork created by ZTE.

Your device appears to be supported by the official OpenWrt project, so I would recommend that you install 22.03.3 (latest as of this writing).

When using forks/offshoots/vendor-specific builds that are "based on OpenWrt", there may be many differences compared to the official versions (hosted by OpenWrt.org). Some of these customizations may fundamentally change the way that OpenWrt works. You might need help from people with specific/specialized knowledge about the firmware you are using, so it is possible that advice you get here may not be useful.

You may find that the best options are:

  1. Install an official version of OpenWrt, if your device is supported (see https://firmware-selector.openwrt.org).
  2. Ask for help from the maintainer(s) or user community of the specific firmware that you are using.
  3. Provide the source code for the firmware so that users on this forum can understand how your firmware works (OpenWrt forum users are volunteers, so somebody might look at the code if they have time and are interested in your issue).

If you believe that this specific issue is common to generic/official OpenWrt and/or the maintainers of your build have indicated as such, please feel free to clarify.

1 Like

I have try to load the firmware from the web interface and now the unit doesn't respond

the version was openwrt-22.03.3-ramips-mt7621-zbtlink_zbt-wg3526-16m-squashfs-sysupgrade

Did it give you any options to select and/or any information and/or warnings before it flashed the image?

I have to force update because it say that its not the good firmware

In the future, if you get that message, it is best to ask questions before forcing it. I would have recommended a progressive upgrade path -- I'm sorry I didn't mention it in my earlier reply.

Do you have a serial-to-usb adapter? You're probably going to need to do some debricking work with a UART connection.

Doesn't ZBT have some kind of httpd based recovery?

Btw. a factory reset might already help (to clear out incompatible configuration setting between ZBT's OEM firmware and OpenWrt):

The firmware that I download from the OpenWrt site is not the same size as the original firmware!

Firmware on OpenWrt: openwrt-22.03.3-ramips-mt7621-zbtlink_zbt-wg3526-16m-squashfs-sysupgrade.bin = 6.5MB

Original firmware: lede-ramips-mt7621-zbt-wg3526-22.0714_114302.bin = 9.8MB

In my opinion it is not compatible at all !!!

The size would not be expected to be the same.

I’m not sure how you have arrived at this conclusion.
If you are able to recover to a running firmware, it should be possible to run openwrt (you’ll just need to progressively upgrade rather than make a single large version jump).