ZBT WG3526: 18.06-snapshot weird issue: Ethernet slow but Wireless fine!

Hi,
I compiled an 18.06 system for my ZBT WG3526 router.
OpenWrt 18.06-SNAPSHOT r7161-b84a1c56f3 / LuCI openwrt-18.06 branch (git-18.206.16200-7501bf6)

This router uses the MT7621 processor.

I have found a weird thing: Wireless MAC80211 802.11nac runs at full speed on my Wireless NBN system (Max speed 25Mb/s), so on wireless I measure about 21Mb/s. If I hard-cable (ethernet) my maximum throughput is about 5Mb/s, or about 80% slower. I tried the computer connection as Wireless, then wired, then wireless & found the internet speed was ~5Mb/s, then 21Mb/s with nac wireless, then back to 5 again with cable etc, so the issue is definitely router related. (I could see no issues in the router error log.)
regards, Doug

What speed do you get if you connect your PC directly to NBN device using the same ethernet cable.
This is just to verify your ethernet cable and PC,

Also if you can check the speed of your PCs network card.

I will check the direct connect speed later, but in the last few days i have had the computer directly connected to the NBN Terminal device, & the speed there was fine with ethernet (seem to remember 21Mb/s).
My feeling is this is router related, but I need to know how I can check further. (I run PCLinuxOS on my computers)

regards, Doug

Maybe it is easier to check the link speed from the router using Luci. The Network->Switch page will show you the negotiated speed for each port.
Screenshot_2018-07-27_08-30-21

100baseT or above should be good.

If your getting 10baseT full-duplex that is going to limit your download speed to MAX of 10Mbps. If you have 10baseT half-duplex that will limit your download speed to MAX of 5Mbps.

Thanks for the responses.
To answer the queries, I was aware of the potential hard connected speeds (was on high speed connection)

Ihave done some more digging, & it seems the issue is related somehow to the time the router has been 'up'. What is weird is that the hard wired speedtest immediately after a router reboot, is really slow: less then 4Mb/s, whereas wireless (NAC) was over 20mb/s. However, if the router is tried after some time (say a day) hardwired, the speed approaches the wireless speed (but is still marginally slower)

I was using SQM, with the download set to 0. When I disabled SQM (rebooted router after!), the speed increased to about 13.98Mb/s (still slower than the Wireless speed).

I will leave the SQM disabled, & check the download speed over the next couple of days to establish a pattern.
(I am wondering if there is a problem in the MT7621 ethernet code). The wireless issues seem to be resolved.

After a few days I might compile a WE1326 snapshot, & see if the same issues are apparent there. (my second router).
regards, Doug (Australia)

Sorry to bring an old topic back from the dead, but I couldn't find any other place mentioning this problem.

I have the same issue, with both of my MT7621A routers (YouHua WR1200JS, ZBT WE1236), when I upgraded them from LEDE 17.01 to 18.06.2 I've noticed approx. 50% throughput drop on Ethernet, wireless is unaffected. I've also enabled Hardware flow offloading on both, things seem more responsive, but throughput is still around 50-55% of what it should be.

My Internet access is 10/100 up/down. I'm smashing 11/107 consistently on speedtest.net on my phone, but barely 10/55 on ethernet on my high-end desktop computer with a 1gbit network card (yes, 1000/1000 is negotiated), using the same test server on speedtest.net back to back. Nobody else is on the network, this is a consistently repeatable controlled test
.
I had great ethernet performance before this upgrade (identical to wireless), anyone knows what happened and how to debug/fix this? I was suspecting a failure with my 1gig powerline adapters, but I hooked up directly to the main router and I'm having the same issue: half the Internet speed I'm supposed to be getting....