zbt-wg3526-16/32M-snapshot compilation is fine but got /etc/preinit error

after installing openwrt-ramips-mt7621-zbt-wg3526-16/32M-squashfs-sysupgrade.bin and reboot ; I got error as below

Starting kernel ...

[    0.000000] Linux version 4.14.37 (root@us32-zbt1-g1) (gcc version 7.3.0 (OpenWrt GCC 7.3.0 r6873-cf7a88c)) #0 SMP Mon May 7 16:54:23 2018
[    0.000000] SoC Type: MediaTek MT7621 ver:1 eco:3
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001992f (MIPS 1004Kc)
[    0.000000] MIPS: machine is ZBT-WG3526 (32M)
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 1c000000 @ 00000000 (usable)
[    0.000000]  memory: 04000000 @ 20000000 (usable)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] VPE topology {2,2} total 4
[    0.000000] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x000000000fffffff]
[    0.000000]   HighMem  [mem 0x0000000010000000-0x0000000023ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x000000001bffffff]
[    0.000000]   node   0: [mem 0x0000000020000000-0x0000000023ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000023ffffff]
[    0.000000] random: get_random_bytes called from start_kernel+0x90/0x4a4 with crng_init=0
[    0.000000] percpu: Embedded 14 pages/cpu @8148f000 s26192 r8192 d22960 u57344
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 130560
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] PID hash table entries: 1024 (order: 0, 4096 bytes)
[    0.000000] Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
[    0.000000] Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Writing ErrCtl register=00000841
[    0.000000] Readback ErrCtl register=00000841
[    0.000000] Memory: 513060K/524288K available (4387K kernel code, 228K rwdata, 976K rodata, 220K init, 268K bss, 11228K reserved, 0K cma-reserved, 262144K highmem)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=4, Nodes=1
[    0.000000] Hierarchical RCU implementation.
[    0.000000] NR_IRQS: 256
[    0.000000] clocksource: GIC: mask: 0xffffffffffffffff max_cycles: 0xcaf478abb4, max_idle_ns: 440795247997 ns
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 4343773742 ns
[    0.000011] sched_clock: 32 bits at 440MHz, resolution 2ns, wraps every 4880645118ns
[    0.007826] Calibrating delay loop... 586.13 BogoMIPS (lpj=2930688)
[    0.073984] pid_max: default: 32768 minimum: 301
[    0.078764] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.085272] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.094110] Hierarchical SRCU implementation.
[    0.099214] smp: Bringing up secondary CPUs ...
[    0.105248] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.105259] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.105273] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.105424] CPU1 revision is: 0001992f (MIPS 1004Kc)
[    0.164003] Synchronize counters for CPU 1: done.
[    0.205714] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.205723] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.205731] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.205807] CPU2 revision is: 0001992f (MIPS 1004Kc)
[    0.255266] Synchronize counters for CPU 2: done.
[    0.286503] Primary instruction cache 32kB, VIPT, 4-way, linesize 32 bytes.
[    0.286511] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.286520] MIPS secondary cache 256kB, 8-way, linesize 32 bytes.
[    0.286599] CPU3 revision is: 0001992f (MIPS 1004Kc)
[    0.340446] Synchronize counters for CPU 3: done.
[    0.370307] smp: Brought up 1 node, 4 CPUs
[    0.377963] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.387755] futex hash table entries: 1024 (order: 3, 32768 bytes)
[    0.394073] pinctrl core: initialized pinctrl subsystem
[    0.399847] NET: Registered protocol family 16
[    0.414989] pull PCIe RST: RALINK_RSTCTRL = 0
[    0.719620] release PCIe RST: RALINK_RSTCTRL = 7000000
[    0.724667] ***** Xtal 40MHz *****
[    0.728024] release PCIe RST: RALINK_RSTCTRL = 7000000
[    0.733121] Port 0 N_FTS = 1b102800
[    0.736588] Port 1 N_FTS = 1b102800
[    0.740035] Port 2 N_FTS = 1b102800
[    1.895067]  -> 21007f2
[    1.897422] PCIE0 enabled
[    1.900027] PCIE1 enabled
[    1.902608] PCIE2 enabled
[    1.905212] PCI host bridge /pcie@1e140000 ranges:
[    1.909969]  MEM 0x0000000060000000..0x000000006fffffff
[    1.915155]   IO 0x000000001e160000..0x000000001e16ffff
[    1.920322] PCI coherence region base: 0x8fc35cf0, mask/settings: 0x60000000
[    1.934988] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    1.940799] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    1.946545] mt7621_gpio 1e000600.gpio: registering 32 gpios
[    1.953367] i2c-mt7621 1e000900.i2c: clock 100KHz, re-start not support
[    1.960374] PCI host bridge to bus 0000:00
[    1.964408] pci_bus 0000:00: root bus resource [mem 0x60000000-0x6fffffff]
[    1.971255] pci_bus 0000:00: root bus resource [io  0xffffffff]
[    1.977092] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    1.983856] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    1.992741] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    2.000672] pci 0000:00:01.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    2.008582] pci 0000:00:02.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    2.018398] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    2.024907] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.031859] pci 0000:00:01.0: BAR 0: no space for [mem size 0x80000000]
[    2.038383] pci 0000:00:01.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.045318] pci 0000:00:02.0: BAR 0: no space for [mem size 0x80000000]
[    2.051869] pci 0000:00:02.0: BAR 0: failed to assign [mem size 0x80000000]
[    2.058797] pci 0000:00:00.0: BAR 8: assigned [mem 0x60000000-0x600fffff]
[    2.065515] pci 0000:00:01.0: BAR 8: assigned [mem 0x60100000-0x601fffff]
[    2.072279] pci 0000:00:01.0: BAR 9: assigned [mem 0x60200000-0x602fffff pref]
[    2.079433] pci 0000:00:02.0: BAR 8: assigned [mem 0x60300000-0x603fffff]
[    2.086190] pci 0000:00:02.0: BAR 9: assigned [mem 0x60400000-0x604fffff pref]
[    2.093341] pci 0000:00:00.0: BAR 1: assigned [mem 0x60500000-0x6050ffff]
[    2.100100] pci 0000:00:01.0: BAR 1: assigned [mem 0x60510000-0x6051ffff]
[    2.106815] pci 0000:00:02.0: BAR 1: assigned [mem 0x60520000-0x6052ffff]
[    2.113584] pci 0000:00:02.0: BAR 7: no space for [io  size 0x1000]
[    2.119777] pci 0000:00:02.0: BAR 7: failed to assign [io  size 0x1000]
[    2.126374] pci 0000:01:00.0: BAR 0: assigned [mem 0x60000000-0x600fffff]
[    2.133087] pci 0000:00:00.0: PCI bridge to [bus 01]
[    2.138025] pci 0000:00:00.0:   bridge window [mem 0x60000000-0x600fffff]
[    2.144754] pci 0000:02:00.0: BAR 0: assigned [mem 0x60100000-0x601fffff 64bit]
[    2.152034] pci 0000:02:00.0: BAR 6: assigned [mem 0x60200000-0x6020ffff pref]
[    2.159177] pci 0000:00:01.0: PCI bridge to [bus 02]
[    2.164121] pci 0000:00:01.0:   bridge window [mem 0x60100000-0x601fffff]
[    2.170839] pci 0000:00:01.0:   bridge window [mem 0x60200000-0x602fffff pref]
[    2.178049] pci 0000:03:00.0: BAR 6: assigned [mem 0x60400000-0x6040ffff pref]
[    2.185179] pci 0000:03:00.0: BAR 5: assigned [mem 0x60300000-0x603001ff]
[    2.191944] pci 0000:03:00.0: BAR 4: no space for [io  size 0x0010]
[    2.198143] pci 0000:03:00.0: BAR 4: failed to assign [io  size 0x0010]
[    2.204729] pci 0000:03:00.0: BAR 0: no space for [io  size 0x0008]
[    2.210927] pci 0000:03:00.0: BAR 0: failed to assign [io  size 0x0008]
[    2.217512] pci 0000:03:00.0: BAR 2: no space for [io  size 0x0008]
[    2.223717] pci 0000:03:00.0: BAR 2: failed to assign [io  size 0x0008]
[    2.230298] pci 0000:03:00.0: BAR 1: no space for [io  size 0x0004]
[    2.236499] pci 0000:03:00.0: BAR 1: failed to assign [io  size 0x0004]
[    2.243085] pci 0000:03:00.0: BAR 3: no space for [io  size 0x0004]
[    2.249291] pci 0000:03:00.0: BAR 3: failed to assign [io  size 0x0004]
[    2.255878] pci 0000:00:02.0: PCI bridge to [bus 03]
[    2.260783] pci 0000:00:02.0:   bridge window [mem 0x60300000-0x603fffff]
[    2.267539] pci 0000:00:02.0:   bridge window [mem 0x60400000-0x604fffff pref]
[    2.275982] clocksource: Switched to clocksource GIC
[    2.282403] NET: Registered protocol family 2
[    2.287383] TCP established hash table entries: 2048 (order: 1, 8192 bytes)
[    2.294268] TCP bind hash table entries: 2048 (order: 2, 16384 bytes)
[    2.300731] TCP: Hash tables configured (established 2048 bind 2048)
[    2.307145] UDP hash table entries: 256 (order: 1, 8192 bytes)
[    2.312912] UDP-Lite hash table entries: 256 (order: 1, 8192 bytes)
[    2.319397] NET: Registered protocol family 1
[    2.555928] 4 CPUs re-calibrate udelay(lpj = 2924544)
[    2.562184] Crashlog allocated RAM at address 0x3f00000
[    2.567565] workingset: timestamp_bits=30 max_order=17 bucket_order=0
[    2.579976] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    2.585720] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    2.598493] random: fast init done
[    2.602185] bounce: pool size: 64 pages
[    2.606010] io scheduler noop registered
[    2.609835] io scheduler deadline registered (default)
[    2.616101] Serial: 8250/16550 driver, 3 ports, IRQ sharing disabled
[    2.623509] console [ttyS0] disabled
[    2.627224] 1e000c00.uartlite: ttyS0 at MMIO 0x1e000c00 (irq = 18, base_baud = 3125000) is a 16550A
[    2.636206] console [ttyS0] enabled
[    2.636206] console [ttyS0] enabled
[    2.643059] bootconsole [early0] disabled
[    2.643059] bootconsole [early0] disabled
[    2.651625] cacheinfo: Failed to find cpu0 device node
[    2.656805] cacheinfo: Unable to detect cache hierarchy for CPU 0
[    2.663539] MediaTek Nand driver init, version v2.1 Fix AHB virt2phys error
[    2.670983] spi-mt7621 1e000b00.spi: sys_freq: 50000000
[    2.686198] m25p80 spi0.0: w25q256 (32768 Kbytes)
[    2.690945] 4 fixed-partitions partitions found on MTD device spi0.0
[    2.697312] Creating 4 MTD partitions on "spi0.0":
[    2.702091] 0x000000000000-0x000000030000 : "u-boot"
[    2.708082] 0x000000030000-0x000000040000 : "u-boot-env"
[    2.714241] 0x000000040000-0x000000050000 : "factory"
[    2.720209] 0x000000050000-0x000002000000 : "firmware"
[    2.795140] 2 uimage-fw partitions found on MTD device firmware
[    2.801099] 0x000000050000-0x000000214d8c : "kernel"
[    2.807056] 0x000000214d8c-0x000002000000 : "rootfs"
[    2.812814] mtd: device 5 (rootfs) set to be root filesystem
[    2.818576] 1 squashfs-split partitions found on MTD device rootfs
[    2.824739] 0x000000450000-0x000002000000 : "rootfs_data"
[    2.831674] libphy: Fixed MDIO Bus: probed
[    2.907979] libphy: mdio: probed
[    4.310780] mtk_soc_eth 1e100000.ethernet: loaded mt7530 driver
[    4.317402] mtk_soc_eth 1e100000.ethernet eth0: mediatek frame engine at 0xbe100000, irq 21
[    4.327818] NET: Registered protocol family 10
[    4.333862] Segment Routing with IPv6
[    4.337650] NET: Registered protocol family 17
[    4.342125] 8021q: 802.1Q VLAN Support v1.8
[    4.348825] hctosys: unable to open rtc device (rtc0)
[    4.360084] VFS: Mounted root (squashfs filesystem) readonly on device 31:5.
[    4.367663] Freeing unused kernel memory: 220K
[    4.372101] This architecture does not have kernel memory protection.
[    4.624236] random: crng init done
[    4.916842] init: Console is alive
[    4.920492] init: - watchdog -
[    5.859285] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    5.970351] usbcore: registered new interface driver usbfs
[    5.976012] usbcore: registered new interface driver hub
[    5.981489] usbcore: registered new device driver usb
[    5.995135] SCSI subsystem initialized
[    6.013770] bus=0x3, slot = 0x2, irq=0x0
[    6.017845] PCI: Enabling device 0000:00:02.0 (0004 -> 0006)
[    6.023622] ahci 0000:03:00.0: SSS flag set, parallel bus scan disabled
[    6.030347] ahci 0000:03:00.0: AHCI 0001.0200 32 slots 2 ports 6 Gbps 0x3 impl IDE mode
[    6.038341] ahci 0000:03:00.0: flags: 64bit ncq sntf stag led clo pmp pio slum part ccc sxs 
[    6.048809] scsi host0: ahci
[    6.052276] scsi host1: ahci
[    6.055434] ata1: SATA max UDMA/133 abar m512@0x60300000 port 0x60300100 irq 25
[    6.062793] ata2: SATA max UDMA/133 abar m512@0x60300000 port 0x60300180 irq 25
[    6.405995] ata1: SATA link down (SStatus 0 SControl 300)
[    6.745974] ata2: SATA link down (SStatus 0 SControl 300)
[    6.759758] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    6.765101] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 1
[    6.776148] xhci-mtk 1e1c0000.xhci: hcc params 0x01401198 hci version 0x96 quirks 0x00210010
[    6.784644] xhci-mtk 1e1c0000.xhci: irq 20, io mem 0x1e1c0000
[    6.791443] hub 1-0:1.0: USB hub found
[    6.795267] hub 1-0:1.0: 2 ports detected
[    6.799898] xhci-mtk 1e1c0000.xhci: xHCI Host Controller
[    6.805211] xhci-mtk 1e1c0000.xhci: new USB bus registered, assigned bus number 2
[    6.812911] usb usb2: We don't know the algorithms for LPM for this host, disabling LPM.
[    6.821878] hub 2-0:1.0: USB hub found
[    6.825697] hub 2-0:1.0: 1 port detected
[    6.838892] MTK MSDC device init.
[    6.896198] mtk-sd: MediaTek MT6575 MSDC Driver
[    6.903903] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    6.916354] init: - preinit -
[    7.408544] usb 1-2: new high-speed USB device number 2 using xhci-mtk
/etc/preinit: line 734: awk: not found
/etc/preinit: line 1: mkdir: not found
/etc/preinit: line 1: strings: not found
/etc/preinit: line 1: head: not found
/etc/preinit: line 1: can't create /tmp/sysinfo/board_name: nonexistent directory
/etc/preinit: line 1: cat: not found
/etc/preinit: line 1: can't create /tmp/sysinfo/model: nonexistent directory
/etc/preinit: line 1: cat: not found
/etc/preinit: line 1: egrep: not found
/etc/preinit: line 1: grep: not [    7.579043] urandom-seed: Seed file not found (/etc/urandom.seed)
found
/etc/preinit: line 1: grep: not found
/etc/preinit: line 1: grep: not found
/etc/preinit: line 1: grep:[    7.595200] procd: - early -
 not found
/etc[    7.598932] procd: - watchdog -
/preinit: line 1: mktemp: not found
/etc/preinit: line 1: mktemp: not found
/etc/preinit: line 1: mktemp: not found
/etc/preinit: line 1: touch: not found
/etc/preinit: line 1: touch: not found
/etc/preinit: line 1: touch: not found
/etc/preinit: line 1: lock: not found
Press the [f] key and hit [enter] to enter failsafe mode
Press the [1], [2], [3] or [4] key and hit [enter] to select the debug level
/etc/preinit: line 1: lock: not found
/etc/preinit: line 1: sleep: not found
/etc/preinit: line 1: sleep: not found
/etc/preinit: line 1: lock: not found
/etc/preinit: line 1: cat: not found/etc/preinit: line 1: rm: not found
/etc/preinit: line 1: rm: not found
/etc/preinit: line 1: rm: not found
/etc/preinit: line 1: rm: not found
/etc/preinit: line 1: grep: not found
/etc/preinit: line 1: mount_root: not found
/etc/preinit: line 1: uci: not found
/etc/preinit: line 1: grep: not found
[    8.306121] procd: - watchdog -
[    8.309569] procd: - ubus -
[    8.368210] procd: - init -
Please press Enter to activate this console.
[    8.575002] mtk_soc_eth 1e100000.ethernet eth0: port 3 link up
[    8.644542] kmodloader: loading kernel modules from /etc/modules.d/*
[    8.654854] ip6_tables: (C) 2000-2006 Netfilter Core Team
[    8.983040] Loading modules backported from Linux version wt-2017-11-01-0-gfe248fc2c180
[    8.991059] Backport generated by backports.git v4.14-rc2-1-31-g86cf0e5d
[    8.999727] ip_tables: (C) 2000-2006 Netfilter Core Team
[    9.381198] nf_conntrack version 0.5.0 (8192 buckets, 32768 max)
[    9.613021] xt_time: kernel timezone is -0000
[    9.923928] bus=0x1, slot = 0x0, irq=0xff
[    9.928025] PCI: Enabling device 0000:00:00.0 (0004 -> 0006)
[    9.933823] mt7603e 0000:01:00.0: ASIC revision: 76030010
[    9.942754] mt7603e 0000:01:00.0: Firmware Version: ap_pcie
[    9.948378] mt7603e 0000:01:00.0: Build Time: 20160107100755
[    9.985993] firmware init done
[   10.174445] bus=0x2, slot = 0x1, irq=0xff
[   10.178559] PCI: Enabling device 0000:00:01.0 (0004 -> 0006)
[   10.184443] mt76x2e 0000:02:00.0: ASIC revision: 76120044
[   10.216598] mt76x2e 0000:02:00.0: ROM patch build: 20141115060606a
[   10.226403] mt76x2e 0000:02:00.0: Firmware Version: 0.0.00
[   10.231884] mt76x2e 0000:02:00.0: Build: 1
[   10.236026] mt76x2e 0000:02:00.0: Build Time: 201507311614____
[   10.256026] mt76x2e 0000:02:00.0: Firmware running!
[   10.271711] PPP generic driver version 2.4.2
[   10.277653] NET: Registered protocol family 24
[   10.285491] kmodloader: done loading kernel modules from /etc/modules.d/*



BusyBox v1.28.3 () built-in shell (ash)

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 %D %V, %C
 -----------------------------------------------------
/bin/ash: grep: not found
/bin/ash: cut: not found
/bin/ash: grep: not found
root@(none):/#

Looks like something is wrong with $PATH or busybox itself?

@Borromini , Can be more specified ?

Hi,
I am not sure if I have exactly the same problem, but I compiled 18'06 tonight, & when I try to install get this message:
The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

I tried on 2 days to compile, & both times same error.

The file compiled was called:
openwrt-ramips-mt7621-zbt-wg3526-16M-squashfs-sysupgrade.bin

What am I doing wrong please?

regards, Doug

Thanks for the reply. I am not sure what else I can say.
I compiled a few days using the 18.06 source. I used the generic selections, except for the MT7621 & WG3526 16M selection, plus Luci. The compilation came up to 5M. As I said there were no errors reported during compile. When I tried to upgrade (using LUCi) I received the error message
"The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform."

I received my WG3526 with 14.07 (from memory) on it, which I updated with the
http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-zbt-we1326-squashfs-sysupgrade.bin
This updated fine.

What other info can I give?

I think I may have found the problem but I do not know how to fix it.

When I upgraded from the old Owrt originally installed, I used the Snapshot image from the device page:

http://downloads.lede-project.org/releases/17.01.4/targets/ramips/mt7621/lede-17.01.4-ramips-mt7621-zbt-wg3526-squashfs-sysupgrade.bin

When I checked the information once loaded I found:

root@OpenWrt:~# cat /etc/os-release
NAME="OpenWrt"
VERSION="SNAPSHOT"
ID="openwrt"
ID_LIKE="lede openwrt"
PRETTY_NAME="OpenWrt SNAPSHOT"
VERSION_ID="snapshot"
HOME_URL="%u"
BUG_URL="http://bugs.openwrt.org/"
SUPPORT_URL="http://forum.openwrt.org/"
BUILD_ID="r7452-7e82418"
LEDE_BOARD="ramips/mt7621"
LEDE_ARCH="mipsel_24kc"
LEDE_TAINTS=""
LEDE_DEVICE_MANUFACTURER="OpenWrt"
LEDE_DEVICE_MANUFACTURER_URL="http://openwrt.org/"
LEDE_DEVICE_PRODUCT="Generic"
LEDE_DEVICE_REVISION="v0"
LEDE_RELEASE="OpenWrt SNAPSHOT r7452-7e82418"

So, it seems I have loaded a generic version of the upgrade, so now the device details do not match, hence the error message.

Can someone advise me how this can be resolved? (My device is wg-2526 16M)

Thanks, Doug

Seems like you flashed WG3526 on WG2526.

THanks. System working now. ssh forced upgrade.

The system is WG3526. Unsure exactly what happened.

btw, I found an easy way to copy the .bin file across. I used ssh & Midnight Commander.

Note: Using Midnight Commander (mc) & ssh to copy files to the router from the system used for compilation:
-Open a terminal & start mc.
-ctl O to other window, & log in to router with ssh (ssh root@192.168.1.1, return, then enter password)
-Ctl O back to MC.
-Click on Right, then Shell link. It will show root@191.168.1.1. Click OK, then enter the password.

Then you can use normal MC file copy to copy the .bin file to /tmp.

(Feel free to verify this, & use the text in the documentation. In my opinion it is an easy way to transfer files to the router). PCLinuOS does not have scp in the repository, so needed another option.

regards, Doug

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.