ZBT WE3526 Soft Bricks Everytime (256MB RAM Variant) Solved

Back when it was 12/23/2019 a snapshot build of this router would work but the stable release (18.06.04) wouldn't. The snapshot around 10/10/2019 also worked as well (OpenWrt SNAPSHOT r11189-33dd522f24).

Today I was trying to upgrade and I learned that the current snapshots build don't work at all for me. It used to be that the snapshot version worked but the stable version doesn't. It is like this guy's thread OpenWrt Stable not booting for ZBT WE3526

However as of 4/26/2020 the snapshot build doesn't work anymore.

I've tried 18.06.8 stable, 19.07.1 and 19.07.2 for ramips-mt7621-zbtlink_zbt-we3526-squashfs-sysupgrade.bin today and they didn't work. To unbrick, I would have to flash one of the snapshots I saved such as OpenWrt SNAPSHOT r11189-33dd522f24 but with these old snapshots I can't do an opkg update...

What can I do?

Is it because ZBT recently changed the amount of ram for the WE3526? I have the 256MB version. Which is slightly different from https://openwrt.org/toh/hwdata/zbt/zbt_we3526

Any help is appreciated. Currently I'm trying to build the image myself from the stable branch following https://openwrt.org/docs/guide-developer/quickstart-build-images but I'm not sure if this will solve my problem. Some guidance to customize the build for 256MB ram is appreciated as well.

Edit 1: Maybe if I edit the reg = line in /openwrt/target/linux/ramips/dts/ZBT-WE3526.dts like shown in this commit things may work. I will update after testing a compiled image.

try to load the upgrade image from bootloader

My suspicions about the image not working for the 256MB variant is confirmed.

Building the image myself worked! Using commit for reference... Here's what I did

I changed /openwrt/target/linux/ramips/dts/ZBT-WE3526.dts

line #14 from

reg = <0x0 0x1c000000>, <0x20000000 0x4000000>;


reg = <0x0 0x10000000>;

Then proceed with make menuconfig


After that it works!

When I tried building the image with reg = <0x0 0x1c000000>, <0x20000000 0x4000000>; and testing the image I would get stuck in the soft brick as I described initially!

Final Question
How do I report this? So that it can get fixed for 256MB Variant? I'm pretty sure there are folks out that having trouble flashing their 256MB versions of the WE3526.... Update: Question Answered

1 Like

See https://openwrt.org/bugs

1 Like

@tmomas thanks

For those who want the current stable release built image for the WE3526 256M variant it is here: https://github.com/StarWhiz/WE3526-OpenWrt-19-07-02-256MVariant

1 Like

Update: I submitted a bug report at https://bugs.openwrt.org/index.php?do=details&task_id=3053&order=dateopened&sort=desc&fbclid=IwAR0ndM4gq_wR77IwEuQa5b6yKD42wGiBhBx5_bydoU77gjyMVOltyrnRmLw

Update 2: 981213 made a commit that fixes this in https://git.openwrt.org/1e0bbd0ce766d5

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.