ZBT WE1226 OpenWrt firmware on ZBT WE1688, soft brick

Howdy folks,

I posted just over a month ago I posted about flashing OpenWRT to my ZBT-WE1226, which worked quite well. Forum link here: ZBT WE1226 - Unable to Flash OpenWrt via OEM firmware

I wanted to grab another, and unfortunately the unit I purchased last time was out of stock with my vendor, but I found an alternative on the same SOC. I thought that sticking to the same SOC (MT7628NN) should be a fairly solid choice, and I found a router that has a slightly more desirable style, at a better price.

Details on the unit here: https://www.youtube.com/watch?v=SqMmPw3zhMY

The process for updating the firmware seems to be identical - hold the reset button, connect power, navigate to 192.168.1.1 (set static IP on PC beforehand of course). I am greeted, and am still greeted by a MT76x8 Firmware Update page, but after updating the firmware, I am no longer able to get my router to respond. I tried a factory reset and multiple browsers, and the device just stops responding about a second after I ask it to update the firmware. All I can access is this firmware update page.

I have a second ZBT WE1688 on stock firmware, but am now scared to try that one. What would be next step in getting this device running on OpenWRT? Any guidance would be greatly appreciated :slight_smile:

Without bootlogs nobody can help you.
Start https://openwrt.org/docs/guide-developer/add.new.device

Thanks - too busy myself to do something like that right now, the virus means I am working 24/7, gonna just buy something else for now but will hang onto it. Might ask the Aliexpress vendor for the stock firmware. Might use the other one as a Wi-Fi access point. If anyone has this hardware and wants some specific information that isn't too complicated to gather, please let me know.

Can you test this image?


Unpack and flash from recovery mode.

Thank you - I will give it a try when I get a spare moment and report back. Thankfully it's quite easy and seemingly safe to flash with the dedicated flash UI...!

Quick update - sadly this firmware is no different. After uploading, the device immediately stops responding to ping and never seems to load anything.

Any idea where I can at least get a stock firmware for this router? Is it possible to dump one from my other router?

Still have a bricked device :frowning: oh well...

For all those looking for a solution to this: I successfully updated ZBT WE1688 using the following firmware:

https://archive.openwrt.org/releases/17.01.7/targets/ramips/mt7628/lede-17.01.7-ramips-mt7628-mt7628-squashfs-sysupgrade.bin

Not the latest OpenWRT/LEDE but at least it works, unlike versions 18.06 and 19.07.

To update follow the instructions in the first post of this thread by @stephendt

Cheers!!!

1 Like

I'm pleased to announce that the suggestion that @jeperez offered works a treat! It's a shame that we have to stick to this older version though, but I planned to just use this as a Wi-Fi bridge so I'm not particularily upset.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.