ZBT-WE1026-5G with 32M flash

I have a no name router with the ZBT-WE1026-5G V05 inscription on the board. It has 32M flash ROM. I want to make a firmware for it with a fresh OpenWRT.

But there is only Zbtlink ZBT-WE1026-5G 16M target system. With 32M is Zbtlink ZBT-WE1026-H 32M and Zbtlink ZBT-WE826 32M.
I have the ZBT-WE826 router too. This board is not very similar to the WE1026-5G board.

Is it possible to reasonably assume which target system to choose? What is a WE1026-H?

If it is the same hardware as this one which has 16M you can try this version

Previously back up the original partitions

i have found this:

How to back up the original partitions in Lede 17.01?

cat /proc/mtd

cat /dev/mtd0 > mtd0.bin
cat /dev/mtd1 > mtd1.bin
cat /dev/mtd2 > mtd2.bin
cat /dev/mtd3 > mtd3.bin
cat /dev/mtd4 > mtd4.bin
cat /dev/mtd5 > mtd5.bin
cat /dev/mtd6 > mtd6.bin
cat /dev/mtd7 > mtd7.bin
cat /dev/mtd8 > mtd8.bin
cat /dev/mtd9 > mtd9.bin
cat /dev/mtd10 > mtd10.bin
cat /dev/mtd11 > mtd11.bin
cat /dev/mtd12 > mtd12.bin
cat /dev/mtd13 > mtd13.bin

After recover mtd files in your computer with SCP or

There are seven partitions: from mtd0 to mtd6.

How to restore them later?

It's not a problem. I copied the partitions to a USB flash drive :slight_smile:

How to write these partitions back to the router? Build a firmware from them? How?

I indicated above where is the firmware in 32M which is available

for restore use luci or ltd write or use mtd write mtd0xxx ( the firmware ) firmware

mtd.xxx matches what you found with cat /proc/mtd

After studying the information, my question sounds like this:

How do I build firmware based on Zbtlink ZBT-WE1026-5G 16M target, but for 32M ROM?

I tried the following firmware:
Only the last one worked. The others result in a cyclical reboot.

And another bad news: modern browsers do not work with the flashing procedure web interface (by power on with pressed reset button). Only the olds. I do not know why.

So how do you still make 32M firmware from 16M?

for 32M firmware requiert to build firmware with sources

modified dts file

&firmware {
reg = <0x50000 0xfb0000>;
&firmware {
reg = <0x50000 0x1fb0000>;

mt7620.mk with add part for 32M

new image size
IMAGE_SIZE := 32448k

possible some others

Thanks, I already.

I added to target/linux/ramips/image/mt7620.mk

define Device/zbtlink_zbt-we1026-5g-32m
  SOC := mt7620a
  IMAGE_SIZE := 32448k
  DEVICE_VENDOR := Zbtlink
  DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci kmod-sdhci-mt7620
  SUPPORTED_DEVICES += we1026-5g-32m zbtlink,we1026-5g-32m
TARGET_DEVICES += zbtlink_zbt-we1026-5g-32m

and to target/linux/ramips/dts/ file mt7620a_zbtlink_zbt-we1026-5g-32m.dts

// SPDX-License-Identifier: GPL-2.0-or-later OR MIT

#include "mt7620a_zbtlink_zbt-we1026-5g.dtsi"

/ {
	compatible = "zbtlink,zbt-we1026-5g-32m", "zbtlink,zbt-we1026-5g",
		"zbtlink,zbt-we1026", "ralink,mt7620a-soc";
	model = "Zbtlink ZBT-WE1026-5G (32M)";

&firmware {
	reg = <0x50000 0x1fb0000>;

just a copy of mt7620a_zbtlink_zbt-we1026-5g-16m.dts with
reg = <0x50000 0x1fb0000>;
instead reg = <0x50000 0xfb0000>;

After that I build firmware with this profile from make defconfig + LuCI.
The firmware is not working properly: the LAN light does not light up, and there is no connection to the router via LAN cable.
But this zbtlink_zbt-we1026-5g-16m-squashfs-sysupgrade.bin firmware work.

Do I need to specifically configure the LAN when creating the firmware?

Look in:



		label_mac=$(mtd_get_mac_binary factory 0x4)


		ucidef_add_switch "switch0" \
			"0:lan" "6t@eth0"

exist also iin target/linux/ramips/mt7620/base-files/etc/board.d/01_leds


	ucidef_set_led_netdev "lan" "LAN" "green:lan" "eth0"
	ucidef_set_led_netdev "wifi_led" "wifi" "green:wifi" "wlan0"

You cna found files & text with this

find ./ -type f -exec grep -H 'zbt-we1026-5g-16m' {} \;
find ./ -name  'zbt-we1026-5g-16m.*'

I don't have my build machine at home right now, I just had a quick look in github

Probably touch target/linux/*/Makefile is necessary...

So, I have the minimum working firmware from "Zbtlink ZBT-WE1026-5G (32M)" target.

It remains to enabled removable storages and make the modem work...

Something strange...
I removed dropbear and added openssh to firmware.

But I have 'Permission denied' when connecting by ssh. But, like, there shouldn't be a password?
Ok, I set password via LuCI. Same thing.

How to configure openssh in firmware?

DropBear is good enough for me and so, sorry, i have no experience with OpenSSH

Your old post !!!


Tested with this nfos:

No problem with WinSCP & sftp

my sshd_config

Port 22
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
PermitRootLogin yes
AuthorizedKeysFile      .ssh/authorized_keys
Subsystem       sftp    /usr/lib/sftp-serve

Well, I've forgotten a lot of things in life. :frowning:

Covid or old age ?
I am 76 years old !!!

60 a month ago :slight_smile:

The wi-fi is configured incorrectly.
Only target/linux/ramips/dts/mt7620a_zbtlink_zbt-we1026-5g.dtsi has something about wi-fi. No other zbtlink_zbt-we files contain anything about wi-fi.

How to troubleshoot wi-fi?