Youku YK1 messed up

I have a Youku YK1 router which had what looked like a stock OpenWRT firmware come pre-installed. I decided to upgrade to the latest 19.07.7 and downloaded the one from the OpenWRT website specifically for this router. I went into LUCI and selected the sysupgrade.bin and clicked on apply. After the upload finished the router bricked.

So doing what every man his worth does RTFM ABI (after breaking it) I realized I needed to do the firmware upgrade via the built-in firmware upgrader. So I tried again but this time using the built-in firmware upgrader and everything seems to upload fine but after that the router just hangs.

Knowing I could at least get access to the built-in firmware upgrader after resetting the router each time I proceeded to download all the different firmwares and kernels I could and see if anyone of them would work. All of them bricked the device except the latest 21.02.0-rc2 Kernel which booted up fine and all functionality worked. However I found I could not save my settings after each reboot. Even if I edited the files manually with UCI or VI none of my edits would be saved after the reboot.

Any help would be appreciated. Despite being a dinky-little-router it is reasonably specced out and has worked well for me for the last 6-months when I didn't try to upgrade to the latest firmware. Would like to avoid purchasing a new one for now.

Make sure to upload the sysupgrade image to BREED bootloader HTTP upgrade interface, that should work. Do not flash initramfs image, that will have you end loosing all changes after every reboot.

still doesn't save. I made double sure I uploaded the openwrt-21.02.0-rc2-ramips-mt7620-youku_yk1-squashfs-sysupgrade using the BREED gui but still doesn't save settings. You think the router is kaput or you think bug with the firmware and I just wait for the next candidate release? This 21.02.0-rc2 is the only stock firmware that will boot on the YOUKU YK1 so not sure where to look right now.

You probably encountered this Youku YK1 OpenWrt 18.06.4 Bad Magic

Try flashing a really old openwrt release, and if it works, upgrade the device to the most current version.

To be able to research (and hopefully solve) the issue further, you'd need serial console access.
Not sure if it's worth it for a 15€/20$ device though.

keeping with openwrt-21.02.0-rc2 I found that using LUCI over HTTPS it was able to save my settings. If over HTTP then none of the settings were saved. Then... after I saved the root password in LUCI under HTTPS which was successful then trying to login using HTTP it could not accept the password and just rejected the login attempt. Previously with HTTP failing to save my settings and installing the kernel which doesn't save settings I compounded the two issues into one and thought they were the same. No biggie as I can use HTTPS to access LUCI. However...a new problem has cropped up...

After creating a PPPoE interface it fails to completely connect on bootup. It does connect and I can see it obtains an IP address but ping to fails. So I must go into LUCI and restart the PPPoE interface which then allows successful ping to and I get a normal connection. Any ideas?

I flashed Gargoyle onto this router just to see the results and Gargoyle gave me the following message when loading the GUI. Could shed some light on the issues I have been having with OpenWRT.

Router storage full (read only) or is mounted in volatile storage (RAM). It will not function correctly, or will revert to a previous state after rebooting. Restore default configuration or flash new firmware (without preserving settings).

I think I have had it with this router. I enjoy fixing things but time to move on I think. Maybe I will give it one more go with Bad Magic and then call it a day.

haven't worked with PPPoE in the past, but if it runs as a service, put a

sleep 5 
/etc/init.d/pppoe restart
/etc/init.d/network restart ( <- might work as an alternative)

in your local startup script.

if it's an interface, put

sleep 5
ipdown <pppeointerface>; ifup <pppeointerface>

in the same place.

Hopefully it'll solve your startup issue.

After having flashed with Gargoyle and then re-flashing back to the only firmware I knew which allowed me to save settings 21.02.0-rc2 sysupgrade.bin now this firmware has the same issue that I cannot save settings anymore and lose all settings after reboot. Now as I stand none of the firmware is able to save settings. I think this thing is dying a slow death. Now looking to replace with a router that is OpenWRT friendly.

Thanks for help...

Figured it out finally. Anyone else with this router and has similar issues be informed:

  1. Flash the stock firmware for the Youku Yk1 using the built-in BREED bootloader (hold button down power on then Use chrome to translate chinese menu options).

  2. After flashing is complete the router will power off (reboot seems to not work).

  3. Hard reset (pull out power jack and insert it again).

  4. Router will boot up and power LED will blink. Within about 60 secs LUCI will be up and running. Do nothing in LUCI at this point! If you login into LUCI now weird stuff happens.

  5. Wait for power LED to go solid i.e. stop blinking. This can take about 10-30 mins to complete. Go on a carribbean vacation for a couple weeks and leave the router running. Again do nothing while the power LED is blinking.

  6. When the power LED turns solid then and LUCI should be working correctly.


and finally add to /etc/rc.local:

sleep 10 && ifdown ; ifup

Thanks for the tip. All good now !!!

1 Like

finally...the reason I couldn't enter passwords in LUCI was because of Firefox. For some reason LUCI with HTTP and Firefox don't get along. Chrome HTTP and Chrome HTTPS and LUCI are fine as for Firefox HTTPS and LUCI. Just Firefox HTTP LUCI doesn't work.

Are you sure it is bricked?

Try to power off, and on.

Can you reboot it by command 'reboot' in command line?

All fixed now thanks. I needed to wait until the power LED turned solid (stop flashing).
The first time I flashed new firmware via LUCI the device bricked. After I flashed using BREED initially it took a long time to bring up the system (long time meaning 15-30 mins). The strange thing is that you can access LUCI when the power LED is still flashing and during this time any changes to settings you make in LUCI is lost. The key is to wait until the power LED turns solid. Subsequent boots are much quicker and boot times are normal again (usually less than a minute) and any settings you make in LUCI become permanent again. The other issue I had was using Firefox which doesn't work well with LUCI (unable to log into LUCI over HTTP).

As noted previously there are two issues with this router with stock openWRT firmware. The first is that the reboot command powers-off the router meaning you need to hard reset (pull power cable) and also PPPoE fails on boot and you need to add the commands "sleep 10 && ifdown [nameofPPPoEinterface]; ifup [nameofPPPoEinterface]" to the rc.local section.

A couple things I messed around with this router that may or may not have had any impact. BREED has a menu option to select your firmware such as DDWRT, OpenWRT, ASUS etc and perform an erase (erasing what I don't know because I could still boot the router after the erase operation). I selected OpenWRT and clicked on erase not knowing what it was erasing but at this point I was desperate. Secondly I flashed a Stable 20.01 kernel bin to the address 0xA00... then flashed its corresponding sysupgrade bin to the address 0x500... I hard reset the router and the router was blinking forever. I could access LUCI but no settings were being saved. I thought I had corrupted some part of the memory so just walked away thinking router is kaput. When I came back after a few hours I noticed the LED turned solid and everything working normally.

Can you reboot it by command 'reboot' in command line from this 'stable' state?

either clicking REBOOT in LUCI or typing in reboot in SSH console the result is the same. The power LED turns off and then nada. I need to walk over to the router and hard reset (pull the power cable). The WAN LED does remain on and solid all the time (no blinking). I am using a PPPoE connection bridged to WAN and WAN6. I waited at least 10 minutes for the router to reboot but did not see the power light come back on. Either openWRT gets stuck in a loop or hangs completely before or on bringing down the WAN interface.

1 Like

Thank you, exactly the same behavior.

Also everyone should note the following commit;a=commit;h=4a9f389ed2dcee18a5c5e1f0d4e5c406f9290579

defined flash space that doesn't actually exist could be cause for this 15-30 minutes flash time

you're welcome to test public SNAPSHOT images of master in the next 24 hours (the current images do not have this commit, so waiting for the next build)

that's assuming you have a way to recover, if something else were to go wrong

I just tested WPA3 and it doesn't work on this router. If you enable WPA3 the wireless LED will not turn on after boot and there is no radio signal. I need to connect back to router with LAN cable and turn back on WPA2 to gain back wireless functionality.

in 19.07, WPA3 requires extra packages