Hi.
Firstly. thanks for all the help I have gathered from here before signing up. I have a WE826-T2 32Mb and a EE sim
I have managed to flash Rooter onto the device, I have setup WiFi & I can get connected to a cell (I see SMS messages in Rooter) The sim has data available (tested in phone) but I have no internet on the WE826.
I have attached the config (got the commands from someone elses post )
****************************************
root@ROOter:~# ubus call system board
****************************************
"kernel": "5.4.158",
"hostname": "ROOter",
"system": "MediaTek MT7620A ver:2 eco:6",
"model": "Zbtlink ZBT-WE826 (32M)",
"board_name": "zbtlink,zbt-we826-32m",
"release": {
"distribution": "OpenWrt",
"version": "21.02-SNAPSHOT",
"revision": " ",
"codename": "",
"target": "ramips/mt7620",
"description": "GoldenOrb_2023-07-27 ( OpenWrt 21.02-SNAPSHOT )"
****************************************
root@ROOter:~# cat /etc/config/network
****************************************
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fda0:8032:b000::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'eth0.1'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname ' tap0 tap-server'
config device
option name 'eth0.2'
option macaddr 'f8:5e:3c:59:67:83'
config interface 'wan'
option device 'eth0.2'
option proto 'dhcp'
option metric '1'
config interface 'wan6'
option device 'eth0.2'
option proto 'dhcpv6'
config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0 1 2 3 6t'
config switch_vlan
option device 'switch0'
option vlan '2'
option ports '4 6t'
config interface 'VPN'
option proto 'none'
option auto '0'
option device 'tun0'
config interface 'VPNS'
option proto 'none'
option auto '0'
option device 'tun-server'
config interface 'TAP'
option proto 'none'
option auto '1'
option device 'tap0'
config interface 'TAPS'
option proto 'none'
option auto '0'
option device 'tap-server'
config interface 'wwan2'
option proto 'dhcp'
option metric '2'
config interface 'wwan26'
option proto 'dhcpv6'
option metric '2'
config interface 'wwan5'
option proto 'dhcp'
option metric '2'
config interface 'wwan56'
option proto 'dhcpv6'
option metric '2'
config interface 'wan2'
option proto 'dhcp'
option metric '20'
option device 'wan2'
config interface 'wg0'
option proto 'wireguard'
option auto '0'
list addresses ''
config interface 'wg1'
option proto 'wireguard'
option auto '0'
list addresses ''
config interface 'wan1'
option proto 'qmi'
option device '/dev/cdc-wdm0'
option metric '10'
option currmodem '1'
****************************************
root@ROOter:~# cat /etc/config/wireless
****************************************
config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/10180000.wmac'
option htmode 'HT20'
option disabled '0'
option noscan '1'
option country 'US'
option txpower '20'
option phy 'phy0'
option channel 'auto'
option cell_density '0'
config wifi-iface 'default_radio0'
option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option ssid 'Valentine'
option key 'weird12345'
config wifi-iface 'wwan2'
option device 'radio0'
option network 'wwan2'
option mode 'sta'
option ssid 'Hotspot Manager Interface'
option encryption 'none'
option disabled '1'
config wifi-iface 'wwan5'
option device 'radio0'
option network 'wwan5'
option mode 'sta'
option ssid 'Hotspot Manager Interface'
option encryption 'none'
option disabled '1'
****************************************
root@ROOter:~# cat /etc/config/dhcp
****************************************
config dnsmasq
option domainneeded '1'
option boguspriv '1'
option filterwin2k '0'
option localise_queries '1'
option rebind_protection '0'
option rebind_localhost '1'
option local '/lan/'
option domain 'lan'
option expandhosts '1'
option nonegcache '0'
option authoritative '1'
option readethers '1'
option leasefile '/tmp/dhcp.leases'
option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
option nonwildcard '1'
option localservice '1'
option ednspacket_max '1232'
option cachesize '150000'
config dhcp 'lan'
option interface 'lan'
option start '100'
option limit '150'
option leasetime '12h'
option dhcpv4 'server'
option dhcpv6 'server'
option ra 'server'
option ra_slaac '1'
list ra_flags 'managed-config'
list ra_flags 'other-config'
config dhcp 'wan'
option interface 'wan'
option ignore '1'
config odhcpd 'odhcpd'
option maindhcp '0'
option leasefile '/tmp/hosts/odhcpd'
option leasetrigger '/usr/sbin/odhcpd-update'
option loglevel '4'
config dhcp 'wan1'
option interface 'wan1'
option ignore '1'
list ra_flags 'none'
****************************************
root@ROOter:~# cat /etc/config/firewall
****************************************
config defaults
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option synflood_protect '1'
config zone
option name 'lan'
list network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
config zone
option name 'wan'
option output 'ACCEPT'
option masq '1'
option mtu_fix '1'
list network 'wan'
list network 'wan1'
list network 'wan2'
list network 'wan6'
list network 'wwan2'
list network 'wwan5'
option input 'ACCEPT'
option forward 'ACCEPT'
list device 'br-lan'
list device 'wwan0'
list device 'wlan0'
config forwarding
option src 'lan'
option dest 'wan'
config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'
config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'
config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'
config rule
option name 'Allow-IPSec-ESP'
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'
config rule
option name 'Allow-ISAKMP'
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT'
config rule
option name 'Support-UDP-Traceroute'
option src 'wan'
option dest_port '33434:33689'
option proto 'udp'
option family 'ipv4'
option target 'REJECT'
option enabled 'false'
config include
option path '/etc/firewall.user'
config zone 'vpnzone'
option name 'VPN'
option forward 'REJECT'
option output 'ACCEPT'
option network 'VPN'
option input 'REJECT'
option masq '1'
option mtu_fix '1'
config forwarding 'vpnforward'
option dest 'VPN'
option src 'lan'
config zone 'vpnzones'
option name 'VPNS'
option forward 'REJECT'
option output 'ACCEPT'
option network 'VPNS'
option input 'ACCEPT'
option masq '1'
option mtu_fix '1'
config forwarding 'vpnforwards'
option dest 'VPNS'
option src 'lan'
config zone 'wgzone'
option name 'wg'
option forward 'ACCEPT'
option output 'ACCEPT'
option network 'wg0 wg1'
option input 'ACCEPT'
option masq '1'
option mtu_fix '1'