YAMon3: Getting # Warning: iptables-legacy tables present, use iptables-legacy to see them

|Model|Linksys WRT3200ACM|
|Architecture|ARMv7 Processor rev 1 (v7l)|
|Target Platform|mvebu/cortexa9|
|Firmware Version|OpenWrt 22.03.2 r19803-9a599fee93 / LuCI openwrt-22.03 branch git-22.288.45147-96ec0cd|

When starting YAMon3, I keep getting this:

Warning: iptables-legacy tables present, use iptables-legacy to see them

and YAMon doens't work correctly. I saw some posts about uninstalling all the iptable software and reinstalling only iptables-nft, but that didn't work either. Any ideas? I couldn't seem to find any solutions via search.

Package name Version Size (.ipk) Description
iptables-mod-ipopt 1.8.7-7 ~13.0 KB iptables extensions for matching/changing IP packet options.…
iptables-nft 1.8.7-7 ~1.1 KB Extra iptables nftables nft binaries.…
kmod-nf-ipt 5.10.146-1 ~19.5 KB Iptables core

Here is the software I have regarding iptables. I had this running just fine on my Asus RT-AC88U.

It can "probably" be made to work with the correct ipt-nft modules, but this should really be fixed upstream.
Have you tried tracking down the maintainers and asking?

For now though, IF it is possible to get it working you will have to carefully check for "legacy modules".

Try doing opkg list-installed | grep legacy

If it shows any legacy modules, these will have to be uninstalled and replaced with the nft versions.

There is no legacy software installed. Looks like it doesn't work with YAMon 4 either. Hmm, I'll try the YAMon help email.