Xiaomi WiFi Router 3G

For me, there is no difference in “did not acknowledge authentication response” with r5117

I updated to r5117-fbde9ac (Oct 20 build) and the "did not acknowledge authentication response" issue still reproducing, but after some reties I'm able to connect to the 2.4GHz.

Sorry now I have only 150 Mbps clients
https://s1.postimg.org/2fb33dqhi7/mir3g.png

@MaFL2k @dror
I can not reproduce the problem anymore, tested with:
Samsung Tab A 10.1 2016
Honor 6X (Two devices)
Moto G4
Lenovo ideapad 700-15ISK
Samsung Tab A 7 2016
Samsung J3 2015
Apple iPad 3
Amazon Kindle

Are you using some particular configuration?
This is mine

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11g'
	option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '4'
	option htmode 'HT40'
	option country '00'
	option noscan '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'LEDE'
	option encryption 'psk2+ccmp'
	option key 'mypassword'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '36'
	option hwmode '11a'
	option path 'pci0000:00/0000:00:01.0/0000:02:00.0'
	option htmode 'VHT80'
	option country '00'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option network 'lan'
	option mode 'ap'
	option encryption 'psk2+ccmp'
	option key 'mypassword'
	option ssid 'LEDE 5GHz'

Reach with my devices expected values....

in 2.4 GHz Network (N-Draft) ---> *-ac devices accting in 5 GHz Network

Force Option Scan CH06

On Client Side:

2_4 Ghz Connected

Full Stat- Window:

LEDE   Overview   LuCI all

What's the use of fullscreen screenshots that nobody can read?

Open image in another tab and you can read everything

1 Like

Hi @craz, comparing to your setting I have the addition configurations:

config wifi-device 'radio0'
        option distance '15'
        option country 'IL'

config wifi-iface 'default_radio0'
        option disassoc_low_ack '0'
        option wpa_group_rekey '1800'

I'll try to match my configurations with yours and hopefully that will finally solve the issue.

Hi @dror,
I used
option disassoc_low_ack '0'
for a long time without any problems but with option
option wpa_group_rekey '1800'
I had problems, many clients after 30" stay connected but without internet/lan.
With this option I had the same problem also with wrt1200ac.
Sorry for my bad english :roll_eyes:

I have a problem with connecting the Samsung J7 2016 (Android 7.0)
The smartphone connects to 2.4GHz without any problems, but after a while, after the smartphone sleep loses access to the Internet (status "Internet may not be avaliable"), but the wifi remains active.
helps only for 2.4GHz switch "N" mode in router config to "Legacy" mode.

@craz + @w2w

Please try with default settings / options "first" - flash Firmware without keep settings - set up your WiFi / Network - connect Your devices - Test!

In my Environment most of the devices will connect without to touch them.... :slight_smile:

LEDE   Overview   LuCI 20171025 v3

1 Like

Some Benchmarks with a current Lenovo Thinkpad T470 [Windows 10 5GHz only]:

Lenovo ThinkPad T470 | Intel Dual Band Wireless-AC 8265

[  5] 118.00-119.01 sec  26.2 MBytes   219 Mbits/sec                  
[  5] 119.01-120.00 sec  26.8 MBytes   225 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec  3.12 GBytes   223 Mbits/sec                  sender
[  5]   0.00-120.00 sec  3.12 GBytes   223 Mbits/sec                  receiver

iperf Done.

Lenovo ThinkPad T470 | netis WF2190 (Realtek 8812AU) | USB3.0

[  5] 118.00-119.00 sec  22.6 MBytes   190 Mbits/sec
[  5] 119.00-120.01 sec  26.5 MBytes   221 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.01 sec  2.90 GBytes   208 Mbits/sec                  sender
[  5]   0.00-120.01 sec  2.90 GBytes   208 Mbits/sec                  receiver

iperf Done.


Lenovo ThinkPad T470 | TP-Link Archer T1U (V1) | | USB3.0

[  5] 118.00-119.01 sec  11.6 MBytes  96.9 Mbits/sec                  
[  5] 119.01-120.00 sec  11.9 MBytes  99.9 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec  1.14 GBytes  81.4 Mbits/sec                  sender
[  5]   0.00-120.00 sec  1.14 GBytes  81.4 Mbits/sec                  receiver

iperf Done.

Wifi Roter 3G - 03

Wifi Roter 3G - 01

Wifi Roter 3G - 02

Setup:

opkg update
opkg install luci-ssl
opkg install luci-app-nlbwmon
opkg install iperf3

/etc/init.d/uhttpd start
/etc/init.d/uhttpd enable

1 Like

Some Benchmarks with a current Lenovo ThinkPad T470 [Windows 10 2,4 GHz only]:

Lenovo ThinkPad T470 | Intel Dual Band Wireless-AC 8265 @2,4 GHz [20 MHz]

[  5] 118.00-119.00 sec  9.12 MBytes  76.6 Mbits/sec                  
[  5] 119.00-120.00 sec  9.50 MBytes  79.5 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec  1.34 GBytes  95.9 Mbits/sec                  sender
[  5]   0.00-120.00 sec  1.34 GBytes  95.9 Mbits/sec                  receiver

iperf Done.

Lenovo ThinkPad T470 | netis WF2190 (Realtek 8812AU) @2,4 GHz [20 MHz]

[  5] 118.01-119.00 sec  10.5 MBytes  88.3 Mbits/sec                  
[  5] 119.00-120.00 sec  10.5 MBytes  88.2 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec  1.18 GBytes  84.2 Mbits/sec                  sender
[  5]   0.00-120.00 sec  1.18 GBytes  84.2 Mbits/sec                  receiver

iperf Done.


Lenovo ThinkPad T470 | 150 Mbits USB2.0 Stick (Ralink rt2870) @2,4 GHz [20 MHz]

[  5] 118.01-119.00 sec  6.38 MBytes  53.9 Mbits/sec                  
[  5] 119.00-120.00 sec  6.25 MBytes  52.3 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec   763 MBytes  53.3 Mbits/sec                  sender
[  5]   0.00-120.00 sec   763 MBytes  53.3 Mbits/sec                  receiver

iperf Done.


Lenovo ThinkPad T470 | USB WiFi Adapter Dongle RT5370 aka Elite ;) @2,4 GHz [20 MHz]

[  5] 118.00-119.00 sec  6.50 MBytes  54.6 Mbits/sec                  
[  5] 119.00-120.00 sec  6.50 MBytes  54.5 Mbits/sec                  
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  5]   0.00-120.00 sec   764 MBytes  53.4 Mbits/sec                  sender
[  5]   0.00-120.00 sec   764 MBytes  53.4 Mbits/sec                  receiver

iperf Done.
1 Like

Hi,
I tested LEDE snapshot on my R3G, and it seams that there is an issue with the integrated switch and VLAN support.
After some search, I found the same issue on a post about D-Link DIR-860L (which use MT7621) : https://forum.openwrt.org/t/mt7621-dir-860l-does-not-support-vlans/1714
And the workaround is the same for the Xiaomi : VLANs need to be incremented to work fine (if you want to use VLAN 1 and 3, you need to add VLAN 1, 2 and 3).
I don't see any patch for this issue, do you think that could be corrected in future release ?

Only pending patch for MT7621 is one to improve stability
https://patchwork.ozlabs.org/patch/808121/

just installed the latest snapshot of LEDE on my miwifi R3G and i confirm that when the wifi 2.4Ghz Chanel is set to AUTO it doesn't work. you have to set it manualy to any number to get it to work.

Thanks for the tips.

Does anyone know where to find this mediatek Openwrt version that we can see in this video @ 2:27 ?

is this an optimised version of Openwrt ?

That is "stock" firmware of that router.
ZBT uses OpenWRT 14.07

1 Like

Hello everyone,
I just got two of these awesome devices and easily managed to flash snapshot r5217, which does seem to work fine beside some small issues (I did not do any extensive testing, btw).

While you may be ok with the stock U-Boot, I was wondering if it would be possible to port a newer version or to add useful features like mtd or a web interface like pepe2k's u-boot_mod for ar9331.
Since U-Boot is GPL2-licensed, should we expect Xiaomi to release the source or do they believe in open source as much as Mediatek does?
The other option would be to grab everything (datasheets, u-boot sources for other mt7621 boards, etc) I can find online and try to make something out of that.

I also need to sort out JTAG connections if there are any (like test pads or on passive components) but after a first look at the board they do not seem to be there...
An alternative would be to install an SPI flash in the unpopulated layout, and put a backup bootloader in it in case we need to restore the NAND... If Xiaomi decided to even put the layout there, there must be a way to make it work.

I am a programmer and embedded electronics enthusiast myself but I haven't really ever dived into this kind of system programming and/or hardware reverse engineering, so any recommendation or advice is appreciated.

Thank you guys

Hi,
I'm looking for the best router for LEDE, to use it as a all-time-online linux box for file sharing, bittorrent, etc..
Is this the best I can find for under 100$ ?
it's 50$ on aliexpress/ebay.
It don't seems fully supported right now but I think it will be, it's a best seller on those websites.

Right now, this is not the best choice... It's still in the works and it's based on the mt76 wifi driver which is not yet production-ready (AFAIK, I don't really have an extensive experience with this driver).

You could look in these two sticky topics: