Xiaomi WiFi Router 3G

Did you wait after switching to the higher channels because of DFS? But >52 is already in the DFS range......

Does anybody have tried OpenVPN client? Is the crypto engine working? I'm interested in this little fella for a project but OpenVPN speeds must reach at least 60mbit/s (router in client mode). Thanks.

I've tried openvpn in Padavan and Lede, and I've just started trying Pandorabox. I ran tests using BF-CBC and AES-128-CBC encryption. Speeds range from 25 Mbps to 30 Mbps, down from my top speed of 50 Mpbs.

The best combination I managed was around 37-40 Mbps in Padavan with hardware NAT, and BF-CBC.

Padavan does not have hardware encryption, at least in the current Prometheus version that I am aware of, and I haven't tried with Lede yet.

I found out Pandorabox, which is also part of the Openwrt "family", comes with the encryption packages already installed. I haven't managed to get any noticeably improved speeds however. In the luci webui there is a section under "Network/Hardware Acceleration" referring to "Hardware Crypto" with the text "This section contains no values yet", so development of this seems to be planned for future releases.

Personally I think one approach to optimisation would be, if openvpn cannot use more than one thread, to allocate openvpn it's own dedicated thread separate from the rest of the system.

Indeed, router advertise 40Mhz 2.4G connection if I switch country TR and select channel 13 with 40Mhz
I can see it's 40 mhz wide signal when I check it by my phone. But phone just connects with 20Mhz. This might be related with my phone. Check it with your devices.

For 5Ghz band, after little wait, it became active for channels >52. It just takes little longer than <52 channels for activation.

1 Like

This is not a phone, I have the same thing. Use the Padavan firmware.


This is a standard behavior to prevent from violation of the IEEE 802.11-2012 specification.

Please have a look (at) smallnetbuilder.com | Bye Bye 40 MHz Mode in 2.4 GHz

Imagine every user would pimp / modifiy they Routers in such an evironment (for example via tl-wr841nd#dbm_tx_power_hack_v9) :wink:


friends, how should proceed to return to firmware stock having LEDE installed ?

I used this method of installation:
In SSH console
cd /extdisks/sda1 (can be different if you remove and reinsert the usb stick)
mtd write lede-ramips-mt7621-mir3g-squashfs-kernel1.bin kernel1
mtd write lede-ramips-mt7621-mir3g-squashfs-rootfs0.bin rootfs0
nvram set flag_last_success=1
nvram commit

What do I need to get back to stock?

I´m in the same boat. Got LEDE running but want to go back to stock (and then try padavan).
But putting the miwifi.bin on a usb drive and pressing the reset button does only put the router in recovery mode but does not flash the sock firmware.

Anyone got any suggestions?



it would suffice to just change that line on the SSH terminal ?

nvram set flag_last_success=0
nvram commit

and put stock firmware on usb ?

Should be enough if you use a build that is after this commit

thank you for your attention
I'll take the test soon.

I'm testing LEDE SNAPSHOT r5107 and I no longer have the problem with “did not acknowledge authentication response” :smiley:

A great thank you to all for the great work.

I have only a small display bug

Wifi works perfectly and even the LEDs work fine, I set the led status to flash red with wan activity.

Most likely that is due to bumped mt76 driver

Seriously, does it work well? And what about the width of the channel 40Mhz?

You have a screenshot of 61mbit / s. Very funny.

Has anyone tested Samba or USB hard drive performance? According to mediatek 2013 roadmap the MT7621A can do 72MB/sec read and 29MB/sec write to FAT32 over samba but it appears to have a hardware "storage accelerator"

Certainly there are 13 connected android clients far away from router to test the problem.

If use 'option noscan 1' (40 MHz) I can get also 170 Mbps, always away from the router.

I think so...

I do not believe. Show me this.