Xiaomi WiFi Router 3G

Hi guys!

I updated my feeds yesterday. and transmission don't resume torrents after restart always rechek it. Do you know why? i didn't find anything. I tried to remove resume files, recheck everything but no success. I also had this problem with transmission 2.92-git4 version. git5 version worked, but now i'm stucked with this bug again on 2.93-git6 (transmission-daemon 2.93 (3c5870d4f5)) (openssl,embedtls version doesn't matter)

Latest Master with HW offloading..

uci set firewall.@defaults[0].flow_offloading=1
uci set firewall.@defaults[0].flow_offloading_hw=1
uci commit
/etc/init.d/firewall restart

to enable cpu on 100mbit goes from 20% down to 1%

Updated new build with O3 - try this out headless...

:dizzy_face: :crazy_face:

Can you test the hdd corruption? It's not clear for me it's solved or not. I build my images with gcc7.3, binutils 2.30, O3 optimization and march=1004kc. But with 4.4 kernel. I'd change the kernel to 4.14 if it's working. Or at least did you flash succesfully 4.14 with O3?

current build is O2.. but if i recall correctly i had a build with O3 recently and booted ok.. Yep compile with O3... works same

it's NOT completely true, sry. I'm just over a brick :slight_smile: if you compile the kernel with O3 flag and exceed 2 mb size then it won't boot
@dissent1 I tried to boot the kernel with uboot command prompt but no luck

nand read 0x88000000 offset_on_flash read_size
bootm 0x88000000 

and i'm not completetly read that part but maybe i've seen that the original kernel size was 3.2 mb so it shouldn't be a size problem, maybe a wrong compressing?

i just issued these commands in u-boot command prompt (4 option)

setenv flag_try_sys2_failed 1

the last one is just to check, then reboot after that i just insert a flashdrive with miwifi.bin and press reset.

You should insert address of a kernel partition here and its size

Try this way

nand read 0x88000000 0xbc600000 0x400000
bootm 0x88000000 

if it doesn't help then try this

nand read 0x88000000 0x600000 0x400000
bootm 0x88000000

I'm not sure how uboot represents nand ranges that's why 2 options

Ahh i put back the router to the original position maybe later, but not today. But if it boots then we can do about it something?

For anyone having trouble to use http://d.miwifi.com/rom/ssh?userId=1800000000 and the resulting download links (like http://d.miwifi.com/rom/ssh/download?sn=10000%2F30000000&userId=1800000000 as the server seems down: I was able to receive the miwifi_ssh.bin by manually setting it to https

Hello! When connecting an HDD wia adapter SATA - usb3 chipset JMicron USA Technology Corp. JMS567 SATA 6Gb/s bridge, error:

[ 144.320647] usb 2-1: new SuperSpeed USB device number 2 using xhci-mtk
[  144.355293] scsi host0: uas
[  144.359431] xhci-mtk 1e1c0000.xhci: ERROR Transfer event for disabled endpoint or incorrect stream ring
[  144.368816] xhci-mtk 1e1c0000.xhci: @000000000f7a7170 0e667000 00000000 05000000 01058001
[  144.376964] xhci-mtk 1e1c0000.xhci: ERROR Transfer event for disabled endpoint or incorrect stream ring
[  144.386316] xhci-mtk 1e1c0000.xhci: @000000000f7a7180 0e667100 00000000 05000000 01078001
[  165.670530] scsi 0:0:0:0: tag#0 uas_eh_abort_handler 0 uas-tag 1 inflight: CMD IN 
[  165.678094] scsi 0:0:0:0: tag#0 CDB: opcode=0x12 12 00 00 00 24 00
[  166.720471] scsi host0: uas_eh_bus_reset_handler FAILED to get lock err -16
[  166.727424] scsi 0:0:0:0: Device offlined - not ready after error recovery

On stock firmware it working good

Guys, any success with kernel 4.14? Can anyone share a configuration file to build the firmware?

I'm new to the Forum and I think I have bricked my Router.
I used the Installation Guide from dissent1 on the top of the Thread.
But after flashing I cant connect to the router with ssh/telnet or the Web Page. The LED is constantly Orange and Reverting to stock isn't working as well. I did not delete the Kernel 0. Bevor installing LEDE I had Padavan installed but I reverted back to Stock to install LEDE. Hope anyone has an idea on how to get my Router working again. :slight_smile:

Downloaded the Binaries from https://downloads.lede-project.org/snapshots/targets/ramips/mt7621/

I do not recomend it if you want to use your router as a NAS, because i can confirm it still has the hdd corruption bug. It is far better (3 days and 4 hours for the first one) then 4.9 but it has.

@nbd i built it from your stagging dir. I couldn't build ntfs-3g package. Gcc7.3, binutils 2.29.1, O3 optimalization. I go back to the good old 4.4 but i was curious about the hw offload. It is not ready to work as a NAS.Could we give you some log to help you to solve this problem? kernel log or something else? kernel log there is a stack trace for mt7603 also. And a lot of Data buffer not 16 bytes aligned:

Why is there no stable release of Openwrt? I have been using padavan but it have old transmission and Aria 2 do not work at all. I want to move to openwrt asap

Does the Entware in the Openwrt require to change file system of USB( Hardisk) or does it work with normal NTFS and install packages?

Should I replace my current padavan rom with lastest openwrt snapshot of this rom? Is it worth it comparing both and is there any issue of keeping hardisk attached to it all the time if I am using Entware with some packages
P.S I kept the range of 2.4 Ghz as low on stock ROM and then flashed Padavan( I thought it will reset eveything) but the range is still low

It was weird that was not a youtube video covering the router 3g in english, so i made one https://www.youtube.com/watch?v=L2dAQ9fGZ_Y

I did experiment with a way to install openwrt that i believe nobody else tried before

lol dude I just saw your video and came here, well I am kinda bot in these things so I need to know how to turn my router with padavan to openwrt and does the openwrt need usb drive to be other than NTFS

Windows .cmd file :

for /f %%i in ("openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin") do ( set /a size = 4194304 - %%~zi >nul )
fsutil file createnew dummy.bin %size% >nul
copy /y /b openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin + /b dummy.bin + /b openwrt-ramips-mt7621-mir3g-squashfs-rootfs0.bin firmware.bin >nul
del dummy.bin

Upload the resulting file into the router and flash it

mtd_write write /tmp/firmware.bin Firmware_Stub

Can you please elaborate a little like how it will work